aboutsummaryrefslogtreecommitdiffstats
path: root/editors/jext/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-03-06 21:11:32 +0800
committersobomax <sobomax@FreeBSD.org>2002-03-06 21:11:32 +0800
commit17576c2d6b245cce02112813b9269a9bc878b9cd (patch)
treefe16c587fd9b8a61571e9afc3b5c9c9687f9fc4f /editors/jext/Makefile
parent541b15f0e4ec1a27eba440e021a34e30e00eb6bd (diff)
downloadfreebsd-ports-graphics-17576c2d6b245cce02112813b9269a9bc878b9cd.tar.gz
freebsd-ports-graphics-17576c2d6b245cce02112813b9269a9bc878b9cd.tar.zst
freebsd-ports-graphics-17576c2d6b245cce02112813b9269a9bc878b9cd.zip
Pre-compile python objects, so that package deinstalls cleanly.
Diffstat (limited to 'editors/jext/Makefile')
-rw-r--r--editors/jext/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/editors/jext/Makefile b/editors/jext/Makefile
index a654cedd1b1..0b03c485d92 100644
--- a/editors/jext/Makefile
+++ b/editors/jext/Makefile
@@ -7,6 +7,7 @@
PORTNAME= jext
PORTVERSION= 3.0.2
+PORTREVISION= 1
CATEGORIES= editors java
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= jext
@@ -34,11 +35,13 @@ do-install:
@(cd ${WRKSRC} && ${TAR} -c -f - Jython-LICENSE LICENSE README \
History.txt Names.txt bin lib) | \
(cd ${INSTSBDR} && ${TAR} --unlink -x -f -)
+ @CLASSPATH=${INSTSBDR}/lib/jython.jar javavm org.python.util.jython \
+ ${INSTSBDR}/lib/Lib/compileall.py ${INSTSBDR}
post-install:
- @${ECHO_MSG} "--------------------------------------------------------------------------------"
+ @${ECHO_MSG} "-------------------------------------------------------------------------------"
@${ECHO_MSG} " Please note that Java2 platform (jdk/jre-1.2.x or later) is required to run"
@${ECHO_MSG} " this program."
- @${ECHO_MSG} "--------------------------------------------------------------------------------"
+ @${ECHO_MSG} "-------------------------------------------------------------------------------"
.include <bsd.port.mk>