aboutsummaryrefslogtreecommitdiffstats
path: root/editors/mule-common
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1999-03-08 15:28:36 +0800
committerasami <asami@FreeBSD.org>1999-03-08 15:28:36 +0800
commit04f6beab8f8083412efad3eadf4e32bffa85bbe2 (patch)
tree907e6a967f7d00919c4dc13b6a581739f386e7ef /editors/mule-common
parent755e63021c52f5292b5284c5d10c05274df15811 (diff)
downloadfreebsd-ports-graphics-04f6beab8f8083412efad3eadf4e32bffa85bbe2.tar.gz
freebsd-ports-graphics-04f6beab8f8083412efad3eadf4e32bffa85bbe2.tar.zst
freebsd-ports-graphics-04f6beab8f8083412efad3eadf4e32bffa85bbe2.zip
Fix to make ports work with bsd.port.mk rev. 1.306.
${MACHINE_ARCH}--freebsd${OSREL} is now passed to CONFIGURE_ARGS if GNU_CONFIGURE is defined. Take the target out of CONFIGURE_ARGS of some ports that added it explicitly; define it as ${MACHINE_ARCH}--freebsd if the port doesn't like the ${OSREL} part; define it as something else (such as ${MACHINE_ARCH}--freebsdelf if the port requires that; define it as an empty string if the port doesn't like it at all. The last might be a sign that a GNU_CONFIGURE port actually doesn't use GNU's version of configure at all; but I don't have time to go look at them all, we'll fix them as time goes on. At least we've got much fewer "-unknown-"s in the tree as the result. :)
Diffstat (limited to 'editors/mule-common')
-rw-r--r--editors/mule-common/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/editors/mule-common/Makefile b/editors/mule-common/Makefile
index 160d605236b..246c35f0011 100644
--- a/editors/mule-common/Makefile
+++ b/editors/mule-common/Makefile
@@ -3,7 +3,7 @@
# Date created: 7 July 1997
# Whom: Satoshi Taoka <taoka@infonets.hiroshima-u.ac.jp>
#
-# $Id: Makefile,v 1.36 1999/01/23 14:28:27 simokawa Exp $
+# $Id: Makefile,v 1.37 1999/02/03 11:11:42 asami Exp $
#
DISTNAME= mule-2.3
@@ -58,15 +58,15 @@ BROKEN= You should build install one of the other mule ports first
INSTALL_COOKIE= ${WRKDIR}/.install_done-${PKGNAME}
PACKAGE_COOKIE= ${WRKDIR}/.package_done-${PKGNAME}
TMPPLIST= ${WRKDIR}/.PLIST.mktmp-${PKGNAME}
-EMACS_ARCH= ${MACHINE_ARCH}--freebsd
-PLIST_SUB= EMACS_VERSION=19.34 EMACS_ARCH=${EMACS_ARCH}
+CONFIGURE_TARGET= ${MACHINE_ARCH}--freebsd
+PLIST_SUB= EMACS_VERSION=19.34 EMACS_ARCH=${CONFIGURE_TARGET}
USE_XLIB= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
EMACS_PREFIX= mule
EMACS_EXECUTABLE = mule
-CONFIGURE_ARGS= ${EMACS_ARCH} --with-executable=${EMACS_EXECUTABLE} \
+CONFIGURE_ARGS= --with-executable=${EMACS_EXECUTABLE} \
--with-emacs-prefix=${EMACS_PREFIX} \
--with-terminal-face \
--x-includes=${X11BASE}/include --x-libraries=${X11BASE}/lib
LAGS)amdmi32011-09-241-2/+2 * - Remove --enable-polkit configure option, that doesn't exists anymoremezz2011-06-052-16/+6 * Sync to new bsd.autotools.mkade2010-12-041-1/+1 * Correct a typo when running gio-querymodules.marcus2010-11-271-1/+1 * Presenting GNOME 2.32.1 for FreeBSD. The offical release notes for thiskwm2010-11-204-72/+108 * Bump PORTREVISION in a few more ports affected by the libgcryptolgeni2010-07-281-1/+1 * Presenting GNOME 2.30.2. for FreeBSD.kwm2010-07-262-6/+6 * Chase libical update.kwm2010-05-231-1/+1 * Presenting GNOME 2.30.1 for FreeBSD. The offical release notes for thiskwm2010-05-115-125/+32 * - update to 1.4.1dinoex2010-03-281-1/+1 * - update to jpeg-8dinoex2010-02-051-1/+1 * - Add support to python2.6 in configure scriptgahr2010-01-071-6/+15 * Allow a BATCH build of gnome-panel to be done without Evo support.marcus2009-12-201-1/+1 * Presenting GNOME 2.28.1 for FreeBSD. The official release notes for thismarcus2009-11-297-186/+146 * -Repocopy devel/libtool15 -> libtool22 and libltdl15 -> libltdl22.mezz2009-08-031-1/+1 * - bump all port that indirectly depends on libjpeg and have not yet been bump...dinoex2009-07-311-1/+1 * Update to 2.26.3.avl2009-07-033-4/+10 * Update to 2.26.2.kwm2009-05-213-59/+5 * Presenting GNOME 2.26.1 for FreeBSD.kwm2009-04-243-5/+11 * Presenting GNOME 2.26 for FreeBSD. Seemarcus2009-04-103-24/+70 * Update to 2.24.3.marcus2009-01-133-4/+7 * Presenting GNOME 2.24 for FreeBSD.marcus2009-01-106-338/+76 * - Remove conditional checks for FreeBSD 5.x and olderwxs2009-01-061-6/+0 * Bump portrevision due to upgrade of devel/gettext.edwin2008-06-061-1/+1 * Update to 2.22.2.mezz2008-05-273-6/+8 * Update to 2.22.1.3.marcus2008-04-204-60/+18 * - Remove unneeded dependency from gtk12/gtk20 [1]miwi2008-04-201-2/+1 * Update to 2.22.1.1ahze2008-04-082-4/+4 * Update to 2.22.1.marcus2008-04-086-60/+22 * Fix the crash by clock-applet when add to the panel. Bump the PORTREVISION.mezz2008-04-062-1/+23 * Fix fetch of x11/gnome-panel-referenceahze2008-03-251-0/+1 * The FreeBSD GNOME team is proud to annunce the release of GNOME 2.22.0 formarcus2008-03-249-31/+426 * Update to 2.20.3.marcus2008-01-082-4/+4 * Update to 2.20.2.mezz2007-12-123-5/+11 * Presenting GNOME 2.20.1 and all related works for FreeBSD. The officialmarcus2007-10-255-201/+199 * Retire obsolete PARALLEL_PACKAGE_BUILD in favour of PACKAGE_BUILDING.kris2007-07-301-1/+1 * -Update to 2.18.3.mezz2007-07-042-7/+5 * Update to 2.18.2.mezz2007-05-293-9/+10 * - Welcome X.org 7.2 \o/.flz2007-05-202-39/+1 * Update to 2.18.1bland2007-04-113-5/+8 * Presenting GNOME 2.18 for FreeBSD. GNOME 2.18 is a departure from recent GNOMEmarcus2007-03-193-6/+46 * Update to 2.16.3.mezz2007-01-303-28/+4 * Update to 2.16.2ahze2006-11-212-4/+4 * I don't want evolution-data-server to be loaded whenever I click onjylefort2006-11-061-1/+3 * Presenting GNOME 2.16.1 for FreeBSD. This release represents a massivemarcus2006-10-145-176/+133 * - Update to 2.14.3ahze2006-08-01