aboutsummaryrefslogtreecommitdiffstats
path: root/editors/mule
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1997-05-21 15:24:28 +0800
committerasami <asami@FreeBSD.org>1997-05-21 15:24:28 +0800
commit0415628de3e76ed04a5338ad662a8c7f3fcd59ef (patch)
treec44fb1e5939f502e7d43d80e81f1bf9e12021566 /editors/mule
parent65db136f245e6e8469b4fea575c8825b452d8e4e (diff)
downloadfreebsd-ports-graphics-0415628de3e76ed04a5338ad662a8c7f3fcd59ef.tar.gz
freebsd-ports-graphics-0415628de3e76ed04a5338ad662a8c7f3fcd59ef.tar.zst
freebsd-ports-graphics-0415628de3e76ed04a5338ad662a8c7f3fcd59ef.zip
Make the mule ports use install-info. Note that our makeinfo can't
handle sources with Japanese characters, so the dir entries for those are given explicitly in Makefile and pkg/PLIST.
Diffstat (limited to 'editors/mule')
-rw-r--r--editors/mule/Makefile23
-rw-r--r--editors/mule/pkg-plist24
2 files changed, 39 insertions, 8 deletions
diff --git a/editors/mule/Makefile b/editors/mule/Makefile
index 9dd12c31984..16fe44a0de7 100644
--- a/editors/mule/Makefile
+++ b/editors/mule/Makefile
@@ -3,7 +3,7 @@
# Date created: 22 November 1994
# Whom: Satoshi Asami (asami)
#
-# $Id: Makefile,v 1.25 1996/11/17 07:01:29 obrien Exp $
+# $Id: Makefile,v 1.26 1996/11/30 10:13:15 asami Exp $
#
DISTNAME= mule-2.3
@@ -28,11 +28,20 @@ pre-build:
post-install:
# note that any2ps is a script
- strip ${PREFIX}/bin/b2m
- strip ${PREFIX}/bin/coco
- strip ${PREFIX}/bin/ctags
- strip ${PREFIX}/bin/etags
- strip ${PREFIX}/bin/m2ps
- strip ${PREFIX}/bin/mule-19.28
+.for file in b2m coco ctags etags m2ps mule-19.28
+ strip ${PREFIX}/bin/${file}
+.endfor
+ if [ ! -f ${PREFIX}/info/dir ]; then \
+ sed -ne '1,/Menu:/p' /usr/share/info/dir > ${PREFIX}/info/dir; \
+ fi
+.for info in emacs vip forms gnus cl sc
+ install-info ${PREFIX}/info/${info} ${PREFIX}/info/dir
+.endfor
+# Our makeinfo can't handle files with Japanese characters. :<
+ install-info --section="The Emacs editor and associated tools" --entry="* Antenews-jp: (antenews-jp). Version 19 Antenews. (Japanese)" ${PREFIX}/info/antenews-jp ${PREFIX}/info/dir
+ install-info --section="The Emacs editor and associated tools" --entry="* Mule: (mule). Multilingual Enhancement to GNU Emacs." ${PREFIX}/info/mule ${PREFIX}/info/dir
+ install-info --section="The Emacs editor and associated tools" --entry="* Mule-jp: (mule-jp). Multilingual Enhancement to GNU Emacs. (Japanese)" ${PREFIX}/info/mule-jp ${PREFIX}/info/dir
+ install-info --section="The Emacs editor and associated tools" --entry="* Egg-jp: (egg-jp). Japanese/Chinese Inputting Method. (Japanese)" ${PREFIX}/info/egg-jp ${PREFIX}/info/dir
+ install-info --section="The Emacs editor and associated tools" --entry="* Canna-jp: (canna-jp). Another Japanese Inputting Method. (Japanese)" ${PREFIX}/info/canna-jp ${PREFIX}/info/dir
.include <bsd.port.mk>
diff --git a/editors/mule/pkg-plist b/editors/mule/pkg-plist
index 9824f538030..99afff216d5 100644
--- a/editors/mule/pkg-plist
+++ b/editors/mule/pkg-plist
@@ -19,6 +19,17 @@ man/man1/ctags.1.gz
man/man1/etags.1.gz
man/man1/m2ps.1.gz
man/man1/mule.1.gz
+@unexec install-info --delete %D/info/emacs %D/info/dir
+@unexec install-info --delete %D/info/vip %D/info/dir
+@unexec install-info --delete %D/info/forms %D/info/dir
+@unexec install-info --delete %D/info/gnus %D/info/dir
+@unexec install-info --delete %D/info/cl %D/info/dir
+@unexec install-info --delete %D/info/sc %D/info/dir
+@unexec install-info --delete --section="The Emacs editor and associated tools" --entry="* Antenews-jp: (antenews-jp). Version 19 Antenews. (Japanese)" %D/info/antenews-jp %D/info/dir
+@unexec install-info --delete --section="The Emacs editor and associated tools" --entry="* Mule: (mule). Multilingual Enhancement to GNU Emacs." %D/info/mule %D/info/dir
+@unexec install-info --delete --section="The Emacs editor and associated tools" --entry="* Mule-jp: (mule-jp). Multilingual Enhancement to GNU Emacs. (Japanese)" %D/info/mule-jp %D/info/dir
+@unexec install-info --delete --section="The Emacs editor and associated tools" --entry="* Egg-jp: (egg-jp). Japanese/Chinese Inputting Method. (Japanese)" %D/info/egg-jp %D/info/dir
+@unexec install-info --delete --section="The Emacs editor and associated tools" --entry="* Canna-jp: (canna-jp). Another Japanese Inputting Method. (Japanese)" %D/info/canna-jp %D/info/dir
@comment
@comment emacs stuff
@comment
@@ -60,7 +71,6 @@ info/gnus
info/gnus-1
info/gnus-2
info/gnus-3
-info/info
info/sc
info/sc-1
info/sc-2
@@ -91,6 +101,18 @@ info/mule-jp-2
info/mule-jp-3
info/quail
info/terminology
+@exec [ -f %D/info/dir ] || sed -ne '1,/Menu:/p' /usr/share/info/dir > %D/info/dir
+@exec install-info %D/info/emacs %D/info/dir
+@exec install-info %D/info/vip %D/info/dir
+@exec install-info %D/info/forms %D/info/dir
+@exec install-info %D/info/gnus %D/info/dir
+@exec install-info %D/info/cl %D/info/dir
+@exec install-info %D/info/sc %D/info/dir
+@exec install-info --section="The Emacs editor and associated tools" --entry="* Antenews-jp: (antenews-jp). Version 19 Antenews. (Japanese)" %D/info/antenews-jp %D/info/dir
+@exec install-info --section="The Emacs editor and associated tools" --entry="* Mule: (mule). Multilingual Enhancement to GNU Emacs." %D/info/mule %D/info/dir
+@exec install-info --section="The Emacs editor and associated tools" --entry="* Mule-jp: (mule-jp). Multilingual Enhancement to GNU Emacs. (Japanese)" %D/info/mule-jp %D/info/dir
+@exec install-info --section="The Emacs editor and associated tools" --entry="* Egg-jp: (egg-jp). Japanese/Chinese Inputting Method. (Japanese)" %D/info/egg-jp %D/info/dir
+@exec install-info --section="The Emacs editor and associated tools" --entry="* Canna-jp: (canna-jp). Another Japanese Inputting Method. (Japanese)" %D/info/canna-jp %D/info/dir
lib/mule/19.28/etc/3B-MAXMEM
lib/mule/19.28/etc/AIX.DUMP
lib/mule/19.28/etc/APPLE