aboutsummaryrefslogtreecommitdiffstats
path: root/editors/openoffice-devel/files/patch-unxfbsd.mk
diff options
context:
space:
mode:
authortruckman <truckman@FreeBSD.org>2015-03-17 23:04:43 +0800
committertruckman <truckman@FreeBSD.org>2015-03-17 23:04:43 +0800
commitd39899ead46f581fbcbdd651bf1dc7ad4cb0fd74 (patch)
tree01102dc7ffc4e25faffc54231b82c56ee1ecb93e /editors/openoffice-devel/files/patch-unxfbsd.mk
parent6060e8f26620c96cd16fe1b8c486f803054b3de3 (diff)
downloadfreebsd-ports-graphics-d39899ead46f581fbcbdd651bf1dc7ad4cb0fd74.tar.gz
freebsd-ports-graphics-d39899ead46f581fbcbdd651bf1dc7ad4cb0fd74.tar.zst
freebsd-ports-graphics-d39899ead46f581fbcbdd651bf1dc7ad4cb0fd74.zip
Unbreak editors/openoffice-4 and editors/openoffice-devel on systems
where clang is the base compiler. The issue was that these ports would only successfully build with gcc and libstdc++, so they specified USE_GCC=yes, but they linked to other C++ ports that were compiled with clang, which brought in libc++. The conflict between libstdc++ and libc++ caused the application to crash whenever an operation that popped up a dialog box was attempted. Thanks to dim@ for helping me track this down. The fix is to patch various bits of the openoffice souce to allow it to be built with clang on systems where the C++ dependencies are also compiled with clang. [1] Add a CUPS option so that CUPS can be disabled [2]. Register print/cups-client as a LIB_DEPENDS when CUPS is enabled. pkg-message claims that user settings are stored in ~/.openoffice,org4, whereas all other platforms seem to use ~/.openoffice.org/4 (or equivalent), and both openoffice-4 and openoffice-devel actually use ~/.openoffice.org-devel/4. The addition of -devel to the location happened with r325370. The / appears to have been introduced in r297259. Change the location match other platforms. Introduce a new variable ${AOOUDIR} so that the actual location and pkg-message stay in sync. Rename ${OOOTAG} to ${AOOTAG} and restore its value so that it can once again be substituted into pkg-message. It has not been set since r296269. Various Makefile cleanups: * Gather and sort USE_* * Simplify use of ${REINPLACE_CMD} * --x-includes and --x-libraries are automatically passed to configure, which ignores them * Get rid of unnecessary include of bsd.port.options.mk PR: 188088 [1] PR: 198458 [2] Differential Revision: https://reviews.freebsd.org/D2055 Reviewed by: pfg Approved by: mat (mentor)
Diffstat (limited to 'editors/openoffice-devel/files/patch-unxfbsd.mk')
-rw-r--r--editors/openoffice-devel/files/patch-unxfbsd.mk33
1 files changed, 26 insertions, 7 deletions
diff --git a/editors/openoffice-devel/files/patch-unxfbsd.mk b/editors/openoffice-devel/files/patch-unxfbsd.mk
index 55a15933769..ad4194f9b1e 100644
--- a/editors/openoffice-devel/files/patch-unxfbsd.mk
+++ b/editors/openoffice-devel/files/patch-unxfbsd.mk
@@ -1,13 +1,32 @@
---- solenv/inc/unxfbsd.mk~ 2012-10-31 10:39:44.000000000 +0900
-+++ solenv/inc/unxfbsd.mk 2012-10-31 17:42:59.000000000 +0900
-@@ -80,14 +80,14 @@
+--- solenv/inc/unxfbsd.mk.orig 2014-09-19 18:16:56 UTC
++++ solenv/inc/unxfbsd.mk
+@@ -27,7 +27,7 @@ ASM=
+ AFLAGS=
+
+ SOLAR_JAVA*=
+-PICSWITCH*:=-fpic
++PICSWITCH*:=-fPIC
+ JAVAFLAGSDEBUG=-g
+
+ # Include arch specific makefile.
+@@ -49,7 +49,7 @@ JAVAFLAGSDEBUG=-g
+ #LINKOUTPUT_FILTER=" |& $(SOLARENV)/bin/msg_filter"
+
+ # _PTHREADS is needed for the stl
+-CDEFS+=$(PTHREAD_CFLAGS) -D_PTHREADS -D_REENTRANT -DNEW_SOLAR -D_USE_NAMESPACE=1 -DSTLPORT_VERSION=450
++CDEFS+=$(PTHREAD_CFLAGS) -D_PTHREADS -D_REENTRANT -DNEW_SOLAR -D_USE_NAMESPACE=1 %%HAVE_STL_INCLUDE_PATH%%
+
+ # enable visibility define in "sal/types.h"
+ .IF "$(HAVE_GCC_VISIBILITY_FEATURE)" == "TRUE"
+@@ -86,14 +86,14 @@ CFLAGSENABLESYMBOLS=-g # was temporarily
.ENDIF
# flags for the C++ Compiler
-CFLAGSCC= -pipe $(ARCH_FLAGS)
+CFLAGSCC= -pipe $(ARCH_FLAGS) %%RPATH%%
# Flags for enabling exception handling
- CFLAGSEXCEPTIONS=-fexceptions -fno-enforce-eh-specs
+-CFLAGSEXCEPTIONS=-fexceptions -fno-enforce-eh-specs
++CFLAGSEXCEPTIONS=-fexceptions
# Flags for disabling exception handling
CFLAGS_NO_EXCEPTIONS=-fno-exceptions
@@ -17,9 +36,9 @@
.IF "$(HAVE_GCC_VISIBILITY_FEATURE)" == "TRUE"
CFLAGSCXX += -fvisibility-inlines-hidden
.ENDIF # "$(HAVE_GCC_VISIBILITY_FEATURE)" == "TRUE"
-@@ -145,7 +145,7 @@
- LINKFLAGSRUNPATH_OXT=
- LINKFLAGSRUNPATH_BOXT=-Wl,-z,origin -Wl,-rpath,\''$$ORIGIN/../../../basis-link/program'\'
+@@ -156,7 +156,7 @@ LINKFLAGSRUNPATH_OXT=
+ LINKFLAGSRUNPATH_BOXT=-Wl,-z,origin -Wl,-rpath,\''$$ORIGIN'\'
+ #LINKFLAGSRUNPATH_BOXT=-Wl,-z,origin -Wl,-rpath,\''$$ORIGIN/../../../basis-link/program'\'
LINKFLAGSRUNPATH_NONE=
-LINKFLAGS=-Wl,-z,combreloc $(LINKFLAGSDEFS) $(LINKFLAGS_SYSBASE)
+LINKFLAGS=-Wl,-z,combreloc %%RPATH%% $(LINKFLAGSDEFS) $(LINKFLAGS_SYSBASE)