aboutsummaryrefslogtreecommitdiffstats
path: root/editors/openoffice-devel
diff options
context:
space:
mode:
authormbr <mbr@FreeBSD.org>2003-04-27 19:58:20 +0800
committermbr <mbr@FreeBSD.org>2003-04-27 19:58:20 +0800
commitf480b4f9c5010a4302df633837dbc12c60550403 (patch)
tree44e0004a693f34cadc23cee445c4cf7fcacbb289 /editors/openoffice-devel
parent9ba2460cfa096803b3bb0f5fba59a1ffa015ee8b (diff)
downloadfreebsd-ports-graphics-f480b4f9c5010a4302df633837dbc12c60550403.tar.gz
freebsd-ports-graphics-f480b4f9c5010a4302df633837dbc12c60550403.tar.zst
freebsd-ports-graphics-f480b4f9c5010a4302df633837dbc12c60550403.zip
Move the KDE wrapper replacement a bit, and only substitute in
the perl script which creates the wrapper bits. Remove a newline in the post-patch target in the openoffice port. Add fix for gnome wrappers too.
Diffstat (limited to 'editors/openoffice-devel')
-rw-r--r--editors/openoffice-devel/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/editors/openoffice-devel/Makefile b/editors/openoffice-devel/Makefile
index 5c8daf1fae2..3792b35c715 100644
--- a/editors/openoffice-devel/Makefile
+++ b/editors/openoffice-devel/Makefile
@@ -359,6 +359,8 @@ post-extract:
post-patch:
@${MAKE} patch-mozilla
+ @${MAKE} fix-kdewrappers
+ @${MAKE} fix-gnomewrappers
.if defined(WITH_TTF_BYTECODE_ENABLED)
@if [ "`echo ${PATCHDIR}/optpatch-*`" != "${PATCHDIR}/optpatch-*" ]; then \
${ECHO_MSG} "===> Applying additional TTF bytecode patches for ${PKGNAME}" ; \
@@ -410,6 +412,14 @@ post-patch:
@${FIND} ${WRKSRC}/.. | ${EGREP} "\.(cxx|h|c)$$" | ${XARGS} \
${PERL} -pi -e "s|<malloc.h>|<stdlib.h>|g"
+fix-kdewrappers:
+ @${PERL} -pi -e 's|"Exec", "\\"\<progpath\>/program/|"Exec", "\\"${PREFIX}/bin/openoffice_${RELEASE_NR}-|' \
+ ${WRKSRC}/../sysui/oounix/office/kde2/kdeint
+
+fix-gnomewrappers:
+ @${PERL} -pi -e 's|"Exec", "<progpath>/program/|"Exec", "${PREFIX}/bin/openoffice_${RELEASE_NR}-|' \
+ ${WRKSRC}/../sysui/oounix/office/gnome/gnomeint
+
extract-mozilla:
.if ! exists(${WRKDIR}/mozilla/Makefile)
@${ECHO_MSG} "===> Extracting mozilla sub project"
@@ -524,9 +534,6 @@ pre-install:
-e 's#%%PORTVERSION%%#${BUILD_NR}#g' \
${WRKSRC}/../instsetoo/unxfbsd.pro/${LANG_EXT}/normal/oo_setup.resp
@${MKDIR} -p ${WRKSRC}/../solver/644/unxfbsd.pro/bin/${LANG_EXT}/osl/
- # fix KDE-files to use our wrapper skrips.
- @${FIND} ${WRKSRC}/../sysui/unxfbsd.pro | ${EGREP} "\.desktop$$" | ${XARGS} \
- ${PERL} -pi -e 's|Exec="\<progpath\>/program/|Exec="${PREFIX}/bin/openoffice_${RELEASE_NR}-|'
do-install:
.if !defined(DISPLAY)