aboutsummaryrefslogtreecommitdiffstats
path: root/editors/poedit
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-06-21 23:52:35 +0800
committerijliao <ijliao@FreeBSD.org>2002-06-21 23:52:35 +0800
commit41375a7fa3ba02e9cf4d8448e52eb7e6aaf3a4ed (patch)
tree9b2d8b8ded963952c33061446db191c200e97854 /editors/poedit
parentc0abd785464496b58bf62d2eee5e0dfa620721cd (diff)
downloadfreebsd-ports-graphics-41375a7fa3ba02e9cf4d8448e52eb7e6aaf3a4ed.tar.gz
freebsd-ports-graphics-41375a7fa3ba02e9cf4d8448e52eb7e6aaf3a4ed.tar.zst
freebsd-ports-graphics-41375a7fa3ba02e9cf4d8448e52eb7e6aaf3a4ed.zip
Replace ${PERL} with ${REINPLACE_CMD}
PR: 39591 Submitted by: Oliver Braun <obraun@informatik.unibw-muenchen.de>
Diffstat (limited to 'editors/poedit')
-rw-r--r--editors/poedit/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/editors/poedit/Makefile b/editors/poedit/Makefile
index a941d5a7463..cbb8d2d5322 100644
--- a/editors/poedit/Makefile
+++ b/editors/poedit/Makefile
@@ -23,6 +23,7 @@ LIB_DEPENDS= intl.2:${PORTSDIR}/devel/gettext \
db3:${PORTSDIR}/databases/db3
PATCH_DIST_ARGS= -d ${PATCH_WRKSRC} -E ${PATCH_DIST_STRIP} -p1
+USE_REINPLACE= yes
USE_X_PREFIX= yes
WANT_GNOME= yes
GNU_CONFIGURE= yes
@@ -42,10 +43,10 @@ CONFIGURE_ARGS+= --without-gnome
.endif
pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @${FIND} ${WRKSRC} -name "Makefile.in*" | ${XARGS} ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+ @${FIND} ${WRKSRC} -name "Makefile.in*" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|\$$(datadir)/gnome/|\$$(datadir)/|g ; \
+ s|\$$(datadir)/locale|\$$(prefix)/share/locale|g'
.include <bsd.port.post.mk>