aboutsummaryrefslogtreecommitdiffstats
path: root/editors/semi/Makefile
diff options
context:
space:
mode:
authorshige <shige@FreeBSD.org>2001-12-03 23:17:41 +0800
committershige <shige@FreeBSD.org>2001-12-03 23:17:41 +0800
commit5f7da7531f2c24d0ef8afb97ff520a8abdcdb8d9 (patch)
treeffab3146f48a371acdca87740da9cfa9922de270 /editors/semi/Makefile
parent166adc3a67ab940f527b491a70de9e396f0747ba (diff)
downloadfreebsd-ports-graphics-5f7da7531f2c24d0ef8afb97ff520a8abdcdb8d9.tar.gz
freebsd-ports-graphics-5f7da7531f2c24d0ef8afb97ff520a8abdcdb8d9.tar.zst
freebsd-ports-graphics-5f7da7531f2c24d0ef8afb97ff520a8abdcdb8d9.zip
New master/slave scheme for semi-1.14.x ports.
Update master port to emacs21. Update slave ports to stub port: semi-emacs20, semi-xemacs21-mule. Does not support semi-emacs(19) and semi-mule for semi-1.14.x or later. Change some style.
Diffstat (limited to 'editors/semi/Makefile')
-rw-r--r--editors/semi/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/editors/semi/Makefile b/editors/semi/Makefile
index 87e41e06d1c..eeba489b89d 100644
--- a/editors/semi/Makefile
+++ b/editors/semi/Makefile
@@ -32,10 +32,14 @@ SEMI_LISPDIR= ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}
SEMI_VERSION_SPECIFIC_LISPDIR= ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}
.if (${PORTCLASS} == "master")
-# emacs port setup
-EMACS_PORT_NAME= emacs20
+EMACS_PORT_NAME= emacs21
+DEPPORT_SUFFIX=
+.else
+DEPPORT_SUFFIX= -${EMACS_PORT_NAME}
.endif
+EMACS_MASTERDIR_PKGFILES=YES
+
# target name for make build
ALL_TARGET?= elc
# environments
@@ -48,8 +52,8 @@ MAKE_ARGS+= PREFIX="${LOCALBASE}" \
.if defined(EMACS_PORT_NAME)
# depends on flim
-BUILD_DEPENDS+= ${LOCALBASE}/share/flim/${FLIM_COOKIE}:${PORTSDIR}/editors/flim${FLIM_TRUNK:S/.//}-${EMACS_PORT_NAME}
-RUN_DEPENDS+= ${LOCALBASE}/share/flim/${FLIM_COOKIE}:${PORTSDIR}/editors/flim${FLIM_TRUNK:S/.//}-${EMACS_PORT_NAME}
+BUILD_DEPENDS+= ${LOCALBASE}/share/flim/${FLIM_COOKIE}:${PORTSDIR}/editors/flim${DEPPORT_SUFFIX}
+RUN_DEPENDS+= ${LOCALBASE}/share/flim/${FLIM_COOKIE}:${PORTSDIR}/editors/flim${DEPPORT_SUFFIX}
.else
.BEGIN:
@${ECHO} "Error: Bad port."