aboutsummaryrefslogtreecommitdiffstats
path: root/editors/treeform/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2007-07-06 11:43:08 +0800
committerijliao <ijliao@FreeBSD.org>2007-07-06 11:43:08 +0800
commit75a7d7df46aac7800c71855014127679a4a6dc45 (patch)
tree9c7cfea38441d2337eaacfcc6bd4d0001b3de483 /editors/treeform/Makefile
parent708c2bd944d3d7bd99bc918430b780ab0169066f (diff)
downloadfreebsd-ports-graphics-75a7d7df46aac7800c71855014127679a4a6dc45.tar.gz
freebsd-ports-graphics-75a7d7df46aac7800c71855014127679a4a6dc45.tar.zst
freebsd-ports-graphics-75a7d7df46aac7800c71855014127679a4a6dc45.zip
add treeform 0.9.10
A Linguistic Syntax/Semantics tree drawing editor PR: 114236 Submitted by: Kuan-Chung Chiu <buganini@gmail.com>
Diffstat (limited to 'editors/treeform/Makefile')
-rw-r--r--editors/treeform/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/editors/treeform/Makefile b/editors/treeform/Makefile
new file mode 100644
index 00000000000..7fa3b52b5d3
--- /dev/null
+++ b/editors/treeform/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: treeform
+# Date created: 3 July 2007
+# Whom: buganini@gmail.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= treeform
+PORTVERSION= 0.9.10
+CATEGORIES= editors java
+MASTER_SITES= SF
+DISTNAME= TreeForm_9_10
+
+MAINTAINER= buganini@gmail.com
+COMMENT= A Linguistic Syntax/Semantics tree drawing editor
+
+USE_ZIP= yes
+NO_BUILD= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.5+
+SUB_FILES= treeform
+
+WRKSRC= ${WRKDIR}/TreeForm
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/treeform ${PREFIX}/bin
+ cd ${WRKSRC} \
+ && ${INSTALL_DATA} TreeForm.jar ${JAVAJARDIR} \
+ && ${COPYTREE_SHARE} about.htm ${DATADIR} \
+ && ${COPYTREE_SHARE} help ${DATADIR} \
+ && ${COPYTREE_SHARE} image ${DATADIR}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>