aboutsummaryrefslogtreecommitdiffstats
path: root/editors/xemacs-devel
diff options
context:
space:
mode:
authoranray <anray@FreeBSD.org>2006-02-18 05:12:07 +0800
committeranray <anray@FreeBSD.org>2006-02-18 05:12:07 +0800
commit2391d7313964533cae24bc7a1fc29831560dfb77 (patch)
tree55ca94e73895b9332c3d42bd460a9496c99dd047 /editors/xemacs-devel
parent46103baf1daf4b5aaa5d9a9695064db96ce61c3d (diff)
downloadfreebsd-ports-graphics-2391d7313964533cae24bc7a1fc29831560dfb77.tar.gz
freebsd-ports-graphics-2391d7313964533cae24bc7a1fc29831560dfb77.tar.zst
freebsd-ports-graphics-2391d7313964533cae24bc7a1fc29831560dfb77.zip
Remove "Cache full" warning.
Diffstat (limited to 'editors/xemacs-devel')
-rw-r--r--editors/xemacs-devel/Makefile1
-rw-r--r--editors/xemacs-devel/files/patch-xgccache.c17
2 files changed, 18 insertions, 0 deletions
diff --git a/editors/xemacs-devel/Makefile b/editors/xemacs-devel/Makefile
index 9d34b1c2420..47e93fd167c 100644
--- a/editors/xemacs-devel/Makefile
+++ b/editors/xemacs-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xemacs-devel
PORTVERSION= ${XEMACS_VER:S/-/./}
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES+= editors
MASTER_SITES= ${MASTER_SITE_XEMACS}
diff --git a/editors/xemacs-devel/files/patch-xgccache.c b/editors/xemacs-devel/files/patch-xgccache.c
new file mode 100644
index 00000000000..bc0d7dbef59
--- /dev/null
+++ b/editors/xemacs-devel/files/patch-xgccache.c
@@ -0,0 +1,17 @@
+Index: src/xgccache.c
+===================================================================
+RCS file: /pack/xemacscvs/XEmacs/xemacs/src/xgccache.c,v
+retrieving revision 1.13
+diff -u -r1.13 xgccache.c
+--- src/xgccache.c 2005/11/26 11:46:11 1.13
++++ src/xgccache.c 2006/02/16 20:18:18
+@@ -233,7 +233,9 @@
+ cache->head = cell->next;
+ cache->head->prev = 0;
+ if (cache->tail == cell) cache->tail = 0; /* only one */
++#if 0
+ debug_out ("Cache full, freeing GC: %08lx\n ", XE_GCONTEXT(cell));
++#endif
+ XFreeGC (cache->dpy, cell->gc);
+ cache->delete_count++;
+ #ifdef GCCACHE_HASH