aboutsummaryrefslogtreecommitdiffstats
path: root/editors/xemacs-devel
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2008-08-20 08:57:32 +0800
committerade <ade@FreeBSD.org>2008-08-20 08:57:32 +0800
commit8eb92ae1d0dce072ddbe65c4852625fae9d1eddb (patch)
tree0187b240fea44ca0f29e4c127dba0644d947187e /editors/xemacs-devel
parent6998bd19975dd6b512ccc433d82c50c8893fbc13 (diff)
downloadfreebsd-ports-graphics-8eb92ae1d0dce072ddbe65c4852625fae9d1eddb.tar.gz
freebsd-ports-graphics-8eb92ae1d0dce072ddbe65c4852625fae9d1eddb.tar.zst
freebsd-ports-graphics-8eb92ae1d0dce072ddbe65c4852625fae9d1eddb.zip
Conversion from (now defunct) autoconf-2.61 to autoconf-2.62
Tested by: exp build run (erwin)
Diffstat (limited to 'editors/xemacs-devel')
-rw-r--r--editors/xemacs-devel/Makefile2
-rw-r--r--editors/xemacs-devel/files/patch-configure.ac31
2 files changed, 15 insertions, 18 deletions
diff --git a/editors/xemacs-devel/Makefile b/editors/xemacs-devel/Makefile
index f5b5e0d2d15..6c827593caa 100644
--- a/editors/xemacs-devel/Makefile
+++ b/editors/xemacs-devel/Makefile
@@ -39,7 +39,7 @@ XEMACS_ARCH= ${CONFIGURE_TARGET}
WRKSRC= ${WRKDIR}/xemacs-${XEMACS_VER:S/-b/./}
STRIP=
-USE_AUTOTOOLS= autoconf:261
+USE_AUTOTOOLS= autoconf:262
CONFIGURE_TARGET=${MACHINE_ARCH}--freebsd
CONFIGURE_ARGS?=--enable-clash-detection \
diff --git a/editors/xemacs-devel/files/patch-configure.ac b/editors/xemacs-devel/files/patch-configure.ac
index d21c7f9b168..5058b3f986d 100644
--- a/editors/xemacs-devel/files/patch-configure.ac
+++ b/editors/xemacs-devel/files/patch-configure.ac
@@ -1,28 +1,25 @@
---- configure.ac.orig Thu Mar 30 21:11:17 2006
-+++ configure.ac Sat Apr 1 19:49:02 2006
-@@ -1272,6 +1272,7 @@
- dnl Straightforward OS determination
- case "$ac_cv_build" in
+--- configure.ac.orig 2007-05-21 03:50:13.000000000 +0000
++++ configure.ac 2008-08-04 13:50:15.000000000 +0000
+@@ -389,5 +389,7 @@
+ dnl
++dnl m4_fst disappeared without a trace in autoconf 2.62
++m4_define([xe_fst], [$1])dnl
+ define([XE_EXPAND_COMPLEX_OPTIONS],
+ [m4_if([$2], [], [],
+- [XE_EXPAND_COMPLEX_OPTION([$1], m4_fst($2))[]dnl
++ [XE_EXPAND_COMPLEX_OPTION([$1], xe_fst($2))[]dnl
+ XE_EXPAND_COMPLEX_OPTIONS([$1], XE_CDR($2))])])dnl
+@@ -1313,2 +1315,3 @@
*-*-linux* ) opsys=linux ;;
+ *-*-freebsd* ) opsys=freebsd ;;
*-*-netbsd* ) opsys=netbsd ;;
- *-*-openbsd* ) opsys=openbsd ;;
- *-*-nextstep* ) opsys=nextstep ;;
-@@ -3439,7 +3440,7 @@
- dnl #### How about /sw/include, and /opt/local/include?
- dnl these directories need to be the parent of the freetype directory
+@@ -3496,3 +3499,3 @@
for freetype_include_top in "/usr/X11R6/include/freetype2" \
- "/usr/include/freetype2"
+ "$with_site_includes/freetype2"
do
- if test -d $freetype_include_top; then
- AC_MSG_CHECKING([in ${freetype_include_top}/freetype2])
-@@ -5339,7 +5340,7 @@
- dnl Check for Berkeley DB.
- if test "$enable_database_berkdb" != "no"; then
+@@ -5420,3 +5423,3 @@
AC_MSG_CHECKING(for Berkeley db.h)
- for header in "db/db.h" "db.h"; do
+ for header in "/usr/include/db.h" "db/db.h" "db.h"; do
AC_COMPILE_IFELSE([AC_LANG_SOURCE([
- #include <stdlib.h>
- #if !(defined __GLIBC__ && __GLIBC_MINOR__ >= 1)