aboutsummaryrefslogtreecommitdiffstats
path: root/editors/xemacs-packages/Makefile
diff options
context:
space:
mode:
authorgj <gj@FreeBSD.org>2000-02-18 05:44:04 +0800
committergj <gj@FreeBSD.org>2000-02-18 05:44:04 +0800
commit0016e261a2b5bac9fd6521917b56d8275c16e19e (patch)
tree79fce393f3a74f7418f8c00ee88fb9c68ab7c392 /editors/xemacs-packages/Makefile
parentec100bcb528b319ad74172f969c13bf4f3073229 (diff)
downloadfreebsd-ports-graphics-0016e261a2b5bac9fd6521917b56d8275c16e19e.tar.gz
freebsd-ports-graphics-0016e261a2b5bac9fd6521917b56d8275c16e19e.tar.zst
freebsd-ports-graphics-0016e261a2b5bac9fd6521917b56d8275c16e19e.zip
Add the hm--html-menus-1.14-pkg.tar.gz package. Also update some other
packages. This is the first stage in a rather ambitious plan which kiri has to add additional xemacs-package ports to make it easier for the user to install additional packages beyond the base support. Submitted by: kiri@pis.toba-cmt.ac.jp
Diffstat (limited to 'editors/xemacs-packages/Makefile')
-rw-r--r--editors/xemacs-packages/Makefile23
1 files changed, 17 insertions, 6 deletions
diff --git a/editors/xemacs-packages/Makefile b/editors/xemacs-packages/Makefile
index 50034a19965..8ec81664e03 100644
--- a/editors/xemacs-packages/Makefile
+++ b/editors/xemacs-packages/Makefile
@@ -28,25 +28,36 @@ DISTFILES= \
mailcrypt-2.04-pkg.tar.gz vc-1.21-pkg.tar.gz \
sh-script-1.11-pkg.tar.gz auctex-1.19-pkg.tar.gz \
ispell-1.18-pkg.tar.gz pcl-cvs-1.41-pkg.tar.gz \
- w3-1.15-pkg.tar.gz texinfo-1.18-pkg.tar.gz
+ w3-1.15-pkg.tar.gz texinfo-1.18-pkg.tar.gz \
+ hm--html-menus-1.14-pkg.tar.gz
MAINTAINER= gj@FreeBSD.org
DIST_SUBDIR= xemacs
NO_BUILD= yes
-NO_WRKSUBDIR= yes
+WRKSRC= ${WRKDIR}/xemacs-packages
+
+XEMACSDIR= ${PREFIX}/lib/xemacs
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+.for f in ${DISTFILES}
+ @${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/${DIST_SUBDIR}/${f} \
+ ${EXTRACT_AFTER_ARGS} -C ${WRKSRC}
+.endfor
do-install:
- ${MKDIR} ${PREFIX}/lib/xemacs/xemacs-packages
- ${CP} -Rp ${WRKDIR}/* ${PREFIX}/lib/xemacs/xemacs-packages
+ ${MKDIR} ${XEMACSDIR}
+ ${CP} -Rp ${WRKSRC} ${XEMACSDIR}
post-install:
@${ECHO_MSG} "This is only a subset of the available packages for xemacs."
@${ECHO_MSG} "You can install additional packages yourself from within xemacs by"
@${ECHO_MSG} "running it as root and using the 'Manage Packes' menu within"
@${ECHO_MSG} "the 'Options' menu of the menubar."
- @${ECHO_MSG} "To install all packages, consider using the xemacs-sumo-packages"
- @${ECHO_MSG} "and xemacs-mule-sumo-packages ports."
+ @${ECHO_MSG} "To install all packages besides basic packages(xemacs-packages or"
+ @${ECHO_MSG} "xemacs-mule-packages), consider using the xemacs-other-packages or"
+ @${ECHO_MSG} "xemacs-mule-other-packages port."
.include <bsd.port.mk>