aboutsummaryrefslogtreecommitdiffstats
path: root/editors/xemacs/Makefile
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>1999-02-04 07:44:30 +0800
committersteve <steve@FreeBSD.org>1999-02-04 07:44:30 +0800
commit6f360007da32d43becbc10079a4ecac2967a9395 (patch)
tree9d1f1791c26a6afd93ca332b8a640f928abc9a80 /editors/xemacs/Makefile
parent949ef83a2a126c2b0cc17270abda1f5c9476d8ff (diff)
downloadfreebsd-ports-graphics-6f360007da32d43becbc10079a4ecac2967a9395.tar.gz
freebsd-ports-graphics-6f360007da32d43becbc10079a4ecac2967a9395.tar.zst
freebsd-ports-graphics-6f360007da32d43becbc10079a4ecac2967a9395.zip
Use XEMACS_ARCH and XEMACS_VER and cleanup PLIST.
Diffstat (limited to 'editors/xemacs/Makefile')
-rw-r--r--editors/xemacs/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/editors/xemacs/Makefile b/editors/xemacs/Makefile
index c2de6cfe09a..1ff099cd42c 100644
--- a/editors/xemacs/Makefile
+++ b/editors/xemacs/Makefile
@@ -3,7 +3,7 @@
# Date created: 26 August 1997
# Whom: Michael Elbel (me)
#
-# $Id: Makefile,v 1.25 1999/01/23 07:05:34 vanilla Exp $
+# $Id: Makefile,v 1.26 1999/01/25 22:06:11 gj Exp $
#
DISTNAME= xemacs-20.4
@@ -25,7 +25,8 @@ LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm \
USE_GMAKE= yes
STRIP=
HAS_CONFIGURE= yes
-CONFIGURE_ARGS= i386--freebsd --prefix=${PREFIX} \
+XEMACS_ARCH= ${MACHINE_ARCH}--freebsd
+CONFIGURE_ARGS= ${XEMACS_ARCH} --prefix=${PREFIX} \
--with-clash-detection \
--lockdir=/var/run/emacs/lock \
--with-sound=native \
@@ -37,6 +38,7 @@ CONFIGURE_ARGS= i386--freebsd --prefix=${PREFIX} \
MAN1= ctags.1 etags.1 gnuattach.1 gnuclient.1 gnudoit.1 \
gnuserv.1 xemacs.1
ALL_TARGET= all dist
+PLIST_SUB= XEMACS_VER=20.4 XEMACS_ARCH=${XEMACS_ARCH}
# Have
pre-configure: