aboutsummaryrefslogtreecommitdiffstats
path: root/editors/zile/Makefile
diff options
context:
space:
mode:
authorbarner <barner@FreeBSD.org>2006-02-01 09:08:58 +0800
committerbarner <barner@FreeBSD.org>2006-02-01 09:08:58 +0800
commit3193bfc871096a963b0df82b59af8910eb00d293 (patch)
tree85ee40e09ee89a2aed6d4873f15f81cd6746a3b1 /editors/zile/Makefile
parent5cc58d009ce95c965140497254172c1b9b918140 (diff)
downloadfreebsd-ports-graphics-3193bfc871096a963b0df82b59af8910eb00d293.tar.gz
freebsd-ports-graphics-3193bfc871096a963b0df82b59af8910eb00d293.tar.zst
freebsd-ports-graphics-3193bfc871096a963b0df82b59af8910eb00d293.zip
- Update to 2.2.11
Submitted by: Ports Fury PR: ports/92614
Diffstat (limited to 'editors/zile/Makefile')
-rw-r--r--editors/zile/Makefile24
1 files changed, 21 insertions, 3 deletions
diff --git a/editors/zile/Makefile b/editors/zile/Makefile
index 380a7269576..64830917a5d 100644
--- a/editors/zile/Makefile
+++ b/editors/zile/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= zile
-PORTVERSION= 2.2.9
+PORTVERSION= 2.2.11
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,9 +15,11 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Small emacs-like text editor
USE_GETOPT_LONG=yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --disable-allegro --disable-epocemx
+CONFIGURE_ENV= LIBS="-lgnuregex"
+CONFIGURE_ARGS= --disable-allegro --disable-epocemx
MAN1= zile.1
INFO= zile
@@ -25,4 +27,20 @@ PLIST_FILES= bin/zile %%DATADIR%%/AUTODOC %%DATADIR%%/FAQ %%DATADIR%%/HELP \
%%DATADIR%%/TUTORIAL %%DATADIR%%/dotzile.sample
PLIST_DIRS= %%DATADIR%%
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 502010
+GNU_REGEX_H= gnu/regex.h
+.else
+GNU_REGEX_H= gnuregex.h
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|<regex\.h>|<${GNU_REGEX_H}>|g ; \
+ s|_regex_h|_${GNU_REGEX_H:S/\//_/g:S/./_/g}|g ; \
+ s|-pedantic||g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ 's|<regex\.h>|<${GNU_REGEX_H}>|g' ${WRKSRC}/src/search.c
+
+.include <bsd.port.post.mk>