aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2016-09-10 16:20:27 +0800
committerrakuco <rakuco@FreeBSD.org>2016-09-10 16:20:27 +0800
commit1a59087cabd9b08131b8a40f9177c6ed3801989e (patch)
tree82268bc45adad540558f42ef5cff3fd72d7a1eb6 /editors
parenta3ba7f47c632141c09666811595076c6a0b7359a (diff)
downloadfreebsd-ports-graphics-1a59087cabd9b08131b8a40f9177c6ed3801989e.tar.gz
freebsd-ports-graphics-1a59087cabd9b08131b8a40f9177c6ed3801989e.tar.zst
freebsd-ports-graphics-1a59087cabd9b08131b8a40f9177c6ed3801989e.zip
Use system hunspell
Stop building texmaker's own, utdated bundled copy of hunspell. In addition to the obvious reasons, this is necessary to get the port to build with the upcoming Qt 5.6, as it passes -std=gnu++11 to the compiler automatically when it's supported and building the bundled hunspell failed like this: hunspell/affentry.hxx:28:94: error: cannot initialize a parameter of type 'unsigned short' with an rvalue of type 'nullptr_t' hunspell/affentry.hxx:91:103: error: cannot initialize a parameter of type 'unsigned short' with an rvalue of type 'nullptr_t' See also: https://www.freebsd.org/doc/en/books/porters-handbook/bundled-libs.html PR: 212366 Approved by: portmgr (mat)
Diffstat (limited to 'editors')
-rw-r--r--editors/texmaker/Makefile5
-rw-r--r--editors/texmaker/files/patch-texmaker.pro65
2 files changed, 65 insertions, 5 deletions
diff --git a/editors/texmaker/Makefile b/editors/texmaker/Makefile
index 50f4a72eb8c..739f2c9bed3 100644
--- a/editors/texmaker/Makefile
+++ b/editors/texmaker/Makefile
@@ -3,7 +3,7 @@
PORTNAME= texmaker
PORTVERSION= 4.5
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 3
CATEGORIES= editors
MASTER_SITES= http://www.xm1math.net/texmaker/
@@ -11,7 +11,8 @@ MASTER_SITES= http://www.xm1math.net/texmaker/
MAINTAINER= makc@FreeBSD.org
COMMENT= LaTeX Development Environment
-LIB_DEPENDS= libpoppler.so:graphics/poppler
+LIB_DEPENDS= libhunspell-1.3.so:textproc/hunspell \
+ libpoppler.so:graphics/poppler
USES= desktop-file-utils ghostscript:x11,run pkgconfig qmake tar:bzip2
_USE_QT4= gui network xml webkit \
diff --git a/editors/texmaker/files/patch-texmaker.pro b/editors/texmaker/files/patch-texmaker.pro
index 457dccb2637..bb81f8957ad 100644
--- a/editors/texmaker/files/patch-texmaker.pro
+++ b/editors/texmaker/files/patch-texmaker.pro
@@ -1,6 +1,65 @@
---- texmaker.pro.orig 2014-12-14 22:51:47 UTC
+--- texmaker.pro.orig 2015-10-24 09:05:27 UTC
+++ texmaker.pro
-@@ -393,13 +393,6 @@ utilities.files = doc/doc1.png \
+@@ -19,11 +19,11 @@ DEFINES += HAVE_SPLASH
+ unix:!macx {
+ contains( QT_VERSION, "^5.*" ) {
+ CONFIG += link_pkgconfig
+-PKGCONFIG = poppler-qt5
++PKGCONFIG = hunspell poppler-qt5
+ DEFINES += POPPLER24
+ } else {
+ CONFIG += link_pkgconfig
+-PKGCONFIG = poppler-qt4
++PKGCONFIG = hunspell poppler-qt4
+ DETECTEDPOPPLER=$$system(pkg-config --modversion poppler)
+ contains( DETECTEDPOPPLER, "^0.18.*" ){
+ DEFINES += OLDPOPPLER
+@@ -98,25 +98,6 @@ HEADERS += texmaker.h \
+ unicodeview.h \
+ quickbeamerdialog.h \
+ svnhelper.h \
+- hunspell/affentry.hxx \
+- hunspell/affixmgr.hxx \
+- hunspell/atypes.hxx \
+- hunspell/baseaffix.hxx \
+- hunspell/csutil.hxx \
+- hunspell/dictmgr.hxx \
+- hunspell/hashmgr.hxx \
+- hunspell/htypes.hxx \
+- hunspell/hunspell.hxx \
+- hunspell/hunspell.h \
+- hunspell/langnum.hxx \
+- hunspell/license.hunspell \
+- hunspell/phonet.hxx \
+- hunspell/suggestmgr.hxx \
+- hunspell/license.myspell \
+- hunspell/filemgr.hxx \
+- hunspell/hunzip.hxx \
+- hunspell/replist.hxx \
+- hunspell/w_char.hxx \
+ singleapp/qtlocalpeer.h \
+ singleapp/qtlockedfile.h \
+ singleapp/qtsingleapplication.h \
+@@ -210,18 +191,6 @@ SOURCES += main.cpp \
+ unicodeview.cpp \
+ quickbeamerdialog.cpp \
+ svnhelper.cpp \
+- hunspell/affentry.cxx \
+- hunspell/affixmgr.cxx \
+- hunspell/csutil.cxx \
+- hunspell/dictmgr.cxx \
+- hunspell/hashmgr.cxx \
+- hunspell/hunspell.cxx \
+- hunspell/phonet.cxx \
+- hunspell/suggestmgr.cxx \
+- hunspell/utf_info.cxx \
+- hunspell/filemgr.cxx \
+- hunspell/replist.cxx \
+- hunspell/hunzip.cxx \
+ singleapp/qtlocalpeer.cpp \
+ singleapp/qtlockedfile.cpp \
+ singleapp/qtsingleapplication.cpp \
+@@ -395,13 +364,6 @@ utilities.files = doc/doc1.png \
utilities/AUTHORS \
utilities/COPYING \
utilities/CHANGELOG.txt \
@@ -14,7 +73,7 @@
scripts/titlecase_selection.tms \
scripts/hardwordwrap_selection_80col.tms \
locale/qt_cs.qm \
-@@ -475,4 +468,20 @@ INSTALLS += desktop
+@@ -477,4 +439,20 @@ INSTALLS += desktop
icon.files = utilities/texmaker.png
INSTALLS += icon