aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-01-12 22:17:21 +0800
committerbapt <bapt@FreeBSD.org>2012-01-12 22:17:21 +0800
commit1c99c8a56d7a55f84df47e63f9ab8f4be47615b7 (patch)
tree6f0a653dd3d811efd24bfc47ac8e67820b1149a6 /editors
parentbadf4ad8be95059ef16d9df55d39b28224fa9067 (diff)
downloadfreebsd-ports-graphics-1c99c8a56d7a55f84df47e63f9ab8f4be47615b7.tar.gz
freebsd-ports-graphics-1c99c8a56d7a55f84df47e63f9ab8f4be47615b7.tar.zst
freebsd-ports-graphics-1c99c8a56d7a55f84df47e63f9ab8f4be47615b7.zip
Remove the glob from the rmdir line "@unexec rmdir ... || true" are
automatically mapped to @dirrmtry by pkgng which is a real keyword not a "rmdir" execution so it does not support glob no bump of the portrevision
Diffstat (limited to 'editors')
-rw-r--r--editors/xemacs-mule-packages/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/editors/xemacs-mule-packages/Makefile b/editors/xemacs-mule-packages/Makefile
index cd74ffdd34b..ae402f5a953 100644
--- a/editors/xemacs-mule-packages/Makefile
+++ b/editors/xemacs-mule-packages/Makefile
@@ -48,7 +48,11 @@ post-install:
${SED} 's:^:lib/xemacs/:' >> ${TMPPLIST}; \
${FIND} ${PACKAGES_SUBDIR}/*/* -type d|${SORT} -r| \
${SED} 's:^:@dirrm lib/xemacs/:'>> ${TMPPLIST}
- @${ECHO_CMD} '@unexec rmdir %D/lib/xemacs/${PACKAGES_SUBDIR}/* 2>/dev/null || true' >> ${TMPPLIST}
+ @${ECHO_CMD} '@unexec rmdir %D/lib/xemacs/${PACKAGES_SUBDIR}/man 2>/dev/null || true' >> ${TMPPLIST}
+ @${ECHO_CMD} '@unexec rmdir %D/lib/xemacs/${PACKAGES_SUBDIR}/lisp 2>/dev/null || true' >> ${TMPPLIST}
+ @${ECHO_CMD} '@unexec rmdir %D/lib/xemacs/${PACKAGES_SUBDIR}/etc 2>/dev/null || true' >> ${TMPPLIST}
+ @${ECHO_CMD} '@unexec rmdir %D/lib/xemacs/${PACKAGES_SUBDIR}/pkginfo 2>/dev/null || true' >> ${TMPPLIST}
+ @${ECHO_CMD} '@unexec rmdir %D/lib/xemacs/${PACKAGES_SUBDIR}/info 2>/dev/null || true' >> ${TMPPLIST}
@${ECHO_CMD} '@unexec rmdir %D/lib/xemacs/${PACKAGES_SUBDIR} 2>/dev/null || true' >> ${TMPPLIST}
@${ECHO_CMD} '@unexec rmdir %D/lib/xemacs 2>/dev/null || true' >> ${TMPPLIST}
@${ECHO_MSG} " This port installs packages for XEmacs with mule. These packages should be"