aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2013-01-29 01:47:30 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2013-01-29 01:47:30 +0800
commit286a40e8ec0741c84c7517645fcbc03606ea313a (patch)
tree746c00a41a715cb61c709a7ff7fce00b3f80c545 /editors
parentea21b46ebf8f593d935b4a88587f4270f79ca418 (diff)
downloadfreebsd-ports-graphics-286a40e8ec0741c84c7517645fcbc03606ea313a.tar.gz
freebsd-ports-graphics-286a40e8ec0741c84c7517645fcbc03606ea313a.tar.zst
freebsd-ports-graphics-286a40e8ec0741c84c7517645fcbc03606ea313a.zip
- Fix search on 64-bit systems
Diffstat (limited to 'editors')
-rw-r--r--editors/chexedit/Makefile1
-rw-r--r--editors/chexedit/files/patch-src-search.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/editors/chexedit/Makefile b/editors/chexedit/Makefile
index 38b87dfff8d..16bafe19dc4 100644
--- a/editors/chexedit/Makefile
+++ b/editors/chexedit/Makefile
@@ -7,6 +7,7 @@
PORTNAME= chexedit
PORTVERSION= 0.9.7
+PORTREVISION= 1
CATEGORIES= editors
MASTER_SITES= http://www.rogoyski.com/adam/programs/hexedit/ \
http://mirror.amdmi3.ru/distfiles/
diff --git a/editors/chexedit/files/patch-src-search.c b/editors/chexedit/files/patch-src-search.c
new file mode 100644
index 00000000000..ed56d008ebb
--- /dev/null
+++ b/editors/chexedit/files/patch-src-search.c
@@ -0,0 +1,11 @@
+--- src/search.c.orig 1999-06-27 17:45:29.000000000 +0400
++++ src/search.c 2013-01-28 21:43:29.590293182 +0400
+@@ -39,7 +39,7 @@
+ if (!buf)
+ return &found;
+
+- memset (l_table, 0, 256 * sizeof (int));
++ memset (l_table, 0, 256 * sizeof (unsigned long));
+ i = 0;
+ s = substr + len - 1;
+ while (i < len)