aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-02-19 23:27:58 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-02-19 23:27:58 +0800
commit683d839eff8b451047326f1bc39eae6ff7f58b0c (patch)
tree9c07c622d9862a26d3f63262e331ca0f80e56b4e /editors
parent2371a81ee4e41f10caa42d713d154bb02d743230 (diff)
downloadfreebsd-ports-graphics-683d839eff8b451047326f1bc39eae6ff7f58b0c.tar.gz
freebsd-ports-graphics-683d839eff8b451047326f1bc39eae6ff7f58b0c.tar.zst
freebsd-ports-graphics-683d839eff8b451047326f1bc39eae6ff7f58b0c.zip
- Use :group to fetch source and patch from correct URL
Diffstat (limited to 'editors')
-rw-r--r--editors/vim/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index 9f024d528dc..fd96034997c 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -5,9 +5,10 @@ PORTNAME= vim
PORTVERSION= 7.4.${PATCHLEVEL}
PORTREVISION?= 0
CATEGORIES?= editors
-MASTER_SITES= VIM \
- LOCAL/sunpoet/${PORTNAME}
-DISTFILES= ${PORTNAME}-${PORTVERSION:R}${EXTRACT_SUFX}
+MASTER_SITES= VIM:source \
+ ${MASTER_SITE_VIM:S|unix|patches/${PORTVERSION:R}|}:patch \
+ LOCAL/sunpoet/${PORTNAME}:source,patch
+DISTFILES= ${PORTNAME}-${PORTVERSION:R}${EXTRACT_SUFX}:source
DIST_SUBDIR= ${PORTNAME}
EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION:R}${EXTRACT_SUFX}
@@ -41,7 +42,7 @@ PATCHLEVEL= 182
PATCHFILES!= /usr/bin/jot -s " " -w "%03d" ${PATCHLEVEL} 1 ${PATCHLEVEL}
BADPATCHES= 064 087 147 # empty
.for p in ${BADPATCHES}
-DISTFILES+= ${PORTVERSION:R}.${p}
+DISTFILES+= ${PORTVERSION:R}.${p}:patch
PATCHFILES:= ${PATCHFILES:N${p}}
.endfor
PATCHFILES:= ${PATCHFILES:C/^/${PORTVERSION:R}./g}