aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2007-06-17 14:27:45 +0800
committerkris <kris@FreeBSD.org>2007-06-17 14:27:45 +0800
commit6a57e79eaf97572e27e5c6c871f4b6da5e9b5559 (patch)
tree8af3a9404050c06fd3511ed3ae75313240686011 /editors
parent48d621e9e381881e939ba70a39076afd54f1ec00 (diff)
downloadfreebsd-ports-graphics-6a57e79eaf97572e27e5c6c871f4b6da5e9b5559.tar.gz
freebsd-ports-graphics-6a57e79eaf97572e27e5c6c871f4b6da5e9b5559.tar.zst
freebsd-ports-graphics-6a57e79eaf97572e27e5c6c871f4b6da5e9b5559.zip
This port contains an incorrect configure test that tries to test for the
pthread_create() function by doing the following | char pthread_create (); | int | main () | { | pthread_create (); | ; | return 0; | } This is completely bogus (pthread_create() requires arguments), so this causes undefined behaviour. One such undefined behaviour seen in practise is an infinite loop. Disable the port until someone cares to fix this. Also shuffle the rxvt PATCH_DEPENDS (!) later, to give a chance for the WITHOUT_X11 to be set. This also looks pretty bogus, rxvt in fact does not appear to be needed for patching.
Diffstat (limited to 'editors')
-rw-r--r--editors/bed/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/editors/bed/Makefile b/editors/bed/Makefile
index 1fa2235745a..b3fae83492b 100644
--- a/editors/bed/Makefile
+++ b/editors/bed/Makefile
@@ -17,6 +17,8 @@ COMMENT= Variable dataformat binary editor
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
+IGNORE= has a broken test for pthread_create() (wrong prototype and calling conventions) causing an infinite loop.
+
USE_GCC= 3.4
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -29,10 +31,6 @@ MANCOMPRESSED= yes
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_X11)
-PATCH_DEPENDS+= rxvt:${PORTSDIR}/x11/rxvt
-.endif
-
# Check for menubar support in "x11/rxvt". In case of failure, disable X11 if
# BATCH or PACKAGE_BUILDING, and IGNORE otherwise.
.if !defined(WITHOUT_X11)
@@ -49,6 +47,10 @@ IGNORE= needs "x11/rxvt" to be compiled with the WITH_MENUBAR option to enable
.endif
.if !defined(WITHOUT_X11)
+PATCH_DEPENDS+= rxvt:${PORTSDIR}/x11/rxvt
+.endif
+
+.if !defined(WITHOUT_X11)
RUN_DEPENDS+= rxvt:${PORTSDIR}/x11/rxvt
PLIST_SUB+= X11=""
.else