aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2009-08-03 03:36:34 +0800
committermezz <mezz@FreeBSD.org>2009-08-03 03:36:34 +0800
commitaf1fc7a24eda71b11fbfc0bc73c1d53d079e5b57 (patch)
treeb69e5428d2c59fc0cebf129e7ba703a374c1bcf7 /editors
parent3a0a9794815da3b9ae9bf959990263eabe231698 (diff)
downloadfreebsd-ports-graphics-af1fc7a24eda71b11fbfc0bc73c1d53d079e5b57.tar.gz
freebsd-ports-graphics-af1fc7a24eda71b11fbfc0bc73c1d53d079e5b57.tar.zst
freebsd-ports-graphics-af1fc7a24eda71b11fbfc0bc73c1d53d079e5b57.zip
-Repocopy devel/libtool15 -> libtool22 and libltdl15 -> libltdl22.
-Update libtool and libltdl to 2.2.6a. -Remove devel/libtool15 and devel/libltdl15. -Fix ports build with libtool22/libltdl22. -Bump ports that depend on libltdl22 due to shared library version change. -Explain what to do update in the UPDATING. It has been tested with GNOME2, XFCE4, KDE3, KDE4 and other many wm/desktop and applications in the runtime. With help: marcus and kwm Pointyhat-exp: a few times by pav Tested by: pgollucci, "Romain Tartière" <romain@blogreen.org>, and a few MarcusCom CVS users. Also, I might have missed a few. Repocopy by: marcus Approved by: portmgr
Diffstat (limited to 'editors')
-rw-r--r--editors/calligra/Makefile2
-rw-r--r--editors/cooledit/Makefile2
-rw-r--r--editors/gedit-plugins/Makefile2
-rw-r--r--editors/gedit/Makefile2
-rw-r--r--editors/gphpedit/Makefile2
-rw-r--r--editors/kate-plugins/Makefile2
-rw-r--r--editors/kile-kde4/Makefile2
-rw-r--r--editors/kile/Makefile2
-rw-r--r--editors/klat/Makefile2
-rw-r--r--editors/koffice-kde3/Makefile2
-rw-r--r--editors/koffice-kde4/Makefile2
-rw-r--r--editors/kxmleditor/Makefile2
-rw-r--r--editors/lpe/Makefile2
-rw-r--r--editors/mlview/Makefile2
-rw-r--r--editors/nvi-devel/Makefile2
-rw-r--r--editors/xmlcopyeditor/Makefile2
-rw-r--r--editors/xmleditor/Makefile2
17 files changed, 17 insertions, 17 deletions
diff --git a/editors/calligra/Makefile b/editors/calligra/Makefile
index 7e2301ffb75..d590f08d7f2 100644
--- a/editors/calligra/Makefile
+++ b/editors/calligra/Makefile
@@ -31,7 +31,7 @@ LIB_DEPENDS= GraphicsMagick++.1:${PORTSDIR}/graphics/GraphicsMagick \
wv2.2:${PORTSDIR}/textproc/wv2
RUN_DEPENDS= ${LOCALBASE}/lib/libpqxx.a:${PORTSDIR}/databases/postgresql-libpqxx
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_LDCONFIG= yes
USE_BZIP2= yes
USE_GMAKE= yes
diff --git a/editors/cooledit/Makefile b/editors/cooledit/Makefile
index f081d079e4e..37f6aef04aa 100644
--- a/editors/cooledit/Makefile
+++ b/editors/cooledit/Makefile
@@ -15,7 +15,7 @@ MASTER_SITE_SUBDIR= apps/editors/X/cooledit
MAINTAINER= ports@FreeBSD.org
COMMENT= Suite of utilities, including a GUI editor
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_PYTHON= yes
USE_GETTEXT= yes
USE_GMAKE= yes
diff --git a/editors/gedit-plugins/Makefile b/editors/gedit-plugins/Makefile
index da75abe5058..d1542032727 100644
--- a/editors/gedit-plugins/Makefile
+++ b/editors/gedit-plugins/Makefile
@@ -24,7 +24,7 @@ USE_LDCONFIG= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_GETTEXT= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_GNOME= gnomehack gnomeprefix intlhack gnomevfs2
WANT_GNOME= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/editors/gedit/Makefile b/editors/gedit/Makefile
index efbecc0d9c1..0ecc96fe8cb 100644
--- a/editors/gedit/Makefile
+++ b/editors/gedit/Makefile
@@ -26,7 +26,7 @@ USE_GETTEXT= yes
INSTALLS_OMF= yes
USE_LDCONFIG= yes
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_GNOME= gnomeprefix gnomehack intlhack gconf2 gtksourceview2 \
desktopfileutils gnomedocutils ltasneededhack
WANT_GNOME= yes
diff --git a/editors/gphpedit/Makefile b/editors/gphpedit/Makefile
index cae0cdd5259..7548481789d 100644
--- a/editors/gphpedit/Makefile
+++ b/editors/gphpedit/Makefile
@@ -18,7 +18,7 @@ COMMENT= PHP, HTML and CSS development environment for GNOME 2.x
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack libgnomeui libgtkhtml
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/editors/kate-plugins/Makefile b/editors/kate-plugins/Makefile
index aac13eba533..26b6e75ae6e 100644
--- a/editors/kate-plugins/Makefile
+++ b/editors/kate-plugins/Makefile
@@ -23,7 +23,7 @@ USE_KDELIBS_VER=3
USE_BZIP2= yes
PREFIX= ${KDE_PREFIX}
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_GMAKE= yes
USE_LDCONFIG= yes
diff --git a/editors/kile-kde4/Makefile b/editors/kile-kde4/Makefile
index ed093e5aab6..c104a95189f 100644
--- a/editors/kile-kde4/Makefile
+++ b/editors/kile-kde4/Makefile
@@ -21,7 +21,7 @@ CONFLICTS= kile-i18n-[0-9]*
USE_KDELIBS_VER=3
USE_BZIP2= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_GMAKE= yes
OPTIONS= KPDF "Use KPDF and KDVI for viewing" on
diff --git a/editors/kile/Makefile b/editors/kile/Makefile
index ed093e5aab6..c104a95189f 100644
--- a/editors/kile/Makefile
+++ b/editors/kile/Makefile
@@ -21,7 +21,7 @@ CONFLICTS= kile-i18n-[0-9]*
USE_KDELIBS_VER=3
USE_BZIP2= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_GMAKE= yes
OPTIONS= KPDF "Use KPDF and KDVI for viewing" on
diff --git a/editors/klat/Makefile b/editors/klat/Makefile
index f5c51993614..e11d83b26dc 100644
--- a/editors/klat/Makefile
+++ b/editors/klat/Makefile
@@ -17,7 +17,7 @@ COMMENT= A LaTeX source editor for KDE
GNU_CONFIGURE= yes
USE_KDELIBS_VER=3
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
INSTALLS_ICONS= yes
.include <bsd.port.mk>
diff --git a/editors/koffice-kde3/Makefile b/editors/koffice-kde3/Makefile
index 7e2301ffb75..d590f08d7f2 100644
--- a/editors/koffice-kde3/Makefile
+++ b/editors/koffice-kde3/Makefile
@@ -31,7 +31,7 @@ LIB_DEPENDS= GraphicsMagick++.1:${PORTSDIR}/graphics/GraphicsMagick \
wv2.2:${PORTSDIR}/textproc/wv2
RUN_DEPENDS= ${LOCALBASE}/lib/libpqxx.a:${PORTSDIR}/databases/postgresql-libpqxx
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_LDCONFIG= yes
USE_BZIP2= yes
USE_GMAKE= yes
diff --git a/editors/koffice-kde4/Makefile b/editors/koffice-kde4/Makefile
index 7e2301ffb75..d590f08d7f2 100644
--- a/editors/koffice-kde4/Makefile
+++ b/editors/koffice-kde4/Makefile
@@ -31,7 +31,7 @@ LIB_DEPENDS= GraphicsMagick++.1:${PORTSDIR}/graphics/GraphicsMagick \
wv2.2:${PORTSDIR}/textproc/wv2
RUN_DEPENDS= ${LOCALBASE}/lib/libpqxx.a:${PORTSDIR}/databases/postgresql-libpqxx
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_LDCONFIG= yes
USE_BZIP2= yes
USE_GMAKE= yes
diff --git a/editors/kxmleditor/Makefile b/editors/kxmleditor/Makefile
index b17459de40f..46f69f18d71 100644
--- a/editors/kxmleditor/Makefile
+++ b/editors/kxmleditor/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= kevlo@FreeBSD.org
COMMENT= XML editor for KDE
USE_KDELIBS_VER=3
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_GMAKE= yes
USE_LDCONFIG= yes
diff --git a/editors/lpe/Makefile b/editors/lpe/Makefile
index 86f97758b23..6d8f51ef74b 100644
--- a/editors/lpe/Makefile
+++ b/editors/lpe/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= slang.2:${PORTSDIR}/devel/libslang2
MAKE_JOBS_UNSAFE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_GETTEXT= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/editors/mlview/Makefile b/editors/mlview/Makefile
index b059d5c0d44..8515db9401d 100644
--- a/editors/mlview/Makefile
+++ b/editors/mlview/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A tree oriented XML editor for Gnome
USE_BZIP2= yes
-USE_AUTOTOOLS= autoconf:262 libtool:15
+USE_AUTOTOOLS= autoconf:262 libtool:22
USE_GNOME= eel2 gnomehack gnomeprefix gtksourceview
USE_GMAKE= yes
USE_LDCONFIG= yes
diff --git a/editors/nvi-devel/Makefile b/editors/nvi-devel/Makefile
index 5f92239a2fe..7fd439f9cad 100644
--- a/editors/nvi-devel/Makefile
+++ b/editors/nvi-devel/Makefile
@@ -21,7 +21,7 @@ CONFLICTS= nvi-m17n-*
USE_BZIP2= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/build.unix
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_LDCONFIG= yes
CONFIGURE_ARGS+= --with-db-prefix=${LOCALBASE} \
--program-prefix=n
diff --git a/editors/xmlcopyeditor/Makefile b/editors/xmlcopyeditor/Makefile
index 861df7d2c18..60d3ac66710 100644
--- a/editors/xmlcopyeditor/Makefile
+++ b/editors/xmlcopyeditor/Makefile
@@ -46,7 +46,7 @@ post-extract:
# iconv.m4 is located in ${LOCALBASE}/share/aclocal
ACLOCAL_ARGS= -I ${LOCALBASE}/share/aclocal
-USE_AUTOTOOLS= aclocal:110 autoconf:262 automake:110 libtool:15
+USE_AUTOTOOLS= aclocal:110 autoconf:262 automake:110 libtool:22
GNU_CONFIGURE= yes
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include \
diff --git a/editors/xmleditor/Makefile b/editors/xmleditor/Makefile
index 30e5dc493ba..281076ab7da 100644
--- a/editors/xmleditor/Makefile
+++ b/editors/xmleditor/Makefile
@@ -21,7 +21,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
USE_BISON= build
USE_GNOME= gnomehack libglade
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \