aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2009-07-15 20:10:36 +0800
committermaho <maho@FreeBSD.org>2009-07-15 20:10:36 +0800
commitbae7886e5785da9ef2cdf6cb3e7e0cc8d8a7870f (patch)
tree099775944694540f9c88d707fbe4db3bece5f546 /editors
parent767e3453a82dee1731c1b729e778944c2ec2f4b8 (diff)
downloadfreebsd-ports-graphics-bae7886e5785da9ef2cdf6cb3e7e0cc8d8a7870f.tar.gz
freebsd-ports-graphics-bae7886e5785da9ef2cdf6cb3e7e0cc8d8a7870f.tar.zst
freebsd-ports-graphics-bae7886e5785da9ef2cdf6cb3e7e0cc8d8a7870f.zip
Now (For __FreeBSD_version >= 702104)
bridge part should work in the original form. Bump portrevision for openoffice.org-2 and -3 ports.
Diffstat (limited to 'editors')
-rw-r--r--editors/openoffice-3-devel/files/patch-i8512610
-rw-r--r--editors/openoffice-3-devel/files/patch-i9878114
-rw-r--r--editors/openoffice-3/Makefile2
-rw-r--r--editors/openoffice-3/files/patch-i8512610
-rw-r--r--editors/openoffice-3/files/patch-i9878110
-rw-r--r--editors/openoffice.org-2-RC/files/patch-i851264
-rw-r--r--editors/openoffice.org-2-RC/files/patch-i987814
-rw-r--r--editors/openoffice.org-2-devel/files/patch-i851264
-rw-r--r--editors/openoffice.org-2-devel/files/patch-i987814
-rw-r--r--editors/openoffice.org-2/Makefile2
-rw-r--r--editors/openoffice.org-2/files/patch-i851264
-rw-r--r--editors/openoffice.org-2/files/patch-i987814
-rw-r--r--editors/openoffice.org-3-RC/files/patch-i8512610
-rw-r--r--editors/openoffice.org-3-RC/files/patch-i9878110
-rw-r--r--editors/openoffice.org-3-devel/files/patch-i8512610
-rw-r--r--editors/openoffice.org-3-devel/files/patch-i9878114
-rw-r--r--editors/openoffice.org-3/Makefile2
-rw-r--r--editors/openoffice.org-3/files/patch-i8512610
-rw-r--r--editors/openoffice.org-3/files/patch-i9878110
-rw-r--r--editors/openoffice.org-vcltesttool/files/patch-i851264
-rw-r--r--editors/openoffice.org-vcltesttool/files/patch-i987814
21 files changed, 53 insertions, 93 deletions
diff --git a/editors/openoffice-3-devel/files/patch-i85126 b/editors/openoffice-3-devel/files/patch-i85126
index 15dfa190b16..d2b427c9991 100644
--- a/editors/openoffice-3-devel/files/patch-i85126
+++ b/editors/openoffice-3-devel/files/patch-i85126
@@ -142,7 +142,7 @@ http://www.openoffice.org/issues/show_bug.cgi?id=97320
reinterpret_cast<
--- bridges/source/cpp_uno/gcc3_freebsd_x86-64/except.cxx 2009-06-13 15:39:58.000000000 +0900
+++ bridges/source/cpp_uno/gcc3_freebsd_x86-64/except.cxx 2009-06-13 15:42:43.000000000 +0900
-@@ -32,10 +32,10 @@
+@@ -32,6 +32,7 @@
#include "precompiled_bridges.hxx"
#include <stdio.h>
@@ -150,16 +150,12 @@ http://www.openoffice.org/issues/show_bug.cgi?id=97320
#include <dlfcn.h>
#include <cxxabi.h>
#include <hash_map>
--#include <sys/param.h>
-
- #include <rtl/strbuf.hxx>
- #include <rtl/ustrbuf.hxx>
@@ -121,7 +121,7 @@
};
//__________________________________________________________________________________________________
RTTI::RTTI() SAL_THROW( () )
-#if __FreeBSD_version < 602103
-+#ifdef FREEBSD /* #i22253# */
++#if __FreeBSD_version < 702104 /* #i22253# */
: m_hApp( dlopen( 0, RTLD_NOW | RTLD_GLOBAL ) )
#else
: m_hApp( dlopen( 0, RTLD_LAZY ) )
@@ -168,7 +164,7 @@ http://www.openoffice.org/issues/show_bug.cgi?id=97320
OString symName( buf.makeStringAndClear() );
-#if __FreeBSD_version < 602103 /* #i22253# */
-+#ifdef FREEBSD /* #i22253# */
++#if __FreeBSD_version < 702104 /* #i22253# */
rtti = (type_info *)dlsym( RTLD_DEFAULT, symName.getStr() );
#else
rtti = (type_info *)dlsym( m_hApp, symName.getStr() );
diff --git a/editors/openoffice-3-devel/files/patch-i98781 b/editors/openoffice-3-devel/files/patch-i98781
index a1a6c99298e..ca3849a011f 100644
--- a/editors/openoffice-3-devel/files/patch-i98781
+++ b/editors/openoffice-3-devel/files/patch-i98781
@@ -84,7 +84,7 @@ in files/patches-i85126
--- bridges/source/cpp_uno/gcc3_freebsd_intel/except.cxx 2009-06-13 14:17:39.000000000 +0900
+++ bridges/source/cpp_uno/gcc3_freebsd_intel/except.cxx 2009-06-13 15:14:24.000000000 +0900
-@@ -32,10 +32,10 @@
+@@ -32,6 +32,7 @@
#include "precompiled_bridges.hxx"
#include <stdio.h>
@@ -92,25 +92,21 @@ in files/patches-i85126
#include <dlfcn.h>
#include <cxxabi.h>
#include <hash_map>
--#include <sys/param.h>
-
- #include <rtl/strbuf.hxx>
- #include <rtl/ustrbuf.hxx>
-@@ -121,7 +121,7 @@
+@@ -121,7 +122,7 @@
};
//__________________________________________________________________________________________________
RTTI::RTTI() SAL_THROW( () )
-#if __FreeBSD_version < 602103
-+#ifdef FREEBSD /* #i22253# */
++#if __FreeBSD_version < 702104 /* #i22253# */
: m_hApp( dlopen( 0, RTLD_NOW | RTLD_GLOBAL ) )
#else
: m_hApp( dlopen( 0, RTLD_LAZY ) )
-@@ -160,7 +160,7 @@
+@@ -160,7 +161,7 @@
buf.append( 'E' );
OString symName( buf.makeStringAndClear() );
-#if __FreeBSD_version < 602103 /* #i22253# */
-+#ifdef FREEBSD /* #i22253# */
++#if __FreeBSD_version < 702104 /* #i22253# */
rtti = (type_info *)dlsym( RTLD_DEFAULT, symName.getStr() );
#else
rtti = (type_info *)dlsym( m_hApp, symName.getStr() );
diff --git a/editors/openoffice-3/Makefile b/editors/openoffice-3/Makefile
index d56f3f05864..97c398c7682 100644
--- a/editors/openoffice-3/Makefile
+++ b/editors/openoffice-3/Makefile
@@ -8,7 +8,7 @@
PORTNAME?= openoffice.org
PORTVERSION?= ${OOOVERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES+= editors java
MASTER_SITES+= http://ooopackages.good-day.net/pub/OpenOffice.org/sources/ \
ftp://ftp.cs.man.ac.uk/pub/toby/gpc/:gpc \
diff --git a/editors/openoffice-3/files/patch-i85126 b/editors/openoffice-3/files/patch-i85126
index 15dfa190b16..973ae74a51b 100644
--- a/editors/openoffice-3/files/patch-i85126
+++ b/editors/openoffice-3/files/patch-i85126
@@ -142,7 +142,7 @@ http://www.openoffice.org/issues/show_bug.cgi?id=97320
reinterpret_cast<
--- bridges/source/cpp_uno/gcc3_freebsd_x86-64/except.cxx 2009-06-13 15:39:58.000000000 +0900
+++ bridges/source/cpp_uno/gcc3_freebsd_x86-64/except.cxx 2009-06-13 15:42:43.000000000 +0900
-@@ -32,10 +32,10 @@
+@@ -32,6 +32,7 @@
#include "precompiled_bridges.hxx"
#include <stdio.h>
@@ -150,16 +150,12 @@ http://www.openoffice.org/issues/show_bug.cgi?id=97320
#include <dlfcn.h>
#include <cxxabi.h>
#include <hash_map>
--#include <sys/param.h>
-
- #include <rtl/strbuf.hxx>
- #include <rtl/ustrbuf.hxx>
@@ -121,7 +121,7 @@
};
//__________________________________________________________________________________________________
RTTI::RTTI() SAL_THROW( () )
-#if __FreeBSD_version < 602103
-+#ifdef FREEBSD /* #i22253# */
++#if __FreeBSD_version < 702104
: m_hApp( dlopen( 0, RTLD_NOW | RTLD_GLOBAL ) )
#else
: m_hApp( dlopen( 0, RTLD_LAZY ) )
@@ -168,7 +164,7 @@ http://www.openoffice.org/issues/show_bug.cgi?id=97320
OString symName( buf.makeStringAndClear() );
-#if __FreeBSD_version < 602103 /* #i22253# */
-+#ifdef FREEBSD /* #i22253# */
++#if __FreeBSD_version < 702104 /* #i22253# */
rtti = (type_info *)dlsym( RTLD_DEFAULT, symName.getStr() );
#else
rtti = (type_info *)dlsym( m_hApp, symName.getStr() );
diff --git a/editors/openoffice-3/files/patch-i98781 b/editors/openoffice-3/files/patch-i98781
index a1a6c99298e..8783a74433a 100644
--- a/editors/openoffice-3/files/patch-i98781
+++ b/editors/openoffice-3/files/patch-i98781
@@ -84,7 +84,7 @@ in files/patches-i85126
--- bridges/source/cpp_uno/gcc3_freebsd_intel/except.cxx 2009-06-13 14:17:39.000000000 +0900
+++ bridges/source/cpp_uno/gcc3_freebsd_intel/except.cxx 2009-06-13 15:14:24.000000000 +0900
-@@ -32,10 +32,10 @@
+@@ -32,6 +32,7 @@
#include "precompiled_bridges.hxx"
#include <stdio.h>
@@ -92,16 +92,12 @@ in files/patches-i85126
#include <dlfcn.h>
#include <cxxabi.h>
#include <hash_map>
--#include <sys/param.h>
-
- #include <rtl/strbuf.hxx>
- #include <rtl/ustrbuf.hxx>
@@ -121,7 +121,7 @@
};
//__________________________________________________________________________________________________
RTTI::RTTI() SAL_THROW( () )
-#if __FreeBSD_version < 602103
-+#ifdef FREEBSD /* #i22253# */
++#if __FreeBSD_version < 702104 /* #i22253# */
: m_hApp( dlopen( 0, RTLD_NOW | RTLD_GLOBAL ) )
#else
: m_hApp( dlopen( 0, RTLD_LAZY ) )
@@ -110,7 +106,7 @@ in files/patches-i85126
OString symName( buf.makeStringAndClear() );
-#if __FreeBSD_version < 602103 /* #i22253# */
-+#ifdef FREEBSD /* #i22253# */
++#if __FreeBSD_version < 702104 /* #i22253# */
rtti = (type_info *)dlsym( RTLD_DEFAULT, symName.getStr() );
#else
rtti = (type_info *)dlsym( m_hApp, symName.getStr() );
diff --git a/editors/openoffice.org-2-RC/files/patch-i85126 b/editors/openoffice.org-2-RC/files/patch-i85126
index c6bb6410bcb..61263d3e1d2 100644
--- a/editors/openoffice.org-2-RC/files/patch-i85126
+++ b/editors/openoffice.org-2-RC/files/patch-i85126
@@ -130,7 +130,7 @@ http://www.freebsd.org/cgi/query-pr.cgi?pr=127946
//__________________________________________________________________________________________________
RTTI::RTTI() SAL_THROW( () )
-#if __FreeBSD_version < 602103
-+#ifdef FREEBSD /* #i22253# */
++#if __FreeBSD_version < 702104
: m_hApp( dlopen( 0, RTLD_NOW | RTLD_GLOBAL ) )
#else
: m_hApp( dlopen( 0, RTLD_LAZY ) )
@@ -139,7 +139,7 @@ http://www.freebsd.org/cgi/query-pr.cgi?pr=127946
OString symName( buf.makeStringAndClear() );
-#if __FreeBSD_version < 602103 /* #i22253# */
-+#ifdef FREEBSD /* #i22253# */
++#if __FreeBSD_version < 702104 /* #i22253# */
rtti = (type_info *)dlsym( RTLD_DEFAULT, symName.getStr() );
#else
rtti = (type_info *)dlsym( m_hApp, symName.getStr() );
diff --git a/editors/openoffice.org-2-RC/files/patch-i98781 b/editors/openoffice.org-2-RC/files/patch-i98781
index 90f951045aa..c334d5b97b0 100644
--- a/editors/openoffice.org-2-RC/files/patch-i98781
+++ b/editors/openoffice.org-2-RC/files/patch-i98781
@@ -9,7 +9,7 @@ http://www.freebsd.org/cgi/query-pr.cgi?pr=127946
//__________________________________________________________________________________________________
RTTI::RTTI() SAL_THROW( () )
-#if __FreeBSD_version < 602103
-+#ifdef FREEBSD /* #i22253# */
++#if __FreeBSD_version < 702104 /* #i22253# */
: m_hApp( dlopen( 0, RTLD_NOW | RTLD_GLOBAL ) )
#else
: m_hApp( dlopen( 0, RTLD_LAZY ) )
@@ -18,7 +18,7 @@ http://www.freebsd.org/cgi/query-pr.cgi?pr=127946
OString symName( buf.makeStringAndClear() );
-#if __FreeBSD_version < 602103 /* #i22253# */
-+#ifdef FREEBSD /* #i22253# */
++#if __FreeBSD_version < 702104 /* #i22253# */
rtti = (type_info *)dlsym( RTLD_DEFAULT, symName.getStr() );
#else
rtti = (type_info *)dlsym( m_hApp, symName.getStr() );
diff --git a/editors/openoffice.org-2-devel/files/patch-i85126 b/editors/openoffice.org-2-devel/files/patch-i85126
index c6bb6410bcb..61263d3e1d2 100644
--- a/editors/openoffice.org-2-devel/files/patch-i85126
+++ b/editors/openoffice.org-2-devel/files/patch-i85126
@@ -130,7 +130,7 @@ http://www.freebsd.org/cgi/query-pr.cgi?pr=127946
//__________________________________________________________________________________________________
RTTI::RTTI() SAL_THROW( () )
-#if __FreeBSD_version < 602103
-+#ifdef FREEBSD /* #i22253# */
++#if __FreeBSD_version < 702104
: m_hApp( dlopen( 0, RTLD_NOW | RTLD_GLOBAL ) )
#else
: m_hApp( dlopen( 0, RTLD_LAZY ) )
@@ -139,7 +139,7 @@ http://www.freebsd.org/cgi/query-pr.cgi?pr=127946
OString symName( buf.makeStringAndClear() );
-#if __FreeBSD_version < 602103 /* #i22253# */
-+#ifdef FREEBSD /* #i22253# */
++#if __FreeBSD_version < 702104 /* #i22253# */
rtti = (type_info *)dlsym( RTLD_DEFAULT, symName.getStr() );
#else
rtti = (type_info *)dlsym( m_hApp, symName.getStr() );
diff --git a/editors/openoffice.org-2-devel/files/patch-i98781 b/editors/openoffice.org-2-devel/files/patch-i98781
index 90f951045aa..c334d5b97b0 100644
--- a/editors/openoffice.org-2-devel/files/patch-i98781
+++ b/editors/openoffice.org-2-devel/files/patch-i98781
@@ -9,7 +9,7 @@ http://www.freebsd.org/cgi/query-pr.cgi?pr=127946
//__________________________________________________________________________________________________
RTTI::RTTI() SAL_THROW( () )
-#if __FreeBSD_version < 602103
-+#ifdef FREEBSD /* #i22253# */
++#if __FreeBSD_version < 702104 /* #i22253# */
: m_hApp( dlopen( 0, RTLD_NOW | RTLD_GLOBAL ) )
#else
: m_hApp( dlopen( 0, RTLD_LAZY ) )
@@ -18,7 +18,7 @@ http://www.freebsd.org/cgi/query-pr.cgi?pr=127946
OString symName( buf.makeStringAndClear() );
-#if __FreeBSD_version < 602103 /* #i22253# */
-+#ifdef FREEBSD /* #i22253# */
++#if __FreeBSD_version < 702104 /* #i22253# */
rtti = (type_info *)dlsym( RTLD_DEFAULT, symName.getStr() );
#else
rtti = (type_info *)dlsym( m_hApp, symName.getStr() );
diff --git a/editors/openoffice.org-2/Makefile b/editors/openoffice.org-2/Makefile
index 92ba7248667..4e6ff9e87f6 100644
--- a/editors/openoffice.org-2/Makefile
+++ b/editors/openoffice.org-2/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= openoffice.org
PORTVERSION?= ${OOOVERSION}
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES+= editors java
MASTER_SITES+= http://ooopackages.good-day.net/pub/OpenOffice.org/sources/ \
ftp://ftp.cs.man.ac.uk/pub/toby/gpc/:gpc \
diff --git a/editors/openoffice.org-2/files/patch-i85126 b/editors/openoffice.org-2/files/patch-i85126
index c6bb6410bcb..61263d3e1d2 100644
--- a/editors/openoffice.org-2/files/patch-i85126
+++ b/editors/openoffice.org-2/files/patch-i85126
@@ -130,7 +130,7 @@ http://www.freebsd.org/cgi/query-pr.cgi?pr=127946
//__________________________________________________________________________________________________
RTTI::RTTI() SAL_THROW( () )
-#if __FreeBSD_version < 602103
-+#ifdef FREEBSD /* #i22253# */
++#if __FreeBSD_version < 702104
: m_hApp( dlopen( 0, RTLD_NOW | RTLD_GLOBAL ) )
#else
: m_hApp( dlopen( 0, RTLD_LAZY ) )
@@ -139,7 +139,7 @@ http://www.freebsd.org/cgi/query-pr.cgi?pr=127946
OString symName( buf.makeStringAndClear() );
-#if __FreeBSD_version < 602103 /* #i22253# */
-+#ifdef FREEBSD /* #i22253# */
++#if __FreeBSD_version < 702104 /* #i22253# */
rtti = (type_info *)dlsym( RTLD_DEFAULT, symName.getStr() );
#else
rtti = (type_info *)dlsym( m_hApp, symName.getStr() );
diff --git a/editors/openoffice.org-2/files/patch-i98781 b/editors/openoffice.org-2/files/patch-i98781
index 90f951045aa..c334d5b97b0 100644
--- a/editors/openoffice.org-2/files/patch-i98781
+++ b/editors/openoffice.org-2/files/patch-i98781
@@ -9,7 +9,7 @@ http://www.freebsd.org/cgi/query-pr.cgi?pr=127946
//__________________________________________________________________________________________________
RTTI::RTTI() SAL_THROW( () )
-#if __FreeBSD_version < 602103
-+#ifdef FREEBSD /* #i22253# */
++#if __FreeBSD_version < 702104 /* #i22253# */
: m_hApp( dlopen( 0, RTLD_NOW | RTLD_GLOBAL ) )
#else
: m_hApp( dlopen( 0, RTLD_LAZY ) )
@@ -18,7 +18,7 @@ http://www.freebsd.org/cgi/query-pr.cgi?pr=127946
OString symName( buf.makeStringAndClear() );
-#if __FreeBSD_version < 602103 /* #i22253# */
-+#ifdef FREEBSD /* #i22253# */
++#if __FreeBSD_version < 702104 /* #i22253# */
rtti = (type_info *)dlsym( RTLD_DEFAULT, symName.getStr() );
#else
rtti = (type_info *)dlsym( m_hApp, symName.getStr() );
diff --git a/editors/openoffice.org-3-RC/files/patch-i85126 b/editors/openoffice.org-3-RC/files/patch-i85126
index 15dfa190b16..d2b427c9991 100644
--- a/editors/openoffice.org-3-RC/files/patch-i85126
+++ b/editors/openoffice.org-3-RC/files/patch-i85126
@@ -142,7 +142,7 @@ http://www.openoffice.org/issues/show_bug.cgi?id=97320
reinterpret_cast<
--- bridges/source/cpp_uno/gcc3_freebsd_x86-64/except.cxx 2009-06-13 15:39:58.000000000 +0900
+++ bridges/source/cpp_uno/gcc3_freebsd_x86-64/except.cxx 2009-06-13 15:42:43.000000000 +0900
-@@ -32,10 +32,10 @@
+@@ -32,6 +32,7 @@
#include "precompiled_bridges.hxx"
#include <stdio.h>
@@ -150,16 +150,12 @@ http://www.openoffice.org/issues/show_bug.cgi?id=97320
#include <dlfcn.h>
#include <cxxabi.h>
#include <hash_map>
--#include <sys/param.h>
-
- #include <rtl/strbuf.hxx>
- #include <rtl/ustrbuf.hxx>
@@ -121,7 +121,7 @@
};
//__________________________________________________________________________________________________
RTTI::RTTI() SAL_THROW( () )
-#if __FreeBSD_version < 602103
-+#ifdef FREEBSD /* #i22253# */
++#if __FreeBSD_version < 702104 /* #i22253# */
: m_hApp( dlopen( 0, RTLD_NOW | RTLD_GLOBAL ) )
#else
: m_hApp( dlopen( 0, RTLD_LAZY ) )
@@ -168,7 +164,7 @@ http://www.openoffice.org/issues/show_bug.cgi?id=97320
OString symName( buf.makeStringAndClear() );
-#if __FreeBSD_version < 602103 /* #i22253# */
-+#ifdef FREEBSD /* #i22253# */
++#if __FreeBSD_version < 702104 /* #i22253# */
rtti = (type_info *)dlsym( RTLD_DEFAULT, symName.getStr() );
#else
rtti = (type_info *)dlsym( m_hApp, symName.getStr() );
diff --git a/editors/openoffice.org-3-RC/files/patch-i98781 b/editors/openoffice.org-3-RC/files/patch-i98781
index a1a6c99298e..8783a74433a 100644
--- a/editors/openoffice.org-3-RC/files/patch-i98781
+++ b/editors/openoffice.org-3-RC/files/patch-i98781
@@ -84,7 +84,7 @@ in files/patches-i85126
--- bridges/source/cpp_uno/gcc3_freebsd_intel/except.cxx 2009-06-13 14:17:39.000000000 +0900
+++ bridges/source/cpp_uno/gcc3_freebsd_intel/except.cxx 2009-06-13 15:14:24.000000000 +0900
-@@ -32,10 +32,10 @@
+@@ -32,6 +32,7 @@
#include "precompiled_bridges.hxx"
#include <stdio.h>
@@ -92,16 +92,12 @@ in files/patches-i85126
#include <dlfcn.h>
#include <cxxabi.h>
#include <hash_map>
--#include <sys/param.h>
-
- #include <rtl/strbuf.hxx>
- #include <rtl/ustrbuf.hxx>
@@ -121,7 +121,7 @@
};
//__________________________________________________________________________________________________
RTTI::RTTI() SAL_THROW( () )
-#if __FreeBSD_version < 602103
-+#ifdef FREEBSD /* #i22253# */
++#if __FreeBSD_version < 702104 /* #i22253# */
: m_hApp( dlopen( 0, RTLD_NOW | RTLD_GLOBAL ) )
#else
: m_hApp( dlopen( 0, RTLD_LAZY ) )
@@ -110,7 +106,7 @@ in files/patches-i85126
OString symName( buf.makeStringAndClear() );
-#if __FreeBSD_version < 602103 /* #i22253# */
-+#ifdef FREEBSD /* #i22253# */
++#if __FreeBSD_version < 702104 /* #i22253# */
rtti = (type_info *)dlsym( RTLD_DEFAULT, symName.getStr() );
#else
rtti = (type_info *)dlsym( m_hApp, symName.getStr() );
diff --git a/editors/openoffice.org-3-devel/files/patch-i85126 b/editors/openoffice.org-3-devel/files/patch-i85126
index 15dfa190b16..d2b427c9991 100644
--- a/editors/openoffice.org-3-devel/files/patch-i85126
+++ b/editors/openoffice.org-3-devel/files/patch-i85126
@@ -142,7 +142,7 @@ http://www.openoffice.org/issues/show_bug.cgi?id=97320
reinterpret_cast<
--- bridges/source/cpp_uno/gcc3_freebsd_x86-64/except.cxx 2009-06-13 15:39:58.000000000 +0900
+++ bridges/source/cpp_uno/gcc3_freebsd_x86-64/except.cxx 2009-06-13 15:42:43.000000000 +0900
-@@ -32,10 +32,10 @@
+@@ -32,6 +32,7 @@
#include "precompiled_bridges.hxx"
#include <stdio.h>
@@ -150,16 +150,12 @@ http://www.openoffice.org/issues/show_bug.cgi?id=97320
#include <dlfcn.h>
#include <cxxabi.h>
#include <hash_map>
--#include <sys/param.h>
-
- #include <rtl/strbuf.hxx>
- #include <rtl/ustrbuf.hxx>
@@ -121,7 +121,7 @@
};
//__________________________________________________________________________________________________
RTTI::RTTI() SAL_THROW( () )
-#if __FreeBSD_version < 602103
-+#ifdef FREEBSD /* #i22253# */
++#if __FreeBSD_version < 702104 /* #i22253# */
: m_hApp( dlopen( 0, RTLD_NOW | RTLD_GLOBAL ) )
#else
: m_hApp( dlopen( 0, RTLD_LAZY ) )
@@ -168,7 +164,7 @@ http://www.openoffice.org/issues/show_bug.cgi?id=97320
OString symName( buf.makeStringAndClear() );
-#if __FreeBSD_version < 602103 /* #i22253# */
-+#ifdef FREEBSD /* #i22253# */
++#if __FreeBSD_version < 702104 /* #i22253# */
rtti = (type_info *)dlsym( RTLD_DEFAULT, symName.getStr() );
#else
rtti = (type_info *)dlsym( m_hApp, symName.getStr() );
diff --git a/editors/openoffice.org-3-devel/files/patch-i98781 b/editors/openoffice.org-3-devel/files/patch-i98781
index a1a6c99298e..ca3849a011f 100644
--- a/editors/openoffice.org-3-devel/files/patch-i98781
+++ b/editors/openoffice.org-3-devel/files/patch-i98781
@@ -84,7 +84,7 @@ in files/patches-i85126
--- bridges/source/cpp_uno/gcc3_freebsd_intel/except.cxx 2009-06-13 14:17:39.000000000 +0900
+++ bridges/source/cpp_uno/gcc3_freebsd_intel/except.cxx 2009-06-13 15:14:24.000000000 +0900
-@@ -32,10 +32,10 @@
+@@ -32,6 +32,7 @@
#include "precompiled_bridges.hxx"
#include <stdio.h>
@@ -92,25 +92,21 @@ in files/patches-i85126
#include <dlfcn.h>
#include <cxxabi.h>
#include <hash_map>
--#include <sys/param.h>
-
- #include <rtl/strbuf.hxx>
- #include <rtl/ustrbuf.hxx>
-@@ -121,7 +121,7 @@
+@@ -121,7 +122,7 @@
};
//__________________________________________________________________________________________________
RTTI::RTTI() SAL_THROW( () )
-#if __FreeBSD_version < 602103
-+#ifdef FREEBSD /* #i22253# */
++#if __FreeBSD_version < 702104 /* #i22253# */
: m_hApp( dlopen( 0, RTLD_NOW | RTLD_GLOBAL ) )
#else
: m_hApp( dlopen( 0, RTLD_LAZY ) )
-@@ -160,7 +160,7 @@
+@@ -160,7 +161,7 @@
buf.append( 'E' );
OString symName( buf.makeStringAndClear() );
-#if __FreeBSD_version < 602103 /* #i22253# */
-+#ifdef FREEBSD /* #i22253# */
++#if __FreeBSD_version < 702104 /* #i22253# */
rtti = (type_info *)dlsym( RTLD_DEFAULT, symName.getStr() );
#else
rtti = (type_info *)dlsym( m_hApp, symName.getStr() );
diff --git a/editors/openoffice.org-3/Makefile b/editors/openoffice.org-3/Makefile
index d56f3f05864..97c398c7682 100644
--- a/editors/openoffice.org-3/Makefile
+++ b/editors/openoffice.org-3/Makefile
@@ -8,7 +8,7 @@
PORTNAME?= openoffice.org
PORTVERSION?= ${OOOVERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES+= editors java
MASTER_SITES+= http://ooopackages.good-day.net/pub/OpenOffice.org/sources/ \
ftp://ftp.cs.man.ac.uk/pub/toby/gpc/:gpc \
diff --git a/editors/openoffice.org-3/files/patch-i85126 b/editors/openoffice.org-3/files/patch-i85126
index 15dfa190b16..973ae74a51b 100644
--- a/editors/openoffice.org-3/files/patch-i85126
+++ b/editors/openoffice.org-3/files/patch-i85126
@@ -142,7 +142,7 @@ http://www.openoffice.org/issues/show_bug.cgi?id=97320
reinterpret_cast<
--- bridges/source/cpp_uno/gcc3_freebsd_x86-64/except.cxx 2009-06-13 15:39:58.000000000 +0900
+++ bridges/source/cpp_uno/gcc3_freebsd_x86-64/except.cxx 2009-06-13 15:42:43.000000000 +0900
-@@ -32,10 +32,10 @@
+@@ -32,6 +32,7 @@
#include "precompiled_bridges.hxx"
#include <stdio.h>
@@ -150,16 +150,12 @@ http://www.openoffice.org/issues/show_bug.cgi?id=97320
#include <dlfcn.h>
#include <cxxabi.h>
#include <hash_map>
--#include <sys/param.h>
-
- #include <rtl/strbuf.hxx>
- #include <rtl/ustrbuf.hxx>
@@ -121,7 +121,7 @@
};
//__________________________________________________________________________________________________
RTTI::RTTI() SAL_THROW( () )
-#if __FreeBSD_version < 602103
-+#ifdef FREEBSD /* #i22253# */
++#if __FreeBSD_version < 702104
: m_hApp( dlopen( 0, RTLD_NOW | RTLD_GLOBAL ) )
#else
: m_hApp( dlopen( 0, RTLD_LAZY ) )
@@ -168,7 +164,7 @@ http://www.openoffice.org/issues/show_bug.cgi?id=97320
OString symName( buf.makeStringAndClear() );
-#if __FreeBSD_version < 602103 /* #i22253# */
-+#ifdef FREEBSD /* #i22253# */
++#if __FreeBSD_version < 702104 /* #i22253# */
rtti = (type_info *)dlsym( RTLD_DEFAULT, symName.getStr() );
#else
rtti = (type_info *)dlsym( m_hApp, symName.getStr() );
diff --git a/editors/openoffice.org-3/files/patch-i98781 b/editors/openoffice.org-3/files/patch-i98781
index a1a6c99298e..8783a74433a 100644
--- a/editors/openoffice.org-3/files/patch-i98781
+++ b/editors/openoffice.org-3/files/patch-i98781
@@ -84,7 +84,7 @@ in files/patches-i85126
--- bridges/source/cpp_uno/gcc3_freebsd_intel/except.cxx 2009-06-13 14:17:39.000000000 +0900
+++ bridges/source/cpp_uno/gcc3_freebsd_intel/except.cxx 2009-06-13 15:14:24.000000000 +0900
-@@ -32,10 +32,10 @@
+@@ -32,6 +32,7 @@
#include "precompiled_bridges.hxx"
#include <stdio.h>
@@ -92,16 +92,12 @@ in files/patches-i85126
#include <dlfcn.h>
#include <cxxabi.h>
#include <hash_map>
--#include <sys/param.h>
-
- #include <rtl/strbuf.hxx>
- #include <rtl/ustrbuf.hxx>
@@ -121,7 +121,7 @@
};
//__________________________________________________________________________________________________
RTTI::RTTI() SAL_THROW( () )
-#if __FreeBSD_version < 602103
-+#ifdef FREEBSD /* #i22253# */
++#if __FreeBSD_version < 702104 /* #i22253# */
: m_hApp( dlopen( 0, RTLD_NOW | RTLD_GLOBAL ) )
#else
: m_hApp( dlopen( 0, RTLD_LAZY ) )
@@ -110,7 +106,7 @@ in files/patches-i85126
OString symName( buf.makeStringAndClear() );
-#if __FreeBSD_version < 602103 /* #i22253# */
-+#ifdef FREEBSD /* #i22253# */
++#if __FreeBSD_version < 702104 /* #i22253# */
rtti = (type_info *)dlsym( RTLD_DEFAULT, symName.getStr() );
#else
rtti = (type_info *)dlsym( m_hApp, symName.getStr() );
diff --git a/editors/openoffice.org-vcltesttool/files/patch-i85126 b/editors/openoffice.org-vcltesttool/files/patch-i85126
index c6bb6410bcb..61263d3e1d2 100644
--- a/editors/openoffice.org-vcltesttool/files/patch-i85126
+++ b/editors/openoffice.org-vcltesttool/files/patch-i85126
@@ -130,7 +130,7 @@ http://www.freebsd.org/cgi/query-pr.cgi?pr=127946
//__________________________________________________________________________________________________
RTTI::RTTI() SAL_THROW( () )
-#if __FreeBSD_version < 602103
-+#ifdef FREEBSD /* #i22253# */
++#if __FreeBSD_version < 702104
: m_hApp( dlopen( 0, RTLD_NOW | RTLD_GLOBAL ) )
#else
: m_hApp( dlopen( 0, RTLD_LAZY ) )
@@ -139,7 +139,7 @@ http://www.freebsd.org/cgi/query-pr.cgi?pr=127946
OString symName( buf.makeStringAndClear() );
-#if __FreeBSD_version < 602103 /* #i22253# */
-+#ifdef FREEBSD /* #i22253# */
++#if __FreeBSD_version < 702104 /* #i22253# */
rtti = (type_info *)dlsym( RTLD_DEFAULT, symName.getStr() );
#else
rtti = (type_info *)dlsym( m_hApp, symName.getStr() );
diff --git a/editors/openoffice.org-vcltesttool/files/patch-i98781 b/editors/openoffice.org-vcltesttool/files/patch-i98781
index 90f951045aa..c334d5b97b0 100644
--- a/editors/openoffice.org-vcltesttool/files/patch-i98781
+++ b/editors/openoffice.org-vcltesttool/files/patch-i98781
@@ -9,7 +9,7 @@ http://www.freebsd.org/cgi/query-pr.cgi?pr=127946
//__________________________________________________________________________________________________
RTTI::RTTI() SAL_THROW( () )
-#if __FreeBSD_version < 602103
-+#ifdef FREEBSD /* #i22253# */
++#if __FreeBSD_version < 702104 /* #i22253# */
: m_hApp( dlopen( 0, RTLD_NOW | RTLD_GLOBAL ) )
#else
: m_hApp( dlopen( 0, RTLD_LAZY ) )
@@ -18,7 +18,7 @@ http://www.freebsd.org/cgi/query-pr.cgi?pr=127946
OString symName( buf.makeStringAndClear() );
-#if __FreeBSD_version < 602103 /* #i22253# */
-+#ifdef FREEBSD /* #i22253# */
++#if __FreeBSD_version < 702104 /* #i22253# */
rtti = (type_info *)dlsym( RTLD_DEFAULT, symName.getStr() );
#else
rtti = (type_info *)dlsym( m_hApp, symName.getStr() );