aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2005-06-19 10:31:48 +0800
committermaho <maho@FreeBSD.org>2005-06-19 10:31:48 +0800
commitbf53891e7d4d85b3c4a9d4e87c88c4ec4d21d6da (patch)
treec7da637ee7835c6700dcaa46e734233a1db748db /editors
parentf79dbf7f7ca0b61ad8f2ff4b9c2ab5315ee7f873 (diff)
downloadfreebsd-ports-graphics-bf53891e7d4d85b3c4a9d4e87c88c4ec4d21d6da.tar.gz
freebsd-ports-graphics-bf53891e7d4d85b3c4a9d4e87c88c4ec4d21d6da.tar.zst
freebsd-ports-graphics-bf53891e7d4d85b3c4a9d4e87c88c4ec4d21d6da.zip
call uname needlessly.
SIMPLEOSVER by parsing the output of `uname -r`. This is pointless, since the same data can be obtained from the (already generated) OSREL variable. PR: 76330 Submitted by: Colin Percival <cperciva@hexahedron.daemonology.net>
Diffstat (limited to 'editors')
-rw-r--r--editors/openoffice-1.1-devel/Makefile2
-rw-r--r--editors/openoffice-1.1/Makefile2
-rw-r--r--editors/openoffice-2.0-devel/Makefile2
-rw-r--r--editors/openoffice-3-devel/Makefile2
-rw-r--r--editors/openoffice-3/Makefile2
-rw-r--r--editors/openoffice.org-1.1-devel/Makefile2
-rw-r--r--editors/openoffice.org-1.1/Makefile2
-rw-r--r--editors/openoffice.org-2-RC/Makefile2
-rw-r--r--editors/openoffice.org-2-devel/Makefile2
-rw-r--r--editors/openoffice.org-2.0-devel/Makefile2
-rw-r--r--editors/openoffice.org-2.0/Makefile2
-rw-r--r--editors/openoffice.org-2/Makefile2
-rw-r--r--editors/openoffice.org-3-RC/Makefile2
-rw-r--r--editors/openoffice.org-3-devel/Makefile2
-rw-r--r--editors/openoffice.org-3/Makefile2
-rw-r--r--editors/openoffice.org-vcltesttool/Makefile2
16 files changed, 16 insertions, 16 deletions
diff --git a/editors/openoffice-1.1-devel/Makefile b/editors/openoffice-1.1-devel/Makefile
index 28189da4b5e..5f7da978b30 100644
--- a/editors/openoffice-1.1-devel/Makefile
+++ b/editors/openoffice-1.1-devel/Makefile
@@ -89,7 +89,7 @@ SNAPDATE= 20050615
INSTALLATION_BASEDIR= OpenOffice.org${RELEASE_NR}
EXECBASE= openoffice.org-${RELEASE_NR}m${MILESTONE}
DIST_SUBDIR= openoffice.org1.1
-SIMPLEOSVER!= ${UNAME} -r | ${SED} -e 's/\.//g' | ${SED} -e 's/-.*//'
+SIMPLEOSVER= ${OSREL:C/\.//g}
PACKAGE_BASENAME= OOo_${RELEASE_NR}m${MILESTONE}_${OPSYS}${SIMPLEOSVER}Intel
# FIXME (Somehow INDEX build fails)
diff --git a/editors/openoffice-1.1/Makefile b/editors/openoffice-1.1/Makefile
index 53a639fe763..a3eff4ca809 100644
--- a/editors/openoffice-1.1/Makefile
+++ b/editors/openoffice-1.1/Makefile
@@ -91,7 +91,7 @@ RELEASE_NR= ${PORTVERSION}
INSTALLATION_BASEDIR= OpenOffice.org${RELEASE_NR}
EXECBASE= openoffice.org-${RELEASE_NR}
DIST_SUBDIR= openoffice.org1.1
-SIMPLEOSVER!= ${UNAME} -r | ${SED} -e 's/\.//g' | ${SED} -e 's/-.*//'
+SIMPLEOSVER= ${OSREL:C/\.//g}
PACKAGE_BASENAME= OOo_${PORTVERSION}_${OPSYS}${SIMPLEOSVER}Intel
# FIXME (Somehow INDEX build fails)
diff --git a/editors/openoffice-2.0-devel/Makefile b/editors/openoffice-2.0-devel/Makefile
index 56b9220d0ed..f878bb2acc2 100644
--- a/editors/openoffice-2.0-devel/Makefile
+++ b/editors/openoffice-2.0-devel/Makefile
@@ -53,7 +53,7 @@ SNAPDATE= 20050616
INSTALLATION_BASEDIR= openoffice.org${RELEASE_NR}m${MILESTONE}
EXECBASE= openoffice.org-${RELEASE_NR}m${MILESTONE}
DIST_SUBDIR= openoffice.org2.0
-SIMPLEOSVER!= ${UNAME} -r | ${SED} -e 's/\.//g' | ${SED} -e 's/-.*//'
+SIMPLEOSVER= ${OSREL:C/\.//g}
PACKAGE_BASENAME= OOo_${RELEASE_NR}m${MILESTONE}_${OPSYS}${SIMPLEOSVER}Intel
LOCALIZED_LANG?= en-US
diff --git a/editors/openoffice-3-devel/Makefile b/editors/openoffice-3-devel/Makefile
index 56b9220d0ed..f878bb2acc2 100644
--- a/editors/openoffice-3-devel/Makefile
+++ b/editors/openoffice-3-devel/Makefile
@@ -53,7 +53,7 @@ SNAPDATE= 20050616
INSTALLATION_BASEDIR= openoffice.org${RELEASE_NR}m${MILESTONE}
EXECBASE= openoffice.org-${RELEASE_NR}m${MILESTONE}
DIST_SUBDIR= openoffice.org2.0
-SIMPLEOSVER!= ${UNAME} -r | ${SED} -e 's/\.//g' | ${SED} -e 's/-.*//'
+SIMPLEOSVER= ${OSREL:C/\.//g}
PACKAGE_BASENAME= OOo_${RELEASE_NR}m${MILESTONE}_${OPSYS}${SIMPLEOSVER}Intel
LOCALIZED_LANG?= en-US
diff --git a/editors/openoffice-3/Makefile b/editors/openoffice-3/Makefile
index 56b9220d0ed..f878bb2acc2 100644
--- a/editors/openoffice-3/Makefile
+++ b/editors/openoffice-3/Makefile
@@ -53,7 +53,7 @@ SNAPDATE= 20050616
INSTALLATION_BASEDIR= openoffice.org${RELEASE_NR}m${MILESTONE}
EXECBASE= openoffice.org-${RELEASE_NR}m${MILESTONE}
DIST_SUBDIR= openoffice.org2.0
-SIMPLEOSVER!= ${UNAME} -r | ${SED} -e 's/\.//g' | ${SED} -e 's/-.*//'
+SIMPLEOSVER= ${OSREL:C/\.//g}
PACKAGE_BASENAME= OOo_${RELEASE_NR}m${MILESTONE}_${OPSYS}${SIMPLEOSVER}Intel
LOCALIZED_LANG?= en-US
diff --git a/editors/openoffice.org-1.1-devel/Makefile b/editors/openoffice.org-1.1-devel/Makefile
index 28189da4b5e..5f7da978b30 100644
--- a/editors/openoffice.org-1.1-devel/Makefile
+++ b/editors/openoffice.org-1.1-devel/Makefile
@@ -89,7 +89,7 @@ SNAPDATE= 20050615
INSTALLATION_BASEDIR= OpenOffice.org${RELEASE_NR}
EXECBASE= openoffice.org-${RELEASE_NR}m${MILESTONE}
DIST_SUBDIR= openoffice.org1.1
-SIMPLEOSVER!= ${UNAME} -r | ${SED} -e 's/\.//g' | ${SED} -e 's/-.*//'
+SIMPLEOSVER= ${OSREL:C/\.//g}
PACKAGE_BASENAME= OOo_${RELEASE_NR}m${MILESTONE}_${OPSYS}${SIMPLEOSVER}Intel
# FIXME (Somehow INDEX build fails)
diff --git a/editors/openoffice.org-1.1/Makefile b/editors/openoffice.org-1.1/Makefile
index 53a639fe763..a3eff4ca809 100644
--- a/editors/openoffice.org-1.1/Makefile
+++ b/editors/openoffice.org-1.1/Makefile
@@ -91,7 +91,7 @@ RELEASE_NR= ${PORTVERSION}
INSTALLATION_BASEDIR= OpenOffice.org${RELEASE_NR}
EXECBASE= openoffice.org-${RELEASE_NR}
DIST_SUBDIR= openoffice.org1.1
-SIMPLEOSVER!= ${UNAME} -r | ${SED} -e 's/\.//g' | ${SED} -e 's/-.*//'
+SIMPLEOSVER= ${OSREL:C/\.//g}
PACKAGE_BASENAME= OOo_${PORTVERSION}_${OPSYS}${SIMPLEOSVER}Intel
# FIXME (Somehow INDEX build fails)
diff --git a/editors/openoffice.org-2-RC/Makefile b/editors/openoffice.org-2-RC/Makefile
index 56b9220d0ed..f878bb2acc2 100644
--- a/editors/openoffice.org-2-RC/Makefile
+++ b/editors/openoffice.org-2-RC/Makefile
@@ -53,7 +53,7 @@ SNAPDATE= 20050616
INSTALLATION_BASEDIR= openoffice.org${RELEASE_NR}m${MILESTONE}
EXECBASE= openoffice.org-${RELEASE_NR}m${MILESTONE}
DIST_SUBDIR= openoffice.org2.0
-SIMPLEOSVER!= ${UNAME} -r | ${SED} -e 's/\.//g' | ${SED} -e 's/-.*//'
+SIMPLEOSVER= ${OSREL:C/\.//g}
PACKAGE_BASENAME= OOo_${RELEASE_NR}m${MILESTONE}_${OPSYS}${SIMPLEOSVER}Intel
LOCALIZED_LANG?= en-US
diff --git a/editors/openoffice.org-2-devel/Makefile b/editors/openoffice.org-2-devel/Makefile
index 56b9220d0ed..f878bb2acc2 100644
--- a/editors/openoffice.org-2-devel/Makefile
+++ b/editors/openoffice.org-2-devel/Makefile
@@ -53,7 +53,7 @@ SNAPDATE= 20050616
INSTALLATION_BASEDIR= openoffice.org${RELEASE_NR}m${MILESTONE}
EXECBASE= openoffice.org-${RELEASE_NR}m${MILESTONE}
DIST_SUBDIR= openoffice.org2.0
-SIMPLEOSVER!= ${UNAME} -r | ${SED} -e 's/\.//g' | ${SED} -e 's/-.*//'
+SIMPLEOSVER= ${OSREL:C/\.//g}
PACKAGE_BASENAME= OOo_${RELEASE_NR}m${MILESTONE}_${OPSYS}${SIMPLEOSVER}Intel
LOCALIZED_LANG?= en-US
diff --git a/editors/openoffice.org-2.0-devel/Makefile b/editors/openoffice.org-2.0-devel/Makefile
index 56b9220d0ed..f878bb2acc2 100644
--- a/editors/openoffice.org-2.0-devel/Makefile
+++ b/editors/openoffice.org-2.0-devel/Makefile
@@ -53,7 +53,7 @@ SNAPDATE= 20050616
INSTALLATION_BASEDIR= openoffice.org${RELEASE_NR}m${MILESTONE}
EXECBASE= openoffice.org-${RELEASE_NR}m${MILESTONE}
DIST_SUBDIR= openoffice.org2.0
-SIMPLEOSVER!= ${UNAME} -r | ${SED} -e 's/\.//g' | ${SED} -e 's/-.*//'
+SIMPLEOSVER= ${OSREL:C/\.//g}
PACKAGE_BASENAME= OOo_${RELEASE_NR}m${MILESTONE}_${OPSYS}${SIMPLEOSVER}Intel
LOCALIZED_LANG?= en-US
diff --git a/editors/openoffice.org-2.0/Makefile b/editors/openoffice.org-2.0/Makefile
index 56b9220d0ed..f878bb2acc2 100644
--- a/editors/openoffice.org-2.0/Makefile
+++ b/editors/openoffice.org-2.0/Makefile
@@ -53,7 +53,7 @@ SNAPDATE= 20050616
INSTALLATION_BASEDIR= openoffice.org${RELEASE_NR}m${MILESTONE}
EXECBASE= openoffice.org-${RELEASE_NR}m${MILESTONE}
DIST_SUBDIR= openoffice.org2.0
-SIMPLEOSVER!= ${UNAME} -r | ${SED} -e 's/\.//g' | ${SED} -e 's/-.*//'
+SIMPLEOSVER= ${OSREL:C/\.//g}
PACKAGE_BASENAME= OOo_${RELEASE_NR}m${MILESTONE}_${OPSYS}${SIMPLEOSVER}Intel
LOCALIZED_LANG?= en-US
diff --git a/editors/openoffice.org-2/Makefile b/editors/openoffice.org-2/Makefile
index 56b9220d0ed..f878bb2acc2 100644
--- a/editors/openoffice.org-2/Makefile
+++ b/editors/openoffice.org-2/Makefile
@@ -53,7 +53,7 @@ SNAPDATE= 20050616
INSTALLATION_BASEDIR= openoffice.org${RELEASE_NR}m${MILESTONE}
EXECBASE= openoffice.org-${RELEASE_NR}m${MILESTONE}
DIST_SUBDIR= openoffice.org2.0
-SIMPLEOSVER!= ${UNAME} -r | ${SED} -e 's/\.//g' | ${SED} -e 's/-.*//'
+SIMPLEOSVER= ${OSREL:C/\.//g}
PACKAGE_BASENAME= OOo_${RELEASE_NR}m${MILESTONE}_${OPSYS}${SIMPLEOSVER}Intel
LOCALIZED_LANG?= en-US
diff --git a/editors/openoffice.org-3-RC/Makefile b/editors/openoffice.org-3-RC/Makefile
index 56b9220d0ed..f878bb2acc2 100644
--- a/editors/openoffice.org-3-RC/Makefile
+++ b/editors/openoffice.org-3-RC/Makefile
@@ -53,7 +53,7 @@ SNAPDATE= 20050616
INSTALLATION_BASEDIR= openoffice.org${RELEASE_NR}m${MILESTONE}
EXECBASE= openoffice.org-${RELEASE_NR}m${MILESTONE}
DIST_SUBDIR= openoffice.org2.0
-SIMPLEOSVER!= ${UNAME} -r | ${SED} -e 's/\.//g' | ${SED} -e 's/-.*//'
+SIMPLEOSVER= ${OSREL:C/\.//g}
PACKAGE_BASENAME= OOo_${RELEASE_NR}m${MILESTONE}_${OPSYS}${SIMPLEOSVER}Intel
LOCALIZED_LANG?= en-US
diff --git a/editors/openoffice.org-3-devel/Makefile b/editors/openoffice.org-3-devel/Makefile
index 56b9220d0ed..f878bb2acc2 100644
--- a/editors/openoffice.org-3-devel/Makefile
+++ b/editors/openoffice.org-3-devel/Makefile
@@ -53,7 +53,7 @@ SNAPDATE= 20050616
INSTALLATION_BASEDIR= openoffice.org${RELEASE_NR}m${MILESTONE}
EXECBASE= openoffice.org-${RELEASE_NR}m${MILESTONE}
DIST_SUBDIR= openoffice.org2.0
-SIMPLEOSVER!= ${UNAME} -r | ${SED} -e 's/\.//g' | ${SED} -e 's/-.*//'
+SIMPLEOSVER= ${OSREL:C/\.//g}
PACKAGE_BASENAME= OOo_${RELEASE_NR}m${MILESTONE}_${OPSYS}${SIMPLEOSVER}Intel
LOCALIZED_LANG?= en-US
diff --git a/editors/openoffice.org-3/Makefile b/editors/openoffice.org-3/Makefile
index 56b9220d0ed..f878bb2acc2 100644
--- a/editors/openoffice.org-3/Makefile
+++ b/editors/openoffice.org-3/Makefile
@@ -53,7 +53,7 @@ SNAPDATE= 20050616
INSTALLATION_BASEDIR= openoffice.org${RELEASE_NR}m${MILESTONE}
EXECBASE= openoffice.org-${RELEASE_NR}m${MILESTONE}
DIST_SUBDIR= openoffice.org2.0
-SIMPLEOSVER!= ${UNAME} -r | ${SED} -e 's/\.//g' | ${SED} -e 's/-.*//'
+SIMPLEOSVER= ${OSREL:C/\.//g}
PACKAGE_BASENAME= OOo_${RELEASE_NR}m${MILESTONE}_${OPSYS}${SIMPLEOSVER}Intel
LOCALIZED_LANG?= en-US
diff --git a/editors/openoffice.org-vcltesttool/Makefile b/editors/openoffice.org-vcltesttool/Makefile
index 56b9220d0ed..f878bb2acc2 100644
--- a/editors/openoffice.org-vcltesttool/Makefile
+++ b/editors/openoffice.org-vcltesttool/Makefile
@@ -53,7 +53,7 @@ SNAPDATE= 20050616
INSTALLATION_BASEDIR= openoffice.org${RELEASE_NR}m${MILESTONE}
EXECBASE= openoffice.org-${RELEASE_NR}m${MILESTONE}
DIST_SUBDIR= openoffice.org2.0
-SIMPLEOSVER!= ${UNAME} -r | ${SED} -e 's/\.//g' | ${SED} -e 's/-.*//'
+SIMPLEOSVER= ${OSREL:C/\.//g}
PACKAGE_BASENAME= OOo_${RELEASE_NR}m${MILESTONE}_${OPSYS}${SIMPLEOSVER}Intel
LOCALIZED_LANG?= en-US