aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/qemu
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2008-03-05 06:22:56 +0800
committernox <nox@FreeBSD.org>2008-03-05 06:22:56 +0800
commit833824b76f0768c611e5a75ab8fce154968163bc (patch)
tree924cfc317e08b5c6f7ea6788ae3a73457afb6dfe /emulators/qemu
parent77599230bb4f5a584ce8dddba016c1d72bdcb6c6 (diff)
downloadfreebsd-ports-graphics-833824b76f0768c611e5a75ab8fce154968163bc.tar.gz
freebsd-ports-graphics-833824b76f0768c611e5a75ab8fce154968163bc.tar.zst
freebsd-ports-graphics-833824b76f0768c611e5a75ab8fce154968163bc.zip
Add knob to explicitly add/remove gnutls dependency
Noticed by: jkim
Diffstat (limited to 'emulators/qemu')
-rw-r--r--emulators/qemu/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index be8b87b5ec3..e2d880d2b30 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -7,6 +7,7 @@
PORTNAME= qemu
PORTVERSION= 0.9.1
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= http://fabrice.bellard.free.fr/qemu/:release \
http://qemu.org/:release \
@@ -34,6 +35,7 @@ OPTIONS= KQEMU "Build with (alpha!) accelerator module" Off \
RTL8139_TIMER "allow use of re(4) nic with FreeBSD guests" Off \
SAMBA "samba dependency (for -smb)" Off \
SDL "SDL/X dependency (graphical output)" On \
+ GNUTLS "gnutls dependency (vnc encryption)" On \
CDROM_DMA "IDE CDROM DMA" On
.include <bsd.port.pre.mk>
@@ -53,6 +55,12 @@ CONFIGURE_ARGS+= --disable-sdl --disable-gfx-check
USE_SDL= sdl
.endif
+.if defined(WITHOUT_GNUTLS)
+CONFIGURE_ARGS+= --disable-vnc-tls
+.else
+LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
+.endif
+
.if defined (WITH_HACKS_CIRRUS) || defined (WITH_HACKS)
DISTFILES+= patch3_cirrus:misc
.endif