aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/rtc
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2006-01-30 00:09:18 +0800
committernetchild <netchild@FreeBSD.org>2006-01-30 00:09:18 +0800
commitb8ea196ab4b54282d71205648e6dd8ec01ea8b5c (patch)
tree9cffd72e94dc34ee5a710a0876024c96e828a5a8 /emulators/rtc
parent106e1fba6d5f0ad6a820546b2b36f4e100aad096 (diff)
downloadfreebsd-ports-graphics-b8ea196ab4b54282d71205648e6dd8ec01ea8b5c.tar.gz
freebsd-ports-graphics-b8ea196ab4b54282d71205648e6dd8ec01ea8b5c.tar.zst
freebsd-ports-graphics-b8ea196ab4b54282d71205648e6dd8ec01ea8b5c.zip
Users are confused by a diagnostic message more than they are
helped because it is printing the -current- value of HZ, not the value requested. This is fixed be rearranging the order of changing the value and printing the message (they are in adjacent lines). Submitted by: rgrimes
Diffstat (limited to 'emulators/rtc')
-rw-r--r--emulators/rtc/Makefile2
-rw-r--r--emulators/rtc/files/rtc.c2
2 files changed, 2 insertions, 2 deletions
diff --git a/emulators/rtc/Makefile b/emulators/rtc/Makefile
index e69104f1450..3bc1152f0c4 100644
--- a/emulators/rtc/Makefile
+++ b/emulators/rtc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= rtc
PORTVERSION= 2004.02.24.1
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= emulators linux
MASTER_SITES= # none
DISTFILES= # none
diff --git a/emulators/rtc/files/rtc.c b/emulators/rtc/files/rtc.c
index 16f573caaf0..c038575e4d1 100644
--- a/emulators/rtc/files/rtc.c
+++ b/emulators/rtc/files/rtc.c
@@ -269,8 +269,8 @@ rtc_ioctl(dev_t dev, u_long cmd, caddr_t arg, int mode, struct proc *p)
}
sc->var.freq = freq;
if ((sc->var.freq > hz) && (hz < 1000)) {
- sc->var.freq = hz;
printf("rtc: %d > kern.hz: Timing will be inaccurate, please increase kern.hz.\n", sc->var.freq);
+ sc->var.freq = hz;
}
sleep = hz / sc->var.freq;
DLog(Linfo, "Set RTC freq %d", sc->var.freq);