aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/virtualbox-ose-legacy
diff options
context:
space:
mode:
authordecke <decke@FreeBSD.org>2012-02-21 20:43:15 +0800
committerdecke <decke@FreeBSD.org>2012-02-21 20:43:15 +0800
commit8b38e4f901be9685128408d03a10d564a7024762 (patch)
treeca29822f411592d3628e8a8309c19ef0e8d3d9b2 /emulators/virtualbox-ose-legacy
parent68902d7b7a7cdbfc4c2a2b5d5ee5eaa9f34971d6 (diff)
downloadfreebsd-ports-graphics-8b38e4f901be9685128408d03a10d564a7024762.tar.gz
freebsd-ports-graphics-8b38e4f901be9685128408d03a10d564a7024762.tar.zst
freebsd-ports-graphics-8b38e4f901be9685128408d03a10d564a7024762.zip
- Update to 4.0.16
- Fix lib32 checks to use /usr/lib32/libc.so Obtained from: redports.org/~virtualbox/
Diffstat (limited to 'emulators/virtualbox-ose-legacy')
-rw-r--r--emulators/virtualbox-ose-legacy/Makefile21
-rw-r--r--emulators/virtualbox-ose-legacy/distinfo8
-rw-r--r--emulators/virtualbox-ose-legacy/files/patch-src-VBox-Devices-Makefile.kmk22
-rw-r--r--emulators/virtualbox-ose-legacy/files/patch-src-VBox-Devices-Storage-DrvHostDVD.cpp14
-rw-r--r--emulators/virtualbox-ose-legacy/files/patch-src-VBox-Frontends-VBoxManage-VBoxInternalManage.cpp48
-rw-r--r--emulators/virtualbox-ose-legacy/files/patch-src-VBox-Frontends-VirtualBox-src-settings-vm-VBoxVMSettingsHD.h11
-rw-r--r--emulators/virtualbox-ose-legacy/files/patch-src-VBox-Main-freebsd-NetIf-freebsd.cpp30
-rw-r--r--emulators/virtualbox-ose-legacy/files/patch-src-VBox-Main-src-server-freebsd-HostHardwareFreeBSD.cpp (renamed from emulators/virtualbox-ose-legacy/files/patch-src-VBox-Main-freebsd-HostHardwareFreeBSD.cpp)4
-rw-r--r--emulators/virtualbox-ose-legacy/files/patch-src-VBox-Runtime-r3-freebsd-fileaio-freebsd.c16
-rw-r--r--emulators/virtualbox-ose-legacy/files/patch-src-VBox-VMM-VMMR3-CPUM.cpp12
-rw-r--r--emulators/virtualbox-ose-legacy/pkg-message36
-rw-r--r--emulators/virtualbox-ose-legacy/pkg-plist5
12 files changed, 95 insertions, 132 deletions
diff --git a/emulators/virtualbox-ose-legacy/Makefile b/emulators/virtualbox-ose-legacy/Makefile
index 3d22fecee6c..6830445b954 100644
--- a/emulators/virtualbox-ose-legacy/Makefile
+++ b/emulators/virtualbox-ose-legacy/Makefile
@@ -6,16 +6,15 @@
#
PORTNAME= virtualbox-ose
-DISTVERSION= 3.2.12
-PORTREVISION= 4
+DISTVERSION= 4.0.16
CATEGORIES= emulators
MASTER_SITES= http://tmp.chruetertee.ch/ \
http://freebsd.unixfreunde.de/sources/ \
http://disasterarea.chruetertee.ch/ \
http://dlc.sun.com/virtualbox/${VBOX_GUEST_VER}/:guestadditions
PKGNAMESUFFIX= -legacy
-DISTFILES= VirtualBox-${DISTVERSION}-OSE${EXTRACT_SUFX} ${GADISTFILES}
-EXTRACT_ONLY= VirtualBox-${DISTVERSION}-OSE${EXTRACT_SUFX}
+DISTFILES= VirtualBox-${DISTVERSION}${EXTRACT_SUFX} ${GADISTFILES}
+EXTRACT_ONLY= VirtualBox-${DISTVERSION}${EXTRACT_SUFX}
#for discussion please use emulation@FreeBSD.org
MAINTAINER= vbox@FreeBSD.org
@@ -35,6 +34,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
WRKSRC= ${WRKDIR}/VirtualBox-${PORTVERSION}_OSE
ONLY_FOR_ARCHS= i386 amd64
+USE_CDRTOOLS= yes
USE_GNOME= libidl
USE_BZIP2= yes
USE_PYTHON= yes
@@ -48,6 +48,7 @@ CONFIGURE_ARGS+=--with-gcc="${CC}" --with-g++="${CXX}" --passive-mesa
USE_LDCONFIG= ${PREFIX}/lib/virtualbox
CONFLICTS= bcc-[0-9]*
+CONFLICTS_BUILD= kBuild-devel-[0-9]*
CONFLICTS_INSTALL= virtualbox-ose-[3,4]* virtualbox-ose-devel-[3,4]* virtualbox-ose-additions-[3,4]* virtualbox-ose-additions-devel-[3,4]*
VBOXUSER?= vboxusers
@@ -185,7 +186,7 @@ EXTRA_PATCHES+= ${FILESDIR}/extrapatch-src-VBox-Devices-PC-vbox.dsl
pre-everything::
.if ${ARCH} == "amd64"
-.if !exists(/usr/lib32)
+.if !exists(/usr/lib32/libc.so)
@${ECHO} 'Requires 32-bit libraries installed under /usr/lib32.'
@${ECHO} 'Do: cd /usr/src; make build32 install32; /etc/rc.d/ldconfig restart'
@${FALSE}
@@ -211,6 +212,9 @@ post-patch:
.if defined(WITH_VNC)
@${ECHO} 'VBOX_WITH_VNC = 1' >> ${WRKSRC}/LocalConfig.kmk
.endif
+.if ${OSVERSION} < 800069
+ @${ECHO} 'VBOX_WITH_USB=' >> ${WRKSRC}/LocalConfig.kmk
+.endif
.if defined(WITH_WEBSERVICE)
@${ECHO} 'VBOX_WITH_WEBSERVICES = 1' >> ${WRKSRC}/LocalConfig.kmk
@${ECHO} 'VBOX_GSOAP_INSTALLED = 1' >> ${WRKSRC}/LocalConfig.kmk
@@ -241,7 +245,7 @@ do-install:
(cd ${WRKSRC}/out/${KMK_ARCH}/${KMK_BUILDTYPE}/bin/sdk/bindings/xpcom/include && ${COPYTREE_SHARE} "*" ${PREFIX}/include/virtualbox)
${MKDIR} ${PREFIX}/lib/virtualbox
- (cd ${WRKSRC}/out/${KMK_ARCH}/${KMK_BUILDTYPE}/bin && ${COPYTREE_SHARE} "*.so *.gc *.r0 *.fd components" ${PREFIX}/lib/virtualbox)
+ (cd ${WRKSRC}/out/${KMK_ARCH}/${KMK_BUILDTYPE}/bin && ${COPYTREE_SHARE} "*.so *.gc *.r0 *.fd components VBoxExtPackHelperApp" ${PREFIX}/lib/virtualbox)
.if !defined(WITHOUT_NLS)
${MKDIR} ${DATADIR}/nls
@@ -258,7 +262,7 @@ do-install:
${CHMOD} 4511 ${PREFIX}/lib/virtualbox/${f}
.endfor
-.for f in VBoxManage VBoxSVC VBoxXPCOMIPCD
+.for f in VBoxManage VBoxSVC VBoxXPCOMIPCD VBoxExtPackHelperApp
${CHMOD} 0711 ${PREFIX}/lib/virtualbox/${f}
.endfor
@@ -283,7 +287,7 @@ do-install:
${PYTHON_CMD} -mcompileall ${PYTHON_SITELIBDIR}/xpcom/
post-install:
-.for f in VBoxManage VBoxNetDHCP VBoxSVC VBoxXPCOMIPCD ${VBOX_FRONTENDS}
+.for f in VBoxManage VBoxNetDHCP VBoxSVC VBoxXPCOMIPCD VBoxExtPackHelperApp ${VBOX_FRONTENDS}
${CHOWN} root:${VBOXGROUP} ${PREFIX}/lib/virtualbox/${f}
.endfor
@@ -300,3 +304,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
+
diff --git a/emulators/virtualbox-ose-legacy/distinfo b/emulators/virtualbox-ose-legacy/distinfo
index a04a6e98292..31b4828107a 100644
--- a/emulators/virtualbox-ose-legacy/distinfo
+++ b/emulators/virtualbox-ose-legacy/distinfo
@@ -1,4 +1,4 @@
-SHA256 (VirtualBox-3.2.12-OSE.tar.bz2) = 064eb382e5b752a3f9189c930734393765125e70b5f99679a63ff4eb6186e261
-SIZE (VirtualBox-3.2.12-OSE.tar.bz2) = 58239733
-SHA256 (VBoxGuestAdditions_3.2.12.iso) = cae0d7c7d3844188caf01973dc97a722a70b2ba18ff189c9b8e82afb771de436
-SIZE (VBoxGuestAdditions_3.2.12.iso) = 33146880
+SHA256 (VirtualBox-4.0.16.tar.bz2) = d6c165cc41063cb8eb8283606b712904cae180000171fb1f833b7eaada633c77
+SIZE (VirtualBox-4.0.16.tar.bz2) = 70042175
+SHA256 (VBoxGuestAdditions_4.0.16.iso) = 778c7c020b853f999317bd017e2f3e2badc6deebfbec33ae89d7710826fb404e
+SIZE (VBoxGuestAdditions_4.0.16.iso) = 41639936
diff --git a/emulators/virtualbox-ose-legacy/files/patch-src-VBox-Devices-Makefile.kmk b/emulators/virtualbox-ose-legacy/files/patch-src-VBox-Devices-Makefile.kmk
index 098410d5ff9..2cdf6521b3d 100644
--- a/emulators/virtualbox-ose-legacy/files/patch-src-VBox-Devices-Makefile.kmk
+++ b/emulators/virtualbox-ose-legacy/files/patch-src-VBox-Devices-Makefile.kmk
@@ -1,15 +1,13 @@
---- src/VBox/Devices/Makefile.kmk.orig 2009-12-17 15:27:43.000000000 +0100
-+++ src/VBox/Devices/Makefile.kmk 2009-12-21 14:29:56.000000000 +0100
-@@ -31,8 +31,10 @@
- include $(PATH_SUB_CURRENT)/PC/VMI/Makefile.kmk
- endif
- include $(PATH_SUB_CURRENT)/Graphics/BIOS/Makefile.kmk
+--- src/VBox/Devices/Makefile.kmk.orig 2010-12-06 22:42:36.000000000 +0100
++++ src/VBox/Devices/Makefile.kmk 2010-12-06 22:42:59.000000000 +0100
+@@ -22,7 +22,9 @@
+ VBOX_PATH_DEVICES_SRC := $(PATH_SUB_CURRENT)
+
+ # Include sub-makefiles.
-include $(PATH_SUB_CURRENT)/testcase/Makefile.kmk
--include $(PATH_SUB_CURRENT)/Storage/testcase/Makefile.kmk
+ifdef VBOX_WITH_TESTCASES
-+ include $(PATH_SUB_CURRENT)/testcase/Makefile.kmk
-+ include $(PATH_SUB_CURRENT)/Storage/testcase/Makefile.kmk
++ include $(PATH_SUB_CURRENT)/testcase/Makefile.kmk
+endif
- ifndef VBOX_OSE
- include $(PATH_SUB_CURRENT)/Storage/VBoxHDDFormats/Makefile.kmk
- endif
+ if defined(VBOX_WITH_INTEL_PXE) || defined(VBOX_ONLY_EXTPACKS)
+ include $(PATH_SUB_CURRENT)/PC/PXE/Makefile.kmk
+ else ifndef VBOX_WITHOUT_ETHERBOOT
diff --git a/emulators/virtualbox-ose-legacy/files/patch-src-VBox-Devices-Storage-DrvHostDVD.cpp b/emulators/virtualbox-ose-legacy/files/patch-src-VBox-Devices-Storage-DrvHostDVD.cpp
deleted file mode 100644
index 97f764a71d1..00000000000
--- a/emulators/virtualbox-ose-legacy/files/patch-src-VBox-Devices-Storage-DrvHostDVD.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
-
---- src/VBox/Devices/Storage/DrvHostDVD.cpp.orig 2010-05-20 10:28:06.000000000 +0300
-+++ src/VBox/Devices/Storage/DrvHostDVD.cpp 2010-05-20 10:37:47.000000000 +0300
-@@ -224,7 +224,7 @@
- */
- static DECLCALLBACK(int) drvHostDvdDoLock(PDRVHOSTBASE pThis, bool fLock)
- {
--#ifdef RT_OS_DARWIN
-+#if defined(RT_OS_FREEBSD) || defined(RT_OS_DARWIN)
- uint8_t abCmd[16] =
- {
- SCSI_PREVENT_ALLOW_MEDIUM_REMOVAL, 0, 0, 0, fLock, 0,
-
-
diff --git a/emulators/virtualbox-ose-legacy/files/patch-src-VBox-Frontends-VBoxManage-VBoxInternalManage.cpp b/emulators/virtualbox-ose-legacy/files/patch-src-VBox-Frontends-VBoxManage-VBoxInternalManage.cpp
deleted file mode 100644
index fdffb0aab89..00000000000
--- a/emulators/virtualbox-ose-legacy/files/patch-src-VBox-Frontends-VBoxManage-VBoxInternalManage.cpp
+++ /dev/null
@@ -1,48 +0,0 @@
---- src/VBox/Frontends/VBoxManage/VBoxInternalManage.cpp.orig 2010-12-01 18:09:24.000000000 +0100
-+++ src/VBox/Frontends/VBoxManage/VBoxInternalManage.cpp 2011-03-16 10:58:37.000000000 +0100
-@@ -178,8 +178,9 @@
- " (the partitioning information in the MBR file is ignored).\n"
- " The diskname is on Linux e.g. /dev/sda, and on Windows e.g.\n"
- " \\\\.\\PhysicalDrive0).\n"
-- " On Linux host the parameter -relative causes a VMDK file to be created\n"
-- " which refers to individual partitions instead to the entire disk.\n"
-+ " On Linux or FreeBSD host the parameter -relative causes a VMDK file to\n"
-+ " be created which refers to individual partitions instead to the entire\n"
-+ " disk.\n"
- " Optionally the created image can be immediately registered.\n"
- " The necessary partition numbers can be queried with\n"
- " VBoxManage internalcommands listpartitions\n"
-@@ -926,12 +927,12 @@
- {
- fRegister = true;
- }
--#ifdef RT_OS_LINUX
-+#if defined(RT_OS_LINUX) || defined(RT_OS_FREEBSD)
- else if (strcmp(argv[i], "-relative") == 0)
- {
- fRelative = true;
- }
--#endif /* RT_OS_LINUX */
-+#endif /* RT_OS_LINUX || RT_OS_FREEBSD */
- else
- {
- return errorSyntax(USAGE_CREATERAWVMDK, "Invalid parameter '%s'", Utf8Str(argv[i]).raw());
-@@ -1280,10 +1281,16 @@
- {
- if (fRelative)
- {
--#ifdef RT_OS_LINUX
-+#if defined(RT_OS_LINUX) || defined(RT_OS_FREEBSD)
- /* Refer to the correct partition and use offset 0. */
- char *psz;
-- vrc = RTStrAPrintf(&psz, "%s%u", rawdisk.raw(),
-+ vrc = RTStrAPrintf(&psz,
-+#if defined(RT_OS_LINUX)
-+ "%s%u",
-+#elif defined(RT_OS_FREEBSD)
-+ "%ss%u",
-+#endif
-+ rawdisk.raw(),
- partitions.aPartitions[i].uIndex);
- if (RT_FAILURE(vrc))
- {
diff --git a/emulators/virtualbox-ose-legacy/files/patch-src-VBox-Frontends-VirtualBox-src-settings-vm-VBoxVMSettingsHD.h b/emulators/virtualbox-ose-legacy/files/patch-src-VBox-Frontends-VirtualBox-src-settings-vm-VBoxVMSettingsHD.h
deleted file mode 100644
index 6b347df656c..00000000000
--- a/emulators/virtualbox-ose-legacy/files/patch-src-VBox-Frontends-VirtualBox-src-settings-vm-VBoxVMSettingsHD.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/VBox/Frontends/VirtualBox/src/settings/vm/VBoxVMSettingsHD.h.orig 2010-06-04 10:43:02.000000000 +0200
-+++ src/VBox/Frontends/VirtualBox/src/settings/vm/VBoxVMSettingsHD.h 2010-06-04 10:33:40.000000000 +0200
-@@ -20,7 +20,7 @@
- #define __VBoxVMSettingsHD_h__
-
- /* Global includes */
--#include <qglobal.h> /* for Q_WS_MAC */
-+#include <QtGlobal> /* for Q_WS_MAC */
- #ifdef Q_WS_MAC
- /* Somewhere Carbon.h includes AssertMacros.h which defines the macro "check".
- * In QItemDelegate a class method is called "check" also. As we not used the
diff --git a/emulators/virtualbox-ose-legacy/files/patch-src-VBox-Main-freebsd-NetIf-freebsd.cpp b/emulators/virtualbox-ose-legacy/files/patch-src-VBox-Main-freebsd-NetIf-freebsd.cpp
deleted file mode 100644
index 8e706db41fd..00000000000
--- a/emulators/virtualbox-ose-legacy/files/patch-src-VBox-Main-freebsd-NetIf-freebsd.cpp
+++ /dev/null
@@ -1,30 +0,0 @@
---- src/VBox/Main/freebsd/NetIf-freebsd.cpp.orig 2010-06-07 15:34:44.000000000 +0300
-+++ src/VBox/Main/freebsd/NetIf-freebsd.cpp 2010-06-18 16:45:31.000000000 +0300
-@@ -180,11 +180,16 @@
- char *pBuf, *pNext;
- int aiMib[6];
- unsigned short u16DefaultIface;
-+ int haveDefaultIface;
-
- /* Get the index of the interface associated with default route. */
- rc = getDefaultIfaceIndex(&u16DefaultIface, PF_INET);
-- if (RT_FAILURE(rc))
-- return rc;
-+ haveDefaultIface = 1;
-+ if (RT_FAILURE(rc)) {
-+ Log(("NetIfList: Failed to get default route interface\n"));
-+ haveDefaultIface = 0;
-+ rc = VINF_SUCCESS;
-+ }
-
- aiMib[0] = CTL_NET;
- aiMib[1] = PF_ROUTE;
-@@ -286,7 +291,7 @@
- IfObj.createObject();
- if (SUCCEEDED(IfObj->init(Bstr(pNew->szName), enmType, pNew)))
- /* Make sure the default interface gets to the beginning. */
-- if (pIfMsg->ifm_index == u16DefaultIface)
-+ if (haveDefaultIface == 1 && pIfMsg->ifm_index == u16DefaultIface)
- list.push_front(IfObj);
- else
- list.push_back(IfObj);
diff --git a/emulators/virtualbox-ose-legacy/files/patch-src-VBox-Main-freebsd-HostHardwareFreeBSD.cpp b/emulators/virtualbox-ose-legacy/files/patch-src-VBox-Main-src-server-freebsd-HostHardwareFreeBSD.cpp
index 673526554ff..69d6260ac6f 100644
--- a/emulators/virtualbox-ose-legacy/files/patch-src-VBox-Main-freebsd-HostHardwareFreeBSD.cpp
+++ b/emulators/virtualbox-ose-legacy/files/patch-src-VBox-Main-src-server-freebsd-HostHardwareFreeBSD.cpp
@@ -1,5 +1,5 @@
---- src/VBox/Main/freebsd/HostHardwareFreeBSD.cpp.cpp.orig 2011-05-16 12:33:46.000000000 -0400
-+++ src/VBox/Main/freebsd/HostHardwareFreeBSD.cpp 2011-06-24 16:03:37.000000000 -0400
+--- src/VBox/Main/src-server/freebsd/HostHardwareFreeBSD.cpp.orig 2011-05-16 12:33:46.000000000 -0400
++++ src/VBox/Main/src-server/freebsd/HostHardwareFreeBSD.cpp 2011-06-24 16:03:37.000000000 -0400
@@ -35,6 +35,7 @@
#include <iprt/string.h>
diff --git a/emulators/virtualbox-ose-legacy/files/patch-src-VBox-Runtime-r3-freebsd-fileaio-freebsd.c b/emulators/virtualbox-ose-legacy/files/patch-src-VBox-Runtime-r3-freebsd-fileaio-freebsd.c
new file mode 100644
index 00000000000..671bb555218
--- /dev/null
+++ b/emulators/virtualbox-ose-legacy/files/patch-src-VBox-Runtime-r3-freebsd-fileaio-freebsd.c
@@ -0,0 +1,16 @@
+Runtime/fileaio-freebsd: Fix error check for aio_error
+
+Obtained-from: https://www.virtualbox.org/changeset/38332
+
+--- src/VBox/Runtime/r3/freebsd/fileaio-freebsd.cpp.orig 2011-07-15 17:34:34.000000000 +0200
++++ src/VBox/Runtime/r3/freebsd/fileaio-freebsd.cpp 2011-11-21 09:33:26.155092865 +0100
+@@ -416,7 +416,8 @@
+ {
+ pReqInt = pahReqs[i];
+ rcBSD = aio_error(&pReqInt->AioCB);
+- if (rcBSD == EINVAL || rcBSD == EAGAIN)
++ if ( rcBSD == -1
++ && errno == EINVAL)
+ {
+ /* Was not submitted. */
+ RTFILEAIOREQ_SET_STATE(pReqInt, PREPARED);
diff --git a/emulators/virtualbox-ose-legacy/files/patch-src-VBox-VMM-VMMR3-CPUM.cpp b/emulators/virtualbox-ose-legacy/files/patch-src-VBox-VMM-VMMR3-CPUM.cpp
new file mode 100644
index 00000000000..5bb1888abe1
--- /dev/null
+++ b/emulators/virtualbox-ose-legacy/files/patch-src-VBox-VMM-VMMR3-CPUM.cpp
@@ -0,0 +1,12 @@
+--- src/VBox/VMM/VMMR3/CPUM.cpp (Revision 71439)
++++ src/VBox/VMM/VMMR3/CPUM.cpp (Revision 71440)
+@@ -999,7 +999,8 @@
+ */
+ if (!fHWVirtExEnabled)
+ {
+- Assert(pVM->cpum.s.aGuestCpuIdStd[4].eax == 0);
++ Assert( pVM->cpum.s.aGuestCpuIdStd[4].eax == 0
++ || pVM->cpum.s.aGuestCpuIdStd[0].eax < 0x4);
+ pVM->cpum.s.aGuestCpuIdStd[4].eax = 0;
+ }
+ }
diff --git a/emulators/virtualbox-ose-legacy/pkg-message b/emulators/virtualbox-ose-legacy/pkg-message
index a5c046c48a1..93aa94f8692 100644
--- a/emulators/virtualbox-ose-legacy/pkg-message
+++ b/emulators/virtualbox-ose-legacy/pkg-message
@@ -6,15 +6,45 @@ You need to load the vboxdrv kernel module via /boot/loader.conf:
vboxdrv_load="YES"
+You also have to add all users to your vboxusers group in order to use vbox.
+
+% pw groupmod vboxusers -m jerry
+
+Reboot the machine to load the needed kernel modules.
+
+
+Bridging Support:
+=================
+
For bridged networking please add the following line to your /etc/rc.conf:
vboxnet_enable="YES"
-Reboot the machine to load the needed kernel modules.
-You also have to add all users to your vboxusers group in order to use vbox.
+USB Support:
+============
-% pw groupmod vboxusers -m jerry
+For USB support your user needs to be in the operator group and needs read
+and write permissions to the USB device.
+
+% pw groupmod operator -m jerry
+
+Add the following to /etc/devfs.rules (create if it doesn't exist):
+
+[system=10]
+add path 'usb/*' mode 0660 group operator
+
+To load these new rule add the following to /etc/rc.conf:
+
+devfs_system_ruleset="system"
+
+Then restart devfs to load the new rules:
+
+% /etc/rc.d/devfs restart
+
+
+Troubleshooting:
+================
Running VirtualBox as non-root user may fail with a fatal error
NS_ERROR_FACTORY_NOT_REGISTERED. In this case delete /tmp/.vbox-*-ipc file.
diff --git a/emulators/virtualbox-ose-legacy/pkg-plist b/emulators/virtualbox-ose-legacy/pkg-plist
index 6335f59569a..740c84ec3c9 100644
--- a/emulators/virtualbox-ose-legacy/pkg-plist
+++ b/emulators/virtualbox-ose-legacy/pkg-plist
@@ -12,11 +12,16 @@ bin/VBoxXPCOMIPCD
%%WEB%%bin/webtest
%%X11%%lib/virtualbox/VBoxBFE
%%X11%%lib/virtualbox/VBoxBFE.so
+lib/virtualbox/DBGCPlugInDiggers.so
+lib/virtualbox/VBoxAuth.so
+lib/virtualbox/VBoxAuthSimple.so
+%%QT4%%lib/virtualbox/VBoxDbg.so
lib/virtualbox/VBoxDD.so
lib/virtualbox/VBoxDD2.so
lib/virtualbox/VBoxDDU.so
lib/virtualbox/VBoxEFI32.fd
lib/virtualbox/VBoxEFI64.fd
+lib/virtualbox/VBoxExtPackHelperApp
lib/virtualbox/VBoxGuestControlSvc.so
lib/virtualbox/VBoxGuestPropSvc.so
lib/virtualbox/VBoxHeadless