aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/xsystem35/Makefile
diff options
context:
space:
mode:
authorsf <sf@FreeBSD.org>2004-08-16 10:43:17 +0800
committersf <sf@FreeBSD.org>2004-08-16 10:43:17 +0800
commite5d04d3f060d46a9bfac85f18b9262a287c64a4c (patch)
tree6c6301e109dc0fcb8e588ab7dfbc4905e769bbac /emulators/xsystem35/Makefile
parent4c32b4dc0e277a56a00a54ce0a4d9363d65d75ae (diff)
downloadfreebsd-ports-graphics-e5d04d3f060d46a9bfac85f18b9262a287c64a4c.tar.gz
freebsd-ports-graphics-e5d04d3f060d46a9bfac85f18b9262a287c64a4c.tar.zst
freebsd-ports-graphics-e5d04d3f060d46a9bfac85f18b9262a287c64a4c.zip
o add missing jpeg dependency, broken configure script did not detect it.
o use custom DOCSDIR.
Diffstat (limited to 'emulators/xsystem35/Makefile')
-rw-r--r--emulators/xsystem35/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/emulators/xsystem35/Makefile b/emulators/xsystem35/Makefile
index f8e2e470976..c3af8ade91e 100644
--- a/emulators/xsystem35/Makefile
+++ b/emulators/xsystem35/Makefile
@@ -13,7 +13,8 @@ MASTER_SITES= http://8ne.sakura.ne.jp:20008/chika/unitbase/xsys35/down/
MAINTAINER= sf@FreeBSD.org
COMMENT= AliceSoft System 3.5/3.6/3.8/3.9 on X Window System
-LIB_DEPENDS= vorbis.3:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS= vorbis.3:${PORTSDIR}/audio/libvorbis \
+ jpeg.9:${PORTSDIR}/graphics/jpeg
USE_AUTOCONF_VER= 259
USE_LIBTOOL_VER= 15
@@ -25,6 +26,7 @@ USE_REINPLACE= yes
PKGMESSAGE= ${WRKSRC}/MESSAGE
+DOCSDIR= ${PREFIX}/share/doc/ja/${PORTNAME}
PATCHES= pastel.diff
.include <bsd.port.pre.mk>
@@ -86,9 +88,9 @@ pre-configure:
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/contrib/instgame ${PREFIX}/bin
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/ja/xsystem35
+ @${MKDIR} ${PREFIX}/${DOCSDIR}
(cd ${WRKSRC}/doc;\
- ${INSTALL_MAN} * ${PREFIX}/share/doc/ja/xsystem35)
+ ${INSTALL_MAN} * ${PREFIX}/${DOCSDIR})
.endif
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/src/xsys35rc.sample ${EXAMPLESDIR}