aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorbrooks <brooks@FreeBSD.org>2016-02-23 03:40:59 +0800
committerbrooks <brooks@FreeBSD.org>2016-02-23 03:40:59 +0800
commit1d54576fc690233584b5bfd5c3a07d43042ea5f3 (patch)
tree746b8412421098f9d4cebcd8c3c0aad68cfc8fe7 /emulators
parent8375129ff9feecc82113e7bdba99af5c56d37f64 (diff)
downloadfreebsd-ports-graphics-1d54576fc690233584b5bfd5c3a07d43042ea5f3.tar.gz
freebsd-ports-graphics-1d54576fc690233584b5bfd5c3a07d43042ea5f3.tar.zst
freebsd-ports-graphics-1d54576fc690233584b5bfd5c3a07d43042ea5f3.zip
Update qemu-cheri to a fresh snapshot and add a port to build the 128-bit
version.
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/qemu-cheri/Makefile6
-rw-r--r--emulators/qemu-cheri/Makefile.snapshot4
-rw-r--r--emulators/qemu-cheri/distinfo4
-rw-r--r--emulators/qemu-cheri128/Makefile20
5 files changed, 28 insertions, 7 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 9254d53ad3e..26eb2cefbd1 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -117,6 +117,7 @@
SUBDIR += q4wine
SUBDIR += qemu
SUBDIR += qemu-cheri
+ SUBDIR += qemu-cheri128
SUBDIR += qemu-devel
SUBDIR += qemu-launcher
SUBDIR += qemu-sbruno
diff --git a/emulators/qemu-cheri/Makefile b/emulators/qemu-cheri/Makefile
index b08ea948284..d689326bf2a 100644
--- a/emulators/qemu-cheri/Makefile
+++ b/emulators/qemu-cheri/Makefile
@@ -3,10 +3,10 @@
PORTNAME= qemu
PORTVERSION= 0.d${SNAPDATE}
CATEGORIES= emulators devel
-PKGNAMESUFFIX= -cheri
+PKGNAMESUFFIX?= -cheri
MAINTAINER= brooks@FreeBSD.org
-COMMENT= QEMU emulator with CHERI CPU support
+COMMENT?= QEMU emulator with CHERI CPU support
USE_GITHUB= yes
GH_ACCOUNT= CTSRD-CHERI
@@ -32,7 +32,7 @@ CONFIGURE_ARGS+= \
--disable-smartcard-nss \
--disable-vte \
--disable-xen \
- --extra-cflags=-g \
+ --extra-cflags="-g ${EXTRA_CFLAGS}" \
--localstatedir=/var
.include <bsd.port.mk>
diff --git a/emulators/qemu-cheri/Makefile.snapshot b/emulators/qemu-cheri/Makefile.snapshot
index 8bee98b09df..aab074e02ea 100644
--- a/emulators/qemu-cheri/Makefile.snapshot
+++ b/emulators/qemu-cheri/Makefile.snapshot
@@ -4,6 +4,6 @@
#
# Generated by: files/gen-Makefile.snapshot.sh.
#
-SNAPDATE= 20160128
+SNAPDATE= 20160220
-QEMU_COMMIT= 100abeddda5764c193807863806df7027471db94
+QEMU_COMMIT= 5f5668398f6eba799298072ac761e7216e360d85
diff --git a/emulators/qemu-cheri/distinfo b/emulators/qemu-cheri/distinfo
index d8f958a55b0..2ca89facbe8 100644
--- a/emulators/qemu-cheri/distinfo
+++ b/emulators/qemu-cheri/distinfo
@@ -1,2 +1,2 @@
-SHA256 (CTSRD-CHERI-qemu-0.d20160128-100abeddda5764c193807863806df7027471db94_GH0.tar.gz) = cbe4c5508c8b3ab2ecf52e1d1e80580fdfe610ec15d7b4413c5531563f71d349
-SIZE (CTSRD-CHERI-qemu-0.d20160128-100abeddda5764c193807863806df7027471db94_GH0.tar.gz) = 11137465
+SHA256 (CTSRD-CHERI-qemu-0.d20160220-5f5668398f6eba799298072ac761e7216e360d85_GH0.tar.gz) = 9a43a26c7144ac7995e33e956390b96695a8d5cae5327dbb06c9ca0b32289437
+SIZE (CTSRD-CHERI-qemu-0.d20160220-5f5668398f6eba799298072ac761e7216e360d85_GH0.tar.gz) = 11139308
diff --git a/emulators/qemu-cheri128/Makefile b/emulators/qemu-cheri128/Makefile
new file mode 100644
index 00000000000..3764a1d6ddb
--- /dev/null
+++ b/emulators/qemu-cheri128/Makefile
@@ -0,0 +1,20 @@
+# Created by: Brooks Davis
+# $FreeBSD$
+
+PKGNAMESUFFIX= -cheri128
+
+COMMENT= QEMU emulator with CHERI CPU support (128-bit)
+
+RUN_DEPENDS= qemu-system-cheri:${PORTSDIR}/emulators/qemu-cheri
+
+MASTERDIR= ${.CURDIR}/../qemu-cheri
+
+EXTRA_CFLAGS= -DCHERI_MAGIC128
+PLIST= /dev/null
+PLIST_FILES= bin/qemu-system-cheri128
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/cheri-softmmu/qemu-system-cheri \
+ ${STAGEDIR}${PREFIX}/bin/qemu-system-cheri128
+
+.include <${MASTERDIR}/Makefile>