aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2008-03-22 01:31:52 +0800
committernox <nox@FreeBSD.org>2008-03-22 01:31:52 +0800
commit364ef771d6a031bbc74270a18737be1686c55fd4 (patch)
tree6f4365f09950d07e4fba2ab86df47b352d4280e1 /emulators
parent61ff76e93eb9d2d3d4f085ffbd2829f76ce2a19a (diff)
downloadfreebsd-ports-graphics-364ef771d6a031bbc74270a18737be1686c55fd4.tar.gz
freebsd-ports-graphics-364ef771d6a031bbc74270a18737be1686c55fd4.tar.zst
freebsd-ports-graphics-364ef771d6a031bbc74270a18737be1686c55fd4.zip
- Add runtime warning when aio is not loaded
- Bump PORTREVISION Requested by: several people on freebsd-emulation@
Diffstat (limited to 'emulators')
-rw-r--r--emulators/qemu-devel/Makefile2
-rw-r--r--emulators/qemu-devel/files/patch-vl.c12
-rw-r--r--emulators/qemu/Makefile2
-rw-r--r--emulators/qemu/files/patch-vl.c12
4 files changed, 26 insertions, 2 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index 9a37644d2e4..550013e92b8 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= qemu
PORTVERSION= 0.9.1s.20080302
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= emulators
MASTER_SITES= http://qemu.org/:release \
http://qemu-forum.ipi.fi/qemu-snapshots/:snapshot \
diff --git a/emulators/qemu-devel/files/patch-vl.c b/emulators/qemu-devel/files/patch-vl.c
index 9acd842bbda..ec763da3848 100644
--- a/emulators/qemu-devel/files/patch-vl.c
+++ b/emulators/qemu-devel/files/patch-vl.c
@@ -33,3 +33,15 @@ Index: qemu/vl.c
if (strstart(filename, "/dev/", NULL)) {
return qemu_chr_open_tty(filename);
} else
+@@ -8423,6 +8423,11 @@
+ nb_nics = 0;
+ /* default mac address of the first network interface */
+
++#ifdef __FreeBSD__
++ if (modfind("aio") == -1)
++ fprintf(stderr, "warning: aio not (kld)loaded, may cause `Invalid system call' traps on disk IO\n");
++#endif
++
+ optind = 1;
+ for(;;) {
+ if (optind >= argc)
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index 7257e8383e6..28e5d457626 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -7,7 +7,7 @@
PORTNAME= qemu
PORTVERSION= 0.9.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= emulators
MASTER_SITES= http://fabrice.bellard.free.fr/qemu/:release \
http://qemu.org/:release \
diff --git a/emulators/qemu/files/patch-vl.c b/emulators/qemu/files/patch-vl.c
index 8f920b047be..a69e42ffd8b 100644
--- a/emulators/qemu/files/patch-vl.c
+++ b/emulators/qemu/files/patch-vl.c
@@ -33,6 +33,18 @@ Index: qemu/vl.c
if (strstart(filename, "/dev/", NULL)) {
return qemu_chr_open_tty(filename);
} else
+@@ -8423,6 +8423,11 @@
+ nb_nics = 0;
+ /* default mac address of the first network interface */
+
++#ifdef __FreeBSD__
++ if (modfind("aio") == -1)
++ fprintf(stderr, "warning: aio not (kld)loaded, may cause `Invalid system call' traps on disk IO\n");
++#endif
++
+ optind = 1;
+ for(;;) {
+ if (optind >= argc)
@@ -8784,6 +8784,7 @@
#ifdef TARGET_ARM
case QEMU_OPTION_old_param: