aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-12-28 08:41:50 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-12-28 08:41:50 +0800
commit702a9ac668e4878e1cf4107e881ff85a735ee355 (patch)
tree241d02a5f6a28e9d86d142c5433b6e3ae1dd4471 /emulators
parentbb107e6e8b37592cfd03381d745da945649930ed (diff)
downloadfreebsd-ports-graphics-702a9ac668e4878e1cf4107e881ff85a735ee355.tar.gz
freebsd-ports-graphics-702a9ac668e4878e1cf4107e881ff85a735ee355.tar.zst
freebsd-ports-graphics-702a9ac668e4878e1cf4107e881ff85a735ee355.zip
- Convert to USES=metaport
- Simplify options handling PR: 201637 Submitted by: s3erios@gmail.com Approved by: maintainer timeout (acm, 5 months)
Diffstat (limited to 'emulators')
-rw-r--r--emulators/mupen64plus-plugins/Makefile38
1 files changed, 6 insertions, 32 deletions
diff --git a/emulators/mupen64plus-plugins/Makefile b/emulators/mupen64plus-plugins/Makefile
index 03eb9bab48e..604e2fb94b4 100644
--- a/emulators/mupen64plus-plugins/Makefile
+++ b/emulators/mupen64plus-plugins/Makefile
@@ -5,14 +5,13 @@ PORTNAME= mupen64plus
PORTVERSION= 2.5
PORTREVISION= 0
CATEGORIES= emulators
-MASTER_SITES= # empty
PKGNAMESUFFIX= -plugins
-DISTFILES= # empty
-EXTRACT_ONLY= # empty
MAINTAINER?= acm@FreeBSD.org
COMMENT= Third party plugins for Mupen64plus
+USES= metaport
+
OPTIONS_DEFINE= VIDEO_ARACHNOID VIDEO_GLIDE64 VIDEO_Z64 RSP_Z64 RSP_CXD4
VIDEO_ARACHNOID_DESC= Arachnoid video plugin
VIDEO_GLIDE64_DESC= Glide64 video plugin
@@ -22,33 +21,8 @@ RSP_CXD4_DESC= cxd4 RSP plugin
OPTIONS_DEFAULT= VIDEO_ARACHNOID VIDEO_GLIDE64 VIDEO_Z64 RSP_Z64 RSP_CXD4
-.include <bsd.port.pre.mk>
-
-# Graphics plugins
-.if ${PORT_OPTIONS:MVIDEO_ARACHNOID}
-RUN_DEPENDS+= ${LOCALBASE}/lib/${PORTNAME}/mupen64plus-video-arachnoid.so:${PORTSDIR}/emulators/mupen64plus-video-arachnoid
-.endif
-
-.if ${PORT_OPTIONS:MVIDEO_GLIDE64}
-RUN_DEPENDS+= ${LOCALBASE}/lib/${PORTNAME}/mupen64plus-video-glide64.so:${PORTSDIR}/emulators/mupen64plus-video-glide64
-.endif
-
-.if ${PORT_OPTIONS:MVIDEO_Z64}
-RUN_DEPENDS+= ${LOCALBASE}/lib/${PORTNAME}/mupen64plus-video-z64.so:${PORTSDIR}/emulators/mupen64plus-video-z64
-.endif
-
-# RSP plugins
-.if ${PORT_OPTIONS:MRSP_Z64}
-RUN_DEPENDS+= ${LOCALBASE}/lib/${PORTNAME}/mupen64plus-rsp-z64.so:${PORTSDIR}/emulators/mupen64plus-rsp-z64
-.endif
-
-.if ${PORT_OPTIONS:MRSP_CXD4}
-RUN_DEPENDS+= ${LOCALBASE}/lib/${PORTNAME}/mupen64plus-rsp-cxd4.so:${PORTSDIR}/emulators/mupen64plus-rsp-cxd4
-.endif
-
-NO_MTREE= yes
-NO_BUILD= yes
-
-do-install: # empty
+.for OPT in ${OPTIONS_DEFINE}
+${OPT}_RUN_DEPENDS= ${LOCALBASE}/lib/${PORTNAME}/mupen64plus-${OPT:tl:S/_/-/}.so:${PORTSDIR}/emulators/mupen64plus-${OPT:tl:S/_/-/}
+.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>