aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2015-10-30 18:45:41 +0800
committerdanfe <danfe@FreeBSD.org>2015-10-30 18:45:41 +0800
commit7b2c29178e83626191859d6b3348ea1ce6129906 (patch)
treecc456d6dfaded1a00c8b4836968c0e6f53f03ea7 /emulators
parente40404494529378017a653a647c54f8ba016a933 (diff)
downloadfreebsd-ports-graphics-7b2c29178e83626191859d6b3348ea1ce6129906.tar.gz
freebsd-ports-graphics-7b2c29178e83626191859d6b3348ea1ce6129906.tar.zst
freebsd-ports-graphics-7b2c29178e83626191859d6b3348ea1ce6129906.zip
- Update to version 0.9.11
- Use sysconf(3) to get number of active CPUs instead of sysctl(3) and thus clean up the patch - Remove BROKEN_ia64 statement at it makes little use these days as ia64 was never a first-class citizen in FreeBSD and officially killed in -CURRENT for a while now PR: 203426 Submitted by: maintainer
Diffstat (limited to 'emulators')
-rw-r--r--emulators/desmume/Makefile5
-rw-r--r--emulators/desmume/distinfo4
-rw-r--r--emulators/desmume/files/patch-src_utils_task.cpp36
3 files changed, 23 insertions, 22 deletions
diff --git a/emulators/desmume/Makefile b/emulators/desmume/Makefile
index 6a0382bff30..bff960d709c 100644
--- a/emulators/desmume/Makefile
+++ b/emulators/desmume/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= desmume
-PORTVERSION= 0.9.10
-PORTREVISION= 3
+PORTVERSION= 0.9.11
CATEGORIES= emulators
MASTER_SITES= SF
@@ -29,6 +28,4 @@ CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib -DGTKGLEXT_AVAILABLE \
-DHAVE_LIBGDKGLEXT_X11_1_0 -DHAVE_GL_GL_H -DHAVE_GL_GLU_H
CXXFLAGS+= ${CFLAGS}
-BROKEN_ia64= Does not compile on ia64
-
.include <bsd.port.mk>
diff --git a/emulators/desmume/distinfo b/emulators/desmume/distinfo
index b70f192cf1d..58342a09a84 100644
--- a/emulators/desmume/distinfo
+++ b/emulators/desmume/distinfo
@@ -1,2 +1,2 @@
-SHA256 (desmume-0.9.10.tar.gz) = 8900a7a1fc849fdd33b014748dd97a6cda4c32548b8d2e06511e6ed8d5ba7445
-SIZE (desmume-0.9.10.tar.gz) = 4141586
+SHA256 (desmume-0.9.11.tar.gz) = 3ab34ba6cc009566245025c1dd94bf449b6a1b416d24387cb42e183c78e38896
+SIZE (desmume-0.9.11.tar.gz) = 5359305
diff --git a/emulators/desmume/files/patch-src_utils_task.cpp b/emulators/desmume/files/patch-src_utils_task.cpp
index 9ae14e3e8a6..f206b4098a4 100644
--- a/emulators/desmume/files/patch-src_utils_task.cpp
+++ b/emulators/desmume/files/patch-src_utils_task.cpp
@@ -1,22 +1,26 @@
---- src/utils/task.cpp.orig 2013-11-28 01:37:27.373159000 +0100
-+++ src/utils/task.cpp 2013-12-14 19:49:02.000000000 +0100
-@@ -26,6 +26,7 @@
- #if defined HOST_LINUX || defined HOST_DARWIN
+--- src/utils/task.cpp.orig 2015-10-30 09:34:37 UTC
++++ src/utils/task.cpp
+@@ -23,9 +23,9 @@
+ #include <windows.h>
+ #else
+ #include <pthread.h>
+-#if defined HOST_LINUX
++#if defined HOST_LINUX || defined HOST_BSD
#include <unistd.h>
- #elif defined HOST_BSD
-+#include <iostream>
+-#elif defined HOST_BSD || defined HOST_DARWIN
++#elif defined HOST_DARWIN
#include <sys/sysctl.h>
#endif
#endif // HOST_WINDOWS
-@@ -41,9 +42,8 @@
+@@ -37,9 +37,9 @@ int getOnlineCores (void)
+ SYSTEM_INFO sysinfo;
+ GetSystemInfo(&sysinfo);
+ return sysinfo.dwNumberOfProcessors;
+-#elif defined HOST_LINUX
++#elif defined HOST_LINUX || defined HOST_BSD
return sysconf(_SC_NPROCESSORS_ONLN);
- #elif defined HOST_BSD
+-#elif defined HOST_BSD || defined HOST_DARWIN
++#elif defined HOST_DARWIN
int cores;
-- const int mib[4] = { CTL_HW, HW_NCPU, 0, 0 };
-- const size_t len = sizeof(cores);
-- sysctl(mib, 2, &cores, &len, NULL, 0);
-+ size_t len = sizeof(cores);
-+ sysctlbyname("hw.ncpu", &cores, &len, NULL, 0);
- return (cores < 1) ? 1 : cores;
- #else
- return 1;
+ int mib[4] = { CTL_HW, HW_NCPU, 0, 0 };
+ size_t len = sizeof(cores); //don't make this const, i guess sysctl can't take a const *