aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2004-03-14 14:17:56 +0800
committerade <ade@FreeBSD.org>2004-03-14 14:17:56 +0800
commit9291e9a32f6612ca0d4f25bdcb5c417e0451d313 (patch)
tree545e55afde412d844a25f5c03d6d51b17ceeebb9 /emulators
parenta8a89c37fe338cbff0192ceeef27ccf7a13714a5 (diff)
downloadfreebsd-ports-graphics-9291e9a32f6612ca0d4f25bdcb5c417e0451d313.tar.gz
freebsd-ports-graphics-9291e9a32f6612ca0d4f25bdcb5c417e0451d313.tar.zst
freebsd-ports-graphics-9291e9a32f6612ca0d4f25bdcb5c417e0451d313.zip
Whoa there, boy, that's a mighty big commit y'all have there...
Begin autotools sanitization sequence by requiring ports to explicitly specify which version of {libtool,autoconf,automake} they need, erasing the concept of a "system default". For ports-in-waiting: USE_LIBTOOL=YES -> USE_LIBTOOL_VER=13 USE_AUTOCONF=YES -> USE_AUTOCONF_VER=213 USE_AUTOMAKE=YES -> USE_AUTOMAKE_VER=14 Ports attempting to use the old style system after June 1st 2004 will be sorely disappointed.
Diffstat (limited to 'emulators')
-rw-r--r--emulators/gnuboy/Makefile2
-rw-r--r--emulators/hfsplusutils/Makefile2
-rw-r--r--emulators/lib765/Makefile2
-rw-r--r--emulators/libspectrum/Makefile2
-rw-r--r--emulators/libvm68k/Makefile2
-rw-r--r--emulators/twin/Makefile2
-rw-r--r--emulators/uae/Makefile2
-rw-r--r--emulators/visualos/Makefile2
-rw-r--r--emulators/vx68k/Makefile2
-rw-r--r--emulators/xsystem35/Makefile2
10 files changed, 10 insertions, 10 deletions
diff --git a/emulators/gnuboy/Makefile b/emulators/gnuboy/Makefile
index 499576ce6d0..3cffd57be48 100644
--- a/emulators/gnuboy/Makefile
+++ b/emulators/gnuboy/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= vga.1:${PORTSDIR}/graphics/svgalib
USE_SDL= sdl
USE_REINPLACE= yes
USE_XLIB= yes
-USE_AUTOCONF= yes
+USE_AUTOCONF_VER= 213
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
CONFIGURE_ARGS= --with-sdl
diff --git a/emulators/hfsplusutils/Makefile b/emulators/hfsplusutils/Makefile
index e86deeb05bf..23c4a37d9bc 100644
--- a/emulators/hfsplusutils/Makefile
+++ b/emulators/hfsplusutils/Makefile
@@ -16,7 +16,7 @@ COMMENT= Utilities for accessing HFS+ filesystems
USE_BZIP2= yes
USE_REINPLACE= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER= 13
INSTALLS_SHLIB= yes
USE_AUTOMAKE_VER= 15
AUTOMAKE_ARGS= --add-missing
diff --git a/emulators/lib765/Makefile b/emulators/lib765/Makefile
index 04cc14c98b3..3434c56db7a 100644
--- a/emulators/lib765/Makefile
+++ b/emulators/lib765/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= http://www.seasip.demon.co.uk/Unix/LibDsk/
MAINTAINER= kemm@in-line.ru
COMMENT= Emulation of uPD765a Floppy Disc Controller
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
DOCS= ChangeLog doc/765.txt
diff --git a/emulators/libspectrum/Makefile b/emulators/libspectrum/Makefile
index 0b71b42c0a5..8aaea834225 100644
--- a/emulators/libspectrum/Makefile
+++ b/emulators/libspectrum/Makefile
@@ -16,7 +16,7 @@ COMMENT= Handling of ZX-Spectrum emulator files formats
USE_PERL5_BUILD= yes
USE_GNOME= glib12
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
.if !defined(WITHOUT_GLIB)
diff --git a/emulators/libvm68k/Makefile b/emulators/libvm68k/Makefile
index c9f56de90f8..b7f8784ed93 100644
--- a/emulators/libvm68k/Makefile
+++ b/emulators/libvm68k/Makefile
@@ -15,7 +15,7 @@ MASTER_SITES= ftp://ftp.hypercore.co.jp/vx68k/${PORTNAME}-${PORTVERSION:R}/
MAINTAINER= ports@FreeBSD.org
COMMENT= M68000 virtual machine library
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
USE_REINPLACE= yes
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
INSTALLS_SHLIB= yes
diff --git a/emulators/twin/Makefile b/emulators/twin/Makefile
index 1dd22632241..8675083fd9c 100644
--- a/emulators/twin/Makefile
+++ b/emulators/twin/Makefile
@@ -23,7 +23,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
USE_XLIB= yes
USE_REINPLACE= yes
-USE_AUTOCONF= yes
+USE_AUTOCONF_VER= 213
GNU_CONFIGURE= yes
.if ${MACHINE_ARCH} == "alpha"
CONFIGURE_ARGS+= --disable-intp
diff --git a/emulators/uae/Makefile b/emulators/uae/Makefile
index 64d6d413d0a..7e73e06d85f 100644
--- a/emulators/uae/Makefile
+++ b/emulators/uae/Makefile
@@ -16,7 +16,7 @@ COMMENT= Amiga emulator
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_AUTOCONF= yes
+USE_AUTOCONF_VER= 213
CONFIGURE_ARGS= --enable-sound --enable-vidmode --enable-dga
USE_XLIB= yes
USE_GNOME= gtk12
diff --git a/emulators/visualos/Makefile b/emulators/visualos/Makefile
index ae1c5d83fe8..57f69b526d5 100644
--- a/emulators/visualos/Makefile
+++ b/emulators/visualos/Makefile
@@ -18,7 +18,7 @@ COMMENT= A visual simulator of an operating system to help understand how OSes w
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gnomehack gnomeprefix libglade
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/emulators/vx68k/Makefile b/emulators/vx68k/Makefile
index 49f872f7869..9435d5bb6b0 100644
--- a/emulators/vx68k/Makefile
+++ b/emulators/vx68k/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= vm68k.4:${PORTSDIR}/emulators/libvm68k
USE_GL= yes
USE_GNOME= gtk12
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
USE_REINPLACE= yes
LIBTOOLFILES= configure vx68k-gtk/configure
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
diff --git a/emulators/xsystem35/Makefile b/emulators/xsystem35/Makefile
index 03afa89c333..82760de9734 100644
--- a/emulators/xsystem35/Makefile
+++ b/emulators/xsystem35/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= sf@FreeBSD.org
COMMENT= AliceSoft System 3.5 on X Window System
USE_REINPLACE= yes
-USE_AUTOCONF= yes
+USE_AUTOCONF_VER= 213
USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= gtk12