aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2011-01-04 14:17:09 +0800
committerdinoex <dinoex@FreeBSD.org>2011-01-04 14:17:09 +0800
commitb3bd55169f68009e024dac115728f5521b5c9c63 (patch)
treeff9de7cbfc89fca24e5568dd6bd8f74a2cf39638 /emulators
parent8925a9060d2342bc559ef99bbd1be9c07cd7796e (diff)
downloadfreebsd-ports-graphics-b3bd55169f68009e024dac115728f5521b5c9c63.tar.gz
freebsd-ports-graphics-b3bd55169f68009e024dac115728f5521b5c9c63.tar.zst
freebsd-ports-graphics-b3bd55169f68009e024dac115728f5521b5c9c63.zip
- add missing dependecies
- support libgif - add option VICE_WITH_ASOUND - use sdlsound as default PR: 151207
Diffstat (limited to 'emulators')
-rw-r--r--emulators/vice/Makefile14
-rw-r--r--emulators/vice/files/patch-RegExp.c10
-rw-r--r--emulators/vice/files/patch-x11video.c12
3 files changed, 33 insertions, 3 deletions
diff --git a/emulators/vice/Makefile b/emulators/vice/Makefile
index cf5495dcf53..23910d80691 100644
--- a/emulators/vice/Makefile
+++ b/emulators/vice/Makefile
@@ -6,7 +6,7 @@
PORTNAME= vice
PORTVERSION= 2.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= emulators
MASTER_SITES= http://www.viceteam.org/online/ \
http://www.zimmers.net/anonftp/pub/cbm/crossplatform/emulators/VICE/ \
@@ -20,7 +20,9 @@ BUILD_DEPENDS= bdftopcf:${PORTSDIR}/x11-fonts/bdftopcf \
mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir \
mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale \
pkg-config:${PORTSDIR}/devel/pkg-config
-LIB_DEPENDS= png:${PORTSDIR}/graphics/png
+LIB_DEPENDS= png:${PORTSDIR}/graphics/png \
+ gif:${PORTSDIR}/graphics/giflib \
+ mp3lame:${PORTSDIR}/audio/lame
.if defined(VICE_WITH_XAW3D)
LIB_DEPENDS+= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
.endif
@@ -108,7 +110,7 @@ PLIST_SUB+= NLS="@comment "
.if !defined(WITHOUT_SDL)
USE_SDL= sdl
-CONFIGURE_ARGS+= --with-sdl
+CONFIGURE_ARGS+= --with-sdl --with-sdlsound
CPPFLAGS+= -I${LOCALBASE}/include/SDL
.endif
@@ -119,12 +121,18 @@ CONFIGURE_ARGS+= --with-esd
CONFIGURE_ARGS+= --without-esd
.endif
+.if defined(VICE_WITH_ASOUND)
+LIB_DEPENDS+= asound.2:${PORTSDIR}/audio/alsa-lib
+.endif
+
post-extract:
@${RM} -f ${WRKSRC}/doc/vice.info*
post-patch:
${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" \
${WRKSRC}/man/vice.1
+ ${REINPLACE_CMD} -e 's|lungif|lgif|g' -e 's|== "x|= "x|' \
+ ${WRKSRC}/configure
.if defined(NOPORTDOCS)
${REINPLACE_CMD} -e 's| doc||' ${WRKSRC}/Makefile.in
.endif
diff --git a/emulators/vice/files/patch-RegExp.c b/emulators/vice/files/patch-RegExp.c
new file mode 100644
index 00000000000..db4b97cb039
--- /dev/null
+++ b/emulators/vice/files/patch-RegExp.c
@@ -0,0 +1,10 @@
+--- src/arch/unix/x11/xaw/widgets/RegExp.c.orig 2009-10-21 18:46:45.000000000 +0200
++++ src/arch/unix/x11/xaw/widgets/RegExp.c 2010-08-02 19:58:49.000000000 +0200
+@@ -120,7 +120,6 @@
+ /* Dummy for system that don't have neither <regex.h> and <regexp.h>. */
+
+ void RegExpInit(fwf_regex_t *r)
+- ;
+ {
+ return;
+ }
diff --git a/emulators/vice/files/patch-x11video.c b/emulators/vice/files/patch-x11video.c
new file mode 100644
index 00000000000..6cf649a9799
--- /dev/null
+++ b/emulators/vice/files/patch-x11video.c
@@ -0,0 +1,12 @@
+--- src/arch/unix/x11/xaw/x11video.c.orig 2009-10-21 18:46:45.000000000 +0200
++++ src/arch/unix/x11/xaw/x11video.c 2010-08-03 06:00:50.000000000 +0200
+@@ -342,6 +342,9 @@
+ int mitshm_failed = 0; /* will be set to true if XShmAttach() failed */
+ int shmmajor; /* major number of MITSHM error codes */
+
++#include <X11/X.h>
++#include <X11/extensions/shmproto.h>
++
+ /* Catch XShmAttach()-failure. */
+ int shmhandler(Display *display, XErrorEvent *err)
+ {