aboutsummaryrefslogtreecommitdiffstats
path: root/finance/p5-Business-OnlinePayment
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2008-02-19 00:16:39 +0800
committererwin <erwin@FreeBSD.org>2008-02-19 00:16:39 +0800
commit4b8a6d933665a62a5262a98739272d2f631cff5c (patch)
tree8b367ecc39e535be6078dab24d1b85fc7362de6d /finance/p5-Business-OnlinePayment
parent31b6e98fdb1bdce96e081d8e83b01d0a409e0930 (diff)
downloadfreebsd-ports-graphics-4b8a6d933665a62a5262a98739272d2f631cff5c.tar.gz
freebsd-ports-graphics-4b8a6d933665a62a5262a98739272d2f631cff5c.tar.zst
freebsd-ports-graphics-4b8a6d933665a62a5262a98739272d2f631cff5c.zip
Update to 3.00
PR: 120693 Submitted by: Felippe de Meirelles Motta <lippemail@gmail.com>
Diffstat (limited to 'finance/p5-Business-OnlinePayment')
-rw-r--r--finance/p5-Business-OnlinePayment/Makefile19
-rw-r--r--finance/p5-Business-OnlinePayment/distinfo6
-rw-r--r--finance/p5-Business-OnlinePayment/pkg-descr2
-rw-r--r--finance/p5-Business-OnlinePayment/pkg-plist9
4 files changed, 23 insertions, 13 deletions
diff --git a/finance/p5-Business-OnlinePayment/Makefile b/finance/p5-Business-OnlinePayment/Makefile
index 1206e40a2d5..a1c92ce8adb 100644
--- a/finance/p5-Business-OnlinePayment/Makefile
+++ b/finance/p5-Business-OnlinePayment/Makefile
@@ -6,21 +6,28 @@
#
PORTNAME= Business-OnlinePayment
-PORTVERSION= 2.01
-PORTREVISION= 1
+PORTVERSION= 3.00
CATEGORIES= finance perl5
-MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
-MASTER_SITE_SUBDIR= Business
+MASTER_SITES= CPAN/../by-authors/id/I/IV/IVAN/
PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION}_08
MAINTAINER= erwin@FreeBSD.org
COMMENT= A generic interface for processing online credit card payments
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay \
+ ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/Tie/IxHash.pm:${PORTSDIR}/devel/p5-Tie-IxHash \
+ ${SITE_PERL}/Test/Pod.pm:${PORTSDIR}/devel/p5-Test-Pod \
+ ${SITE_PERL}/${PERL_ARCH}/Crypt/SSLeay.pm:${PORTSDIR}/security/p5-Crypt-SSLeay \
+ ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
-MAN3= Business::OnlinePayment.3
+MAN3= Business::OnlinePayment.3 \
+ Business::FraudDetect.3 \
+ Business::FraudDetect::preCharge.3 \
+ Business::OnlinePayment::HTTPS.3
.include <bsd.port.mk>
diff --git a/finance/p5-Business-OnlinePayment/distinfo b/finance/p5-Business-OnlinePayment/distinfo
index 2546e8ffa85..5353180ca0e 100644
--- a/finance/p5-Business-OnlinePayment/distinfo
+++ b/finance/p5-Business-OnlinePayment/distinfo
@@ -1,3 +1,3 @@
-MD5 (Business-OnlinePayment-2.01.tar.gz) = 1ad6ad0cfff36c813c36195ef91b704a
-SHA256 (Business-OnlinePayment-2.01.tar.gz) = ab0e76382fda9db825f68b60b69b0649ae289a391fe50f13c5946ccbf0b99dea
-SIZE (Business-OnlinePayment-2.01.tar.gz) = 5514
+MD5 (Business-OnlinePayment-3.00_08.tar.gz) = 5eb8c86124c8305039e4eb0d190e8d12
+SHA256 (Business-OnlinePayment-3.00_08.tar.gz) = f354ecbc695dfcbac8b82a302e3f2ba0c6890e31c265ab99d3064e02dd842475
+SIZE (Business-OnlinePayment-3.00_08.tar.gz) = 16840
diff --git a/finance/p5-Business-OnlinePayment/pkg-descr b/finance/p5-Business-OnlinePayment/pkg-descr
index 9f97a08a4fe..4607806e3f0 100644
--- a/finance/p5-Business-OnlinePayment/pkg-descr
+++ b/finance/p5-Business-OnlinePayment/pkg-descr
@@ -7,3 +7,5 @@ IMPORTANT: Business::OnlinePayment only defines the frontend interface to the
system, in order to use it you also need to have at least one backend
processing module installed, the processors supported are listed below along
with the types of transactions supported.
+
+WWW: http://search.cpan.org/dist/Business-OnlinePayment/
diff --git a/finance/p5-Business-OnlinePayment/pkg-plist b/finance/p5-Business-OnlinePayment/pkg-plist
index 44c0ddcd73b..8f19e3eccdf 100644
--- a/finance/p5-Business-OnlinePayment/pkg-plist
+++ b/finance/p5-Business-OnlinePayment/pkg-plist
@@ -1,9 +1,10 @@
-%%SITE_PERL%%/Business/OnlinePayment.pm
-%%SITE_PERL%%/auto/Business/OnlinePayment/autosplit.ix
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Business/OnlinePayment/.packlist
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Business/OnlinePayment
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Business
+%%SITE_PERL%%/Business/FraudDetect.pm
+%%SITE_PERL%%/Business/OnlinePayment.pm
+%%SITE_PERL%%/Business/FraudDetect/preCharge.pm
+%%SITE_PERL%%/Business/OnlinePayment/HTTPS.pm
@dirrmtry %%SITE_PERL%%/Business/OnlinePayment
+@dirrmtry %%SITE_PERL%%/Business/FraudDetect
@dirrmtry %%SITE_PERL%%/Business
-@dirrm %%SITE_PERL%%/auto/Business/OnlinePayment
-@dirrm %%SITE_PERL%%/auto/Business