aboutsummaryrefslogtreecommitdiffstats
path: root/finance
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-09-11 02:00:21 +0800
committermarino <marino@FreeBSD.org>2016-09-11 02:00:21 +0800
commit39170898ad12bcf10c866fec41bf9009bcae4b52 (patch)
tree906f3a840cc5a166188cd01df91edb991cc08ac3 /finance
parent33408a91d204e71c5a15a632913442b8807ca7c2 (diff)
downloadfreebsd-ports-graphics-39170898ad12bcf10c866fec41bf9009bcae4b52.tar.gz
freebsd-ports-graphics-39170898ad12bcf10c866fec41bf9009bcae4b52.tar.zst
freebsd-ports-graphics-39170898ad12bcf10c866fec41bf9009bcae4b52.zip
devel/php-tclink: Document SSL requirement and fix build for LibreSSL
Approved by: SSL blanket
Diffstat (limited to 'finance')
-rw-r--r--finance/php-tclink/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/finance/php-tclink/Makefile b/finance/php-tclink/Makefile
index 1a8f50b12af..65c4a8a4ea6 100644
--- a/finance/php-tclink/Makefile
+++ b/finance/php-tclink/Makefile
@@ -12,9 +12,13 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-php
MAINTAINER= mbowie@buzmo.com
COMMENT= PHP extension for TrustCommerce credit card processing
-USES= php:ext
-USE_OPENSSL= yes
+USES= php:ext ssl
IGNORE_WITH_PHP= 70
+post-patch:
+ # avoid name conflicts with libressl
+ ${REINPLACE_CMD} -e 's|\(X509_STORE_load_mem\)|uniq_\1|g' \
+ -e 's|\(X509_LOOKUP_mem\)|uniq_\1|g' ${WRKSRC}/mem.c
+
.include <bsd.port.mk>