aboutsummaryrefslogtreecommitdiffstats
path: root/finance
diff options
context:
space:
mode:
authorskreuzer <skreuzer@FreeBSD.org>2011-04-03 12:42:04 +0800
committerskreuzer <skreuzer@FreeBSD.org>2011-04-03 12:42:04 +0800
commite2b74e7fd58ffe28f0af6895c8abed01933c44e1 (patch)
treebe52b8c53712c42a893df6882d05c38bd30d2a69 /finance
parent883f7bd1e316e879932a49dd96850d349077a461 (diff)
downloadfreebsd-ports-graphics-e2b74e7fd58ffe28f0af6895c8abed01933c44e1.tar.gz
freebsd-ports-graphics-e2b74e7fd58ffe28f0af6895c8abed01933c44e1.tar.zst
freebsd-ports-graphics-e2b74e7fd58ffe28f0af6895c8abed01933c44e1.zip
Bitcoin is a peer-to-peer network based digital currency.
Finance::Bitcoin provides a perl interface to the high and low level APIs for managing a running bitcoin instance over JSON-RPC. WWW: http://search.cpan.org/dist/Finance-Bitcoin/
Diffstat (limited to 'finance')
-rw-r--r--finance/Makefile1
-rw-r--r--finance/p5-Finance-Bitcoin/Makefile30
-rw-r--r--finance/p5-Finance-Bitcoin/distinfo2
-rw-r--r--finance/p5-Finance-Bitcoin/pkg-descr7
-rw-r--r--finance/p5-Finance-Bitcoin/pkg-plist10
5 files changed, 50 insertions, 0 deletions
diff --git a/finance/Makefile b/finance/Makefile
index 4b42db07ead..7310d037d01 100644
--- a/finance/Makefile
+++ b/finance/Makefile
@@ -64,6 +64,7 @@
SUBDIR += p5-Business-WorldPay-Junior
SUBDIR += p5-Data-Currency
SUBDIR += p5-Finance-Amortization
+ SUBDIR += p5-Finance-Bitcoin
SUBDIR += p5-Finance-Currency-Convert
SUBDIR += p5-Finance-Currency-Convert-WebserviceX
SUBDIR += p5-Finance-Currency-Convert-XE
diff --git a/finance/p5-Finance-Bitcoin/Makefile b/finance/p5-Finance-Bitcoin/Makefile
new file mode 100644
index 00000000000..1d9925e9b53
--- /dev/null
+++ b/finance/p5-Finance-Bitcoin/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Finance-Bitcoin
+# Date created: 2011-04-02
+# Whom: Steven Kreuzer <skreuzer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Finance-Bitcoin
+PORTVERSION= 0.002
+CATEGORIES= finance perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skreuzer@FreeBSD.org
+COMMENT= Perl interface to a bitcoin instance
+
+RUN_DEPENDS= p5-JSON-RPC>=0.96:${PORTSDIR}/devel/p5-JSON-RPC \
+ p5-Class-Accessor>=0.34:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-Module-Signature>=0.66:${PORTSDIR}/security/p5-Module-Signature \
+ p5-Scalar-List-Utils>=1.23:${PORTSDIR}/lang/p5-Scalar-List-Utils
+BUILD_DEPENDS= p5-Test-Simple>=0.86:${PORTSDIR}/devel/p5-Test-Simple
+
+PERL_CONFIGURE= yes
+
+MAN3= Finance::Bitcoin::API.3 \
+ Finance::Bitcoin::Address.3 \
+ Finance::Bitcoin::Wallet.3 \
+ Finance::Bitcoin.3
+
+.include <bsd.port.mk>
diff --git a/finance/p5-Finance-Bitcoin/distinfo b/finance/p5-Finance-Bitcoin/distinfo
new file mode 100644
index 00000000000..0fab5d06216
--- /dev/null
+++ b/finance/p5-Finance-Bitcoin/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Finance-Bitcoin-0.002.tar.gz) = ef486d12f3a14dfc224637a6758eca6119e7a49900179809abc783550d6f2e63
+SIZE (Finance-Bitcoin-0.002.tar.gz) = 31052
diff --git a/finance/p5-Finance-Bitcoin/pkg-descr b/finance/p5-Finance-Bitcoin/pkg-descr
new file mode 100644
index 00000000000..6ece33a05e7
--- /dev/null
+++ b/finance/p5-Finance-Bitcoin/pkg-descr
@@ -0,0 +1,7 @@
+Bitcoin is a peer-to-peer network based digital currency.
+
+Finance::Bitcoin provides a perl interface to the high
+and low level APIs for managing a running bitcoin
+instance over JSON-RPC.
+
+WWW: http://search.cpan.org/dist/Finance-Bitcoin/
diff --git a/finance/p5-Finance-Bitcoin/pkg-plist b/finance/p5-Finance-Bitcoin/pkg-plist
new file mode 100644
index 00000000000..934373c4199
--- /dev/null
+++ b/finance/p5-Finance-Bitcoin/pkg-plist
@@ -0,0 +1,10 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/Finance/Bitcoin/API.pm
+%%SITE_PERL%%/Finance/Bitcoin/Address.pm
+%%SITE_PERL%%/Finance/Bitcoin/Wallet.pm
+%%SITE_PERL%%/Finance/Bitcoin.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Finance/Bitcoin/.packlist
+@dirrm %%SITE_PERL%%/Finance/Bitcoin
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Finance/Bitcoin
+@dirrmtry %%SITE_PERL%%/Finance
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Finance