aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/moxftp/Makefile
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2000-11-13 22:10:08 +0800
committerkevlo <kevlo@FreeBSD.org>2000-11-13 22:10:08 +0800
commitb64721adc7579c37a2b94b1698ff0181c4a70dc5 (patch)
treefd848fdc1e1d76dea1d05285ea95804774498ed3 /ftp/moxftp/Makefile
parent540ca0e3a85ed76f3d80cda3f11e6445e42280a0 (diff)
downloadfreebsd-ports-graphics-b64721adc7579c37a2b94b1698ff0181c4a70dc5.tar.gz
freebsd-ports-graphics-b64721adc7579c37a2b94b1698ff0181c4a70dc5.tar.zst
freebsd-ports-graphics-b64721adc7579c37a2b94b1698ff0181c4a70dc5.zip
- Fix MASTER_SITES
- Support CFLAGS propely PR: 22813 Submitted by: Ports Fury
Diffstat (limited to 'ftp/moxftp/Makefile')
-rw-r--r--ftp/moxftp/Makefile19
1 files changed, 9 insertions, 10 deletions
diff --git a/ftp/moxftp/Makefile b/ftp/moxftp/Makefile
index da22eadb1b0..918357bf0da 100644
--- a/ftp/moxftp/Makefile
+++ b/ftp/moxftp/Makefile
@@ -8,32 +8,31 @@
PORTNAME= moxftp
PORTVERSION= 2.2
CATEGORIES= ftp
-MASTER_SITES= ftp://metalab.unc.edu/pub/X11/contrib/applications/ \
- ftp://ftp.inria.fr/X/contrib-R5/applications/ \
- ftp://ftp.tk.mesh.ad.jp/pub/X/contrib/applications/
+MASTER_SITES= ftp://ftp.ibiblio.org/pub/X11/contrib/applications/ \
+ ftp://ftp.inria.fr/X/contrib-R5/applications/
EXTRACT_SUFX= .tar.Z
MAINTAINER= ports@FreeBSD.org
-GNU_CONFIGURE= yes
USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
MAN1= ${PROGRAM_NAME}.1
PLIST_SUB= PROGRAM_NAME=${PROGRAM_NAME} RESOURCE_NAME=${RESOURCE_NAME}
-STRIP=
+STRIP= # empty
.if !defined(WANT_ATHENA_VERSION)
USE_MOTIF= yes
CONFIGURE_ARGS= motif
-PROGRAM_NAME=mftp
-RESOURCE_NAME=Mftp
+PROGRAM_NAME= mftp
+RESOURCE_NAME= Mftp
.else
CONFIGURE_ARGS= athena
-PROGRAM_NAME=xftp
-RESOURCE_NAME=Xftp
+PROGRAM_NAME= xftp
+RESOURCE_NAME= Xftp
.endif
post-install:
@strip ${PREFIX}/bin/${PROGRAM_NAME}
- @${INSTALL_MAN} ${WRKSRC}/${PROGRAM_NAME}.man ${PREFIX}/man/man1/${PROGRAM_NAME}.1
+ ${INSTALL_MAN} ${WRKSRC}/${PROGRAM_NAME}.man ${MANPREFIX}/man/man1/${PROGRAM_NAME}.1
.include <bsd.port.mk>