aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/proftpd
diff options
context:
space:
mode:
authorshaun <shaun@FreeBSD.org>2006-11-16 03:22:23 +0800
committershaun <shaun@FreeBSD.org>2006-11-16 03:22:23 +0800
commit53f297df3dd6112b262cfd1a153f4c42cceee90f (patch)
tree65c7d090888f5d46bde486448691b562c1f79b57 /ftp/proftpd
parent25a53e47ca4d31ea6c395d2c7c8476a42b34e075 (diff)
downloadfreebsd-ports-graphics-53f297df3dd6112b262cfd1a153f4c42cceee90f.tar.gz
freebsd-ports-graphics-53f297df3dd6112b262cfd1a153f4c42cceee90f.tar.zst
freebsd-ports-graphics-53f297df3dd6112b262cfd1a153f4c42cceee90f.zip
- Fix the last imported patch (which came from proftpd's CVS repo),
as it was causing segfaults prior to login. - Add the new CommandBufferSize variable into the default config file to stop proftpd complaining. Reported by: many
Diffstat (limited to 'ftp/proftpd')
-rw-r--r--ftp/proftpd/Makefile2
-rw-r--r--ftp/proftpd/files/patch-main.c8
-rw-r--r--ftp/proftpd/files/patch-sample-configurations_basic.conf15
3 files changed, 17 insertions, 8 deletions
diff --git a/ftp/proftpd/Makefile b/ftp/proftpd/Makefile
index 5c7ccf8d6f6..d392044538e 100644
--- a/ftp/proftpd/Makefile
+++ b/ftp/proftpd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= proftpd
DISTVERSION= 1.3.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= ftp
MASTER_SITES= ftp://ftp.proftpd.org/distrib/source/ \
ftp://ftp.fastorama.com/mirrors/ftp.proftpd.org/distrib/source/ \
diff --git a/ftp/proftpd/files/patch-main.c b/ftp/proftpd/files/patch-main.c
index 10b29b39584..eb948cc779a 100644
--- a/ftp/proftpd/files/patch-main.c
+++ b/ftp/proftpd/files/patch-main.c
@@ -1,5 +1,5 @@
---- src/main.c.orig Wed Mar 15 21:41:01 2006
-+++ src/main.c Tue Nov 14 08:47:12 2006
+--- src/main.c.orig Wed Mar 15 19:41:01 2006
++++ src/main.c Wed Nov 15 19:06:18 2006
@@ -116,6 +116,8 @@
static char sbuf[PR_TUNABLE_BUFFER_SIZE] = {'\0'};
@@ -27,9 +27,9 @@
- cmd_buf_size = 512;
+ if (bufsz == NULL ||
+ *bufsz <= 0) {
-+ pr_log_pri(PR_LOG_WARNING, "invalid CommandBufferSize size (%d) "
++ pr_log_pri(PR_LOG_WARNING, "invalid CommandBufferSize size "
+ "given, resetting to default buffer size (%u)",
-+ *bufsz, (unsigned int) PR_DEFAULT_CMD_BUFSZ);
++ (unsigned int) PR_DEFAULT_CMD_BUFSZ);
+ cmd_buf_size = PR_DEFAULT_CMD_BUFSZ;
+
+ } else if (*bufsz + 1 > sizeof(buf)) {
diff --git a/ftp/proftpd/files/patch-sample-configurations_basic.conf b/ftp/proftpd/files/patch-sample-configurations_basic.conf
index fa3f8dfc355..d6312df3da9 100644
--- a/ftp/proftpd/files/patch-sample-configurations_basic.conf
+++ b/ftp/proftpd/files/patch-sample-configurations_basic.conf
@@ -1,5 +1,5 @@
---- sample-configurations/basic.conf.orig Fri Jun 17 15:10:06 2005
-+++ sample-configurations/basic.conf Fri Jun 17 15:10:43 2005
+--- sample-configurations/basic.conf.orig Thu Apr 15 19:46:38 2004
++++ sample-configurations/basic.conf Wed Nov 15 19:14:36 2006
@@ -1,3 +1,7 @@
+#
+# To have more informations about Proftpd configuration
@@ -16,7 +16,16 @@
# Port 21 is the standard FTP port.
Port 21
-@@ -40,23 +45,29 @@
+@@ -22,6 +27,8 @@
+ # (such as xinetd).
+ MaxInstances 30
+
++CommandBufferSize 512
++
+ # Set the user and group under which the server will run.
+ User nobody
+ Group nogroup
+@@ -40,23 +47,29 @@
# A basic anonymous configuration, no upload directories. If you do not
# want anonymous users, simply delete this entire <Anonymous> section.