aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/wget
diff options
context:
space:
mode:
authorsf <sf@FreeBSD.org>2002-07-28 16:24:49 +0800
committersf <sf@FreeBSD.org>2002-07-28 16:24:49 +0800
commitc8b3a4f5575caa21e1623bbf9d8713a8f20b970f (patch)
tree4fb9e221a8794ab1e00f3496189d7cf7054e68d4 /ftp/wget
parent113441033bb82d96946a56c897fb8452f436004f (diff)
downloadfreebsd-ports-graphics-c8b3a4f5575caa21e1623bbf9d8713a8f20b970f.tar.gz
freebsd-ports-graphics-c8b3a4f5575caa21e1623bbf9d8713a8f20b970f.tar.zst
freebsd-ports-graphics-c8b3a4f5575caa21e1623bbf9d8713a8f20b970f.zip
When I update wget to 1.8.2, I intentionally removed manpage due to
its absence. Further investigation lead me to the answer, it depends on perl. wget.1 has been built with pod2man which is of course a part of perl5 port now in -CURRENT. add USE_PERL5 and resurrect MAN1 for this port. Thanks to: vanilla
Diffstat (limited to 'ftp/wget')
-rw-r--r--ftp/wget/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/ftp/wget/Makefile b/ftp/wget/Makefile
index 17a288a553b..ac6a4ca9094 100644
--- a/ftp/wget/Makefile
+++ b/ftp/wget/Makefile
@@ -7,6 +7,7 @@
PORTNAME= wget
PORTVERSION= 1.8.2
+PORTREVISION= 1
CATEGORIES= ftp www
MASTER_SITES= ${MASTER_SITE_GNU} \
ftp://ftp.dl.ac.uk/ccp14/ftp-mirror/wget/pub/unix/util/wget/ \
@@ -22,6 +23,7 @@ LIB_DEPENDS= intl.2:${PORTSDIR}/devel/gettext
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_PERL5= yes # only for pod2man
.if defined(WITHOUT_SSL)
CONFIGURE_ARGS= --with-ssl=no
@@ -31,6 +33,8 @@ USE_OPENSSL= yes
CONFIGURE_ENV+= CPPFLAGS=-I${LOCALBASE}/include \
LIBS=-L${LOCALBASE}/lib
+MAN1= wget.1
+
post-patch:
${RM} -f ${WRKSRC}/doc/wget.info*
# we don't need to run autoconf.