aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-10-21 23:21:13 +0800
committermat <mat@FreeBSD.org>2016-10-21 23:21:13 +0800
commit60e51bda11dcc0742419f2a459990d0d81cb07d8 (patch)
treea5029ff30555b3a7ee0621f4dd5aacb832fde1d8 /ftp
parent3432585b4743642027fc2b3af5eac2780fc2c4cd (diff)
downloadfreebsd-ports-graphics-60e51bda11dcc0742419f2a459990d0d81cb07d8.tar.gz
freebsd-ports-graphics-60e51bda11dcc0742419f2a459990d0d81cb07d8.tar.zst
freebsd-ports-graphics-60e51bda11dcc0742419f2a459990d0d81cb07d8.zip
Use USES=pathfix where applicable.
PR: 213195 Submitted by: mat Exp-run by: antoine Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D8093
Diffstat (limited to 'ftp')
-rw-r--r--ftp/curl/Makefile2
-rw-r--r--ftp/curl/files/patch-configure10
-rw-r--r--ftp/curlpp/Makefile1
3 files changed, 1 insertions, 12 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index 60fa37f535a..630210937fc 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -158,7 +158,7 @@ IGNORE= unsupported TLS-SRP in LibreSSL
post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS = / s|$$| docs scripts|; /^DIST_SUBDIRS = / s| docs scripts||; /cd docs &&/d' ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e 's|\(flags_dbg_off=\)".*"|\1""|; s|\(flags_opt_off=\)".*"|\1""|; s|lib/pkgconfig|libdata/pkgconfig|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|\(flags_dbg_off=\)".*"|\1""|; s|\(flags_opt_off=\)".*"|\1""|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|include <gssapi.h>|include <gssapi/gssapi.h>|' ${WRKSRC}/lib/curl_gssapi.h ${WRKSRC}/lib/urldata.h
.if !defined(BUILDING_HIPHOP)
diff --git a/ftp/curl/files/patch-configure b/ftp/curl/files/patch-configure
index be10172e26d..86d89feb651 100644
--- a/ftp/curl/files/patch-configure
+++ b/ftp/curl/files/patch-configure
@@ -70,16 +70,6 @@ Last-Update: 2010-12-19
if test "$want_optimize" = "yes"; then
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking if compiler accepts optimizer enabling options" >&5
-@@ -21417,7 +21425,8 @@ if test "$curl_ssl_msg" = "$init_ssl_msg
- PKGTEST="no"
- PREFIX_OPENSSL=$OPT_SSL
-
-- OPENSSL_PCDIR="$OPT_SSL/lib/pkgconfig"
-+ # Use the FreeBSD location of the pkgconf libdir
-+ OPENSSL_PCDIR="$LOCALBASE/libdata/pkgconfig"
- { $as_echo "$as_me:${as_lineno-$LINENO}: PKG_CONFIG_LIBDIR will be set to \"$OPENSSL_PCDIR\"" >&5
- $as_echo "$as_me: PKG_CONFIG_LIBDIR will be set to \"$OPENSSL_PCDIR\"" >&6;}
- if test -f "$OPENSSL_PCDIR/openssl.pc"; then
@@ -25050,29 +25059,30 @@ $as_echo "found" >&6; }
;;
off)
diff --git a/ftp/curlpp/Makefile b/ftp/curlpp/Makefile
index 6fd218cd4f7..f5cd649372e 100644
--- a/ftp/curlpp/Makefile
+++ b/ftp/curlpp/Makefile
@@ -20,7 +20,6 @@ OPTIONS_DEFINE= BOOST DOCS EXAMPLES
CONFIGURE_ARGS= --disable-ewarning
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-PATHFIX_MAKEFILEIN= Makefile.am
USE_LDCONFIG= yes
USES= autoreconf libtool localbase pathfix