aboutsummaryrefslogtreecommitdiffstats
path: root/games/adonthell
diff options
context:
space:
mode:
authoralexbl <alexbl@FreeBSD.org>2007-07-30 17:42:28 +0800
committeralexbl <alexbl@FreeBSD.org>2007-07-30 17:42:28 +0800
commit7d749db4cf14f30613e9a53a08ffa3d3b4575146 (patch)
treead9062005432bbf28f5cce4ad3a1cd32a59dba69 /games/adonthell
parent8e2da239f74a82ad1c98b69bd27abb3f4e40ecf3 (diff)
downloadfreebsd-ports-graphics-7d749db4cf14f30613e9a53a08ffa3d3b4575146.tar.gz
freebsd-ports-graphics-7d749db4cf14f30613e9a53a08ffa3d3b4575146.tar.zst
freebsd-ports-graphics-7d749db4cf14f30613e9a53a08ffa3d3b4575146.zip
- Make Python 2.5.1 the default Python version
- Add significantly better support in bsd.python.mk for working with Python Eggs and the easy_install system Tested by: pointyhat runs Approved by: pav (portmgr) Most work by: perky Thanks to: pav
Diffstat (limited to 'games/adonthell')
-rw-r--r--games/adonthell/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/games/adonthell/Makefile b/games/adonthell/Makefile
index 2c23abefeb7..ef100a64d6e 100644
--- a/games/adonthell/Makefile
+++ b/games/adonthell/Makefile
@@ -22,13 +22,14 @@ BUILD_DEPENDS= swig:${PORTSDIR}/devel/swig13 \
LIB_DEPENDS= vorbis.4:${PORTSDIR}/audio/libvorbis
USE_SDL= mixer sdl
-USE_PYTHON= yes
+USE_PYTHON= -2.4
USE_GETTEXT= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --disable-py-debug
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= LDFLAGS=-L${LOCALBASE}/lib
+CONFIGURE_ENV= LDFLAGS=-L${LOCALBASE}/lib \
+ PYPACKAGE=${PYTHON_CMD}
.include <bsd.port.pre.mk>