aboutsummaryrefslogtreecommitdiffstats
path: root/games/alephone
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2004-09-21 03:43:12 +0800
committerdanfe <danfe@FreeBSD.org>2004-09-21 03:43:12 +0800
commit2b7ea3b722b8bf6dfc324b73fee79e5da07b858f (patch)
tree32522faa7ab4543dc6ee43246c3804d909f47931 /games/alephone
parentf9f97a16b5ae45fb7dbe85ae20dc58ed3feda0b3 (diff)
downloadfreebsd-ports-graphics-2b7ea3b722b8bf6dfc324b73fee79e5da07b858f.tar.gz
freebsd-ports-graphics-2b7ea3b722b8bf6dfc324b73fee79e5da07b858f.tar.zst
freebsd-ports-graphics-2b7ea3b722b8bf6dfc324b73fee79e5da07b858f.zip
Fix problematic C++ code, and unbreak the build with recent GCC.
Reported by: kris Approved by: portmgr (marcus), fjoe (mentor, implicit)
Diffstat (limited to 'games/alephone')
-rw-r--r--games/alephone/Makefile8
-rw-r--r--games/alephone/files/patch-Source_Files::Misc::sdl_widgets.h20
2 files changed, 21 insertions, 7 deletions
diff --git a/games/alephone/Makefile b/games/alephone/Makefile
index 9ea6be5a6dd..8f677a4475c 100644
--- a/games/alephone/Makefile
+++ b/games/alephone/Makefile
@@ -22,12 +22,6 @@ USE_X_PREFIX= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
post-patch:
@${PERL} -pi -e 's,^#include \"network_modem.h\".*,,' \
${WRKSRC}/Source_Files/Network/network.cpp \
@@ -38,4 +32,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/alephone/files/patch-Source_Files::Misc::sdl_widgets.h b/games/alephone/files/patch-Source_Files::Misc::sdl_widgets.h
new file mode 100644
index 00000000000..89bc01409e5
--- /dev/null
+++ b/games/alephone/files/patch-Source_Files::Misc::sdl_widgets.h
@@ -0,0 +1,20 @@
+--- Source_Files/Misc/sdl_widgets.h.orig Mon Jul 16 21:37:51 2001
++++ Source_Files/Misc/sdl_widgets.h Mon Sep 20 20:46:48 2004
+@@ -402,7 +402,7 @@
+ protected:
+ void draw_items(SDL_Surface *s) const
+ {
+- vector<T>::const_iterator i = items.begin() + top_item;
++ typename vector<T>::const_iterator i = items.begin() + top_item;
+ int x = rect.x + get_dialog_space(LIST_L_SPACE);
+ int y = rect.y + get_dialog_space(LIST_T_SPACE);
+ int width = rect.w - get_dialog_space(LIST_L_SPACE) - get_dialog_space(LIST_R_SPACE);
+@@ -413,7 +413,7 @@
+ const vector<T> &items; // List of items
+
+ private:
+- virtual void draw_item(vector<T>::const_iterator i, SDL_Surface *s, int x, int y, int width, bool selected) const = 0;
++ virtual void draw_item(typename vector<T>::const_iterator i, SDL_Surface *s, int x, int y, int width, bool selected) const = 0;
+ };
+
+ #endif