aboutsummaryrefslogtreecommitdiffstats
path: root/games/atris-sounds
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2013-11-17 23:21:04 +0800
committerdanilo <danilo@FreeBSD.org>2013-11-17 23:21:04 +0800
commit49b1aab429f2620e4f6d46a017842fe633fc8236 (patch)
tree8f5a0f492786432ac25e8a932fb72683e2f38f72 /games/atris-sounds
parent34719da55460bbd7190db66df6e755159630a86b (diff)
downloadfreebsd-ports-graphics-49b1aab429f2620e4f6d46a017842fe633fc8236.tar.gz
freebsd-ports-graphics-49b1aab429f2620e4f6d46a017842fe633fc8236.tar.zst
freebsd-ports-graphics-49b1aab429f2620e4f6d46a017842fe633fc8236.zip
- Convert USE_GMAKE to USES
- Add stage support
Diffstat (limited to 'games/atris-sounds')
-rw-r--r--games/atris-sounds/Makefile6
-rw-r--r--games/atris-sounds/pkg-plist3
2 files changed, 6 insertions, 3 deletions
diff --git a/games/atris-sounds/Makefile b/games/atris-sounds/Makefile
index 09c88a02938..fb0ae6beeed 100644
--- a/games/atris-sounds/Makefile
+++ b/games/atris-sounds/Makefile
@@ -14,14 +14,16 @@ COMMENT= Sounds for Atris: Alizarin Tetris
RUN_DEPENDS= atris:${PORTSDIR}/games/atris
-USE_GMAKE= yes
+USES= gmake
GNU_CONFIGURE= yes
NO_WRKSUBDIR= yes
-NO_STAGE= yes
post-patch:
# Fix path to ${DATADIR}
${REINPLACE_CMD} -e 's|\(GAME_INSTALLDIR=\).*|\1"${DATADIR}"|' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+do-install:
+ (cd ${WRKSRC} ; ${COPYTREE_SHARE} sounds ${STAGEDIR}${DATADIR})
+
.include <bsd.port.mk>
diff --git a/games/atris-sounds/pkg-plist b/games/atris-sounds/pkg-plist
index 9f1bfb103ea..08862832770 100644
--- a/games/atris-sounds/pkg-plist
+++ b/games/atris-sounds/pkg-plist
@@ -62,4 +62,5 @@
%%DATADIR%%/sounds/staffh.wav
%%DATADIR%%/sounds/whirling.wav
%%DATADIR%%/sounds/whoosh.wav
-@dirrm %%DATADIR%%/sounds
+@dirrmtry %%DATADIR%%/sounds
+@dirrmtry %%DATADIR%%