aboutsummaryrefslogtreecommitdiffstats
path: root/games/cleanq3/files/patch-code-unix-unix_main.c
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2006-07-24 02:56:26 +0800
committeralepulver <alepulver@FreeBSD.org>2006-07-24 02:56:26 +0800
commit9fc8ec49dfbba1e61e8c4ea86a294e1a0ef611d7 (patch)
treed885180368e9d4eee667641cd9b6a14f0c998a17 /games/cleanq3/files/patch-code-unix-unix_main.c
parent2fd6173bb8db9e9f2a87b2e8bd1a4d803737e196 (diff)
downloadfreebsd-ports-graphics-9fc8ec49dfbba1e61e8c4ea86a294e1a0ef611d7.tar.gz
freebsd-ports-graphics-9fc8ec49dfbba1e61e8c4ea86a294e1a0ef611d7.tar.zst
freebsd-ports-graphics-9fc8ec49dfbba1e61e8c4ea86a294e1a0ef611d7.zip
- Bump PORTREVISION.
- Use Makefile for building instead of scons, and remove Perl dependency. - Use pkg-plist. - Add OPTIONS. Allow to build without X11, threaded version, etc. - Fix building on non-i386 and FreeBSD 4.X. - Respect CFLAGS when optimizations are enabled. - Add patch to fix 2 security vulnerabilities [1]. PR: ports/98295 Submitted by: alepulver (myself) Approved by: maintainer (timeout) Obtained from: q3icculus (http://icculus.org/quake3/) [1] Security: CVE-2006-2082 [1]
Diffstat (limited to 'games/cleanq3/files/patch-code-unix-unix_main.c')
-rw-r--r--games/cleanq3/files/patch-code-unix-unix_main.c6
1 files changed, 3 insertions, 3 deletions
diff --git a/games/cleanq3/files/patch-code-unix-unix_main.c b/games/cleanq3/files/patch-code-unix-unix_main.c
index 61d3841662c..049808e7784 100644
--- a/games/cleanq3/files/patch-code-unix-unix_main.c
+++ b/games/cleanq3/files/patch-code-unix-unix_main.c
@@ -1,5 +1,5 @@
---- code/unix/unix_main.c.orig Mon Mar 20 18:39:10 2006
-+++ code/unix/unix_main.c Mon Mar 20 20:24:22 2006
+--- ./code/unix/unix_main.c.orig Wed May 31 20:52:08 2006
++++ ./code/unix/unix_main.c Wed May 31 20:52:09 2006
@@ -722,17 +722,7 @@
assert( name );
@@ -25,7 +25,7 @@
{
+ Com_Printf( "Sys_LoadDll(%s) failed:\n\"%s\"\n", fn, dlerror() );
+ // FreeBSD package installation path
-+ fn = FS_BuildOSPath( "%%PREFIX%%/lib/cleanq3", gamedir, fname );
++ fn = FS_BuildOSPath( LIBDIR , gamedir, fname );
+ Com_Printf( "Sys_LoadDll(%s)... \n", fn );
+ libHandle = dlopen( fn, Q_RTLD );
+