aboutsummaryrefslogtreecommitdiffstats
path: root/games/freeciv-gtk2/Makefile
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1999-02-03 19:12:01 +0800
committerasami <asami@FreeBSD.org>1999-02-03 19:12:01 +0800
commitaa52cd921c82a10ec33065084fe0edb5cf8bebbc (patch)
treeb70284a297d2e3c06462e3a3a86166c4371477f9 /games/freeciv-gtk2/Makefile
parentdd1603cad7e60d10dd91a2f1f918e24ed859ed24 (diff)
downloadfreebsd-ports-graphics-aa52cd921c82a10ec33065084fe0edb5cf8bebbc.tar.gz
freebsd-ports-graphics-aa52cd921c82a10ec33065084fe0edb5cf8bebbc.tar.zst
freebsd-ports-graphics-aa52cd921c82a10ec33065084fe0edb5cf8bebbc.zip
Adjust port Makefiles to new EXTRACT_* variable defaults. See log of
bsd.port.mk rev. 1.304 for details on the change. The fix here is one of the following. (1) Define USE_BZIP2 instead of BUILD_DEPENDS on bzip2 and redefining EXTRACT_* commands. (2) Change ${EXTRACT_CMD} to ${TAR} when the command is obviously calling the "tar" command (i.e., arguments like "-xzf" are spelled out). (3) If ${EXTRACT_CMD} is called directly with ${EXTRACT_BEFORE_ARGS}, add ${EXTRACT_AFTER_ARGS} to the command line as well. (4) If any of EXTRACT_CMD, EXTRACT_BEFORE_ARGS or EXTRACT_AFTER_ARGS is set, define the other two too.
Diffstat (limited to 'games/freeciv-gtk2/Makefile')
-rw-r--r--games/freeciv-gtk2/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/games/freeciv-gtk2/Makefile b/games/freeciv-gtk2/Makefile
index 686a1cd0902..4ac230d5d9c 100644
--- a/games/freeciv-gtk2/Makefile
+++ b/games/freeciv-gtk2/Makefile
@@ -3,7 +3,7 @@
# Date created: Jun 20 1997
# Whom: ada@bsd.org
#
-# $Id: Makefile,v 1.16 1999/02/01 01:22:16 obrien Exp $
+# $Id: Makefile,v 1.17 1999/02/01 22:01:00 asami Exp $
#
DISTNAME= freeciv-1.7.2
@@ -13,15 +13,11 @@ EXTRACT_SUFX= .tar.bz2
MAINTAINER= ada@bsd.org
-BUILD_DEPENDS= bzip2:${PORTSDIR}/archivers/bzip2
LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm
BROKEN='no route to the *single* mastersite'
-EXTRACT_CMD= bzip2
-EXTRACT_BEFORE_ARGS= -cd
-EXTRACT_AFTER_ARGS= | tar xf -
-
+USE_BZIP2= yes
GNU_CONFIGURE= yes
.include <bsd.port.mk>