aboutsummaryrefslogtreecommitdiffstats
path: root/games/garith/Makefile
diff options
context:
space:
mode:
authormharo <mharo@FreeBSD.org>2000-04-02 09:00:24 +0800
committermharo <mharo@FreeBSD.org>2000-04-02 09:00:24 +0800
commitd6dca242be4c3ffc4cb11bccc8226000d08b8de0 (patch)
tree243714e8b0e8504368d58d81c3c431e9a2ef2533 /games/garith/Makefile
parentf8facd78314b70d65c255b6702a5c1ddabdd19ea (diff)
downloadfreebsd-ports-graphics-d6dca242be4c3ffc4cb11bccc8226000d08b8de0.tar.gz
freebsd-ports-graphics-d6dca242be4c3ffc4cb11bccc8226000d08b8de0.tar.zst
freebsd-ports-graphics-d6dca242be4c3ffc4cb11bccc8226000d08b8de0.zip
***
games/affenspiel - Support CC properly *** games/battalion - Support PREFIX properly *** games/block - Support CC/CFLAGS properly *** games/blue - Support CC/CFLAGS properly - Add WWW: line into pkg/DESCR New file: patches/patch-aa *** games/bs - Add WWW: line into pkg/DESCR *** games/columns - Support CXXFLAGS properly - Support sdl-config *** games/empire - Exclude GPL doc from package - Add WWW: line into pkg/DESCR *** games/freesweep to 0.87 - Update to version 0.87 *** games/galaxis - Support CC properly - Add WWW: line into pkg/DESCR *** games/garith - Support CC/CFLAGS properly - Support GTK_CONFIG *** games/gemdropx to 0.7 - Update to version 0.7 *** games/gtkballs - Exclude GPL doc from package - Support GTK_CONFIG *** games/icbm3d - Update WWW: line of pkg/DESCR *** games/mirrormagic - Support CC/X11BASE properly *** games/phalanx to 22 - Update to version 22 - Add WWW: line into pkg/DESCR *** games/spellcast - Update MASTER_SITES and WWW: line of pkg/DESCR - Support CFLAGS properly - Exclude GPL doc from package *** games/starlanes - Support CC properly - Exclude GPL doc from package *** games/xdigger to 1.0.10 - Update to version 1.0.10 New file: patches/patch-ad patches/patch-ae *** games/xtron - Support PREFIX properly - Exclude GPL doc from package *** games/xtruco - Support CC/CFLAGS/X11BASE properly *** games/xvier - Support X11BASE properly *** PR: 17741 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp>
Diffstat (limited to 'games/garith/Makefile')
-rw-r--r--games/garith/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/games/garith/Makefile b/games/garith/Makefile
index 75ac9ca8029..7a5113f6bab 100644
--- a/games/garith/Makefile
+++ b/games/garith/Makefile
@@ -12,18 +12,21 @@ MASTER_SITES= http://www.cnm-vra.com/micah/garith/
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= gdk12.2:${PORTSDIR}/x11-toolkits/gtk12
+LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
-ALL_TARGET=
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+
+ALL_TARGET= # empty
USE_X_PREFIX= yes
+MAKE_ENV= GTK_CONFIG="${GTK_CONFIG}"
WRKSRC= ${WRKDIR}/garith
do-install:
- @ ${INSTALL_PROGRAM} ${WRKSRC}/garith ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/garith ${PREFIX}/bin
.if !defined(NOPORTDOCS)
- @ ${MKDIR} ${PREFIX}/share/doc/garith
+ @${MKDIR} ${PREFIX}/share/doc/garith
.for file in BUGS COPYING HISTORY README TODO
- @ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/garith
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/garith
.endfor
.endif