aboutsummaryrefslogtreecommitdiffstats
path: root/games/gnocatan
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2000-09-02 02:21:24 +0800
committerade <ade@FreeBSD.org>2000-09-02 02:21:24 +0800
commit26f2c645bce203260251585648a2cc51922508cf (patch)
treed78fc659e684e2337983a63e2847a8dcdd8b46cb /games/gnocatan
parentb710a3f95d0f17b690de7a610609a5975896eb59 (diff)
downloadfreebsd-ports-graphics-26f2c645bce203260251585648a2cc51922508cf.tar.gz
freebsd-ports-graphics-26f2c645bce203260251585648a2cc51922508cf.tar.zst
freebsd-ports-graphics-26f2c645bce203260251585648a2cc51922508cf.zip
GNOME cleanups
Diffstat (limited to 'games/gnocatan')
-rw-r--r--games/gnocatan/Makefile7
-rw-r--r--games/gnocatan/files/patch-aa20
2 files changed, 9 insertions, 18 deletions
diff --git a/games/gnocatan/Makefile b/games/gnocatan/Makefile
index 376ed1c8b00..6453457c3e3 100644
--- a/games/gnocatan/Makefile
+++ b/games/gnocatan/Makefile
@@ -28,4 +28,11 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GTK_CONFIG="${GTK_CONFIG}" \
LIBS="-L${LOCALBASE}/lib"
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
.include <bsd.port.mk>
diff --git a/games/gnocatan/files/patch-aa b/games/gnocatan/files/patch-aa
index 46731c9e549..ac13f43362b 100644
--- a/games/gnocatan/files/patch-aa
+++ b/games/gnocatan/files/patch-aa
@@ -1,23 +1,7 @@
--- client/Makefile.in.orig Sun Jun 18 19:05:24 2000
-+++ client/Makefile.in Thu Jun 22 13:49:47 2000
-@@ -101,9 +101,9 @@
-
- pixmapdir = $(datadir)/pixmaps/gnocatan
- appicondir = $(datadir)/pixmaps
--Gamesdir = $(datadir)/gnome/apps/Games
-+Gamesdir = $(datadir)/apps/Games
++++ client/Makefile.in Fri Sep 1 11:57:51 2000
+@@ -105,3 +105,3 @@
-SUBDIRS = help
+SUBDIRS = # help
- bin_PROGRAMS = gnocatan
-
-@@ -115,7 +115,7 @@
- @ADMIN_GTK_SUPPORT_TRUE@ADMIN_GTK_FILES_INACTIVE =
- @ADMIN_GTK_SUPPORT_FALSE@ADMIN_GTK_FILES_INACTIVE = admin-gtk.c
-
--INCLUDES = -I$(srcdir)/../common -I. -DGNOMELOCALEDIR=\""$(datadir)/locale"\" $(ADMIN_GTK) -I$(includedir) $(GNOME_INCLUDEDIR)
-+INCLUDES = -I$(srcdir)/../common -I. -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" $(ADMIN_GTK) -I$(includedir) $(GNOME_INCLUDEDIR)
-
-
- EXTRA_gnocatan_SOURCES = $(ADMIN_GTK_FILES_INACTIVE)