aboutsummaryrefslogtreecommitdiffstats
path: root/games/gnomegames2/Makefile
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>1999-05-30 12:02:08 +0800
committersteve <steve@FreeBSD.org>1999-05-30 12:02:08 +0800
commit30258963d7a5fa0cc68822a3e6754dcb2ed9c1dc (patch)
tree728532fef2f7db62aba2d92edc77dbccafd510ab /games/gnomegames2/Makefile
parentaafb9e645384cfe8ffd4e08ce7860a9f2e1a523d (diff)
downloadfreebsd-ports-graphics-30258963d7a5fa0cc68822a3e6754dcb2ed9c1dc.tar.gz
freebsd-ports-graphics-30258963d7a5fa0cc68822a3e6754dcb2ed9c1dc.tar.zst
freebsd-ports-graphics-30258963d7a5fa0cc68822a3e6754dcb2ed9c1dc.zip
Use new gnome libs and set USE_LIBTOOL=yes.
PR: 11844 Submitted by: Jeremy Lea <reg@shale.csir.co.za>
Diffstat (limited to 'games/gnomegames2/Makefile')
-rw-r--r--games/gnomegames2/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/games/gnomegames2/Makefile b/games/gnomegames2/Makefile
index a49329c950a..834fdf287a9 100644
--- a/games/gnomegames2/Makefile
+++ b/games/gnomegames2/Makefile
@@ -3,7 +3,7 @@
# Date created: 03 July 1998
# Whom: Yukihiro Nakai <Nakai@technologist.com>
#
-# $Id: Makefile,v 1.15 1999/04/08 18:08:32 steve Exp $
+# $Id: Makefile,v 1.16 1999/05/09 17:06:20 steve Exp $
#
DISTNAME= gnome-games-1.0.2
@@ -17,17 +17,16 @@ MAINTAINER= nacai@iname.com
BUILD_DEPENDS= panel:${PORTSDIR}/x11/gnomecore
RUN_DEPENDS= panel:${PORTSDIR}/x11/gnomecore
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+
USE_X_PREFIX= yes
USE_GMAKE= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
--datadir=${PREFIX}/share/gnome \
- --with-gnome=${X11BASE}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
- GTK_CONFIG="${X11BASE}/bin/gtk12-config" \
- LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lxpg4"
-
-post-install:
- @${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
+ --with-gnome=${PREFIX}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ LIBS="-L${LOCALBASE}/lib"
.include <bsd.port.mk>