aboutsummaryrefslogtreecommitdiffstats
path: root/games/lianliankan
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-04-29 21:18:41 +0800
committerpav <pav@FreeBSD.org>2006-04-29 21:18:41 +0800
commit1c5b898f79f96f34f782a9105818addfa710ff9f (patch)
treeb1ed744a73d4b5e304f9cde8d08b614e6b7712c1 /games/lianliankan
parentc61b15bedc7254343e769077a3ea1680b0b09283 (diff)
downloadfreebsd-ports-graphics-1c5b898f79f96f34f782a9105818addfa710ff9f.tar.gz
freebsd-ports-graphics-1c5b898f79f96f34f782a9105818addfa710ff9f.tar.zst
freebsd-ports-graphics-1c5b898f79f96f34f782a9105818addfa710ff9f.zip
LianLianKan is a scarce recreation game. Game playing is very simple,
first you are required to choose a pair of same pattern links, but the path of links appeared can not exceed twice turns, after links keep away from other patterns. Only can enter next one when you fulfill task. The difficulty of game can be divided into three levels. WWW: http://sourceforge.net/projects/llk-linux PR: ports/96366 Submitted by: Liu.Yinghong <liu_yinghong@yahoo.com.cn>
Diffstat (limited to 'games/lianliankan')
-rw-r--r--games/lianliankan/Makefile30
-rw-r--r--games/lianliankan/distinfo3
-rw-r--r--games/lianliankan/files/lianliankan.desktop11
-rw-r--r--games/lianliankan/files/patch-Makefile.in11
-rw-r--r--games/lianliankan/files/patch-src_pak_pak.c41
-rw-r--r--games/lianliankan/pkg-descr7
-rw-r--r--games/lianliankan/pkg-plist24
7 files changed, 127 insertions, 0 deletions
diff --git a/games/lianliankan/Makefile b/games/lianliankan/Makefile
new file mode 100644
index 00000000000..54eb149bcf7
--- /dev/null
+++ b/games/lianliankan/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: lianliankan
+# Date created: 26 April 2006
+# Whom: Liu.Yinghong <liu_yinghong@yahoo.com.cn>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lianliankan
+PORTVERSION= 2.2
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= llk-linux
+DISTNAME= llk_linux-${PORTVERSION}
+
+MAINTAINER= liu_yinghong@yahoo.com.cn
+COMMENT= A scarce recreation game
+
+USE_GNOME= gtk20 esound
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+post-install:
+ ${MKDIR} ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${FILESDIR}/lianliankan.desktop ${PREFIX}/share/applications
+
+.include <bsd.port.mk>
diff --git a/games/lianliankan/distinfo b/games/lianliankan/distinfo
new file mode 100644
index 00000000000..e5cbe1b71b1
--- /dev/null
+++ b/games/lianliankan/distinfo
@@ -0,0 +1,3 @@
+MD5 (llk_linux-2.2.tar.gz) = b3a6408e4024e9e2d26b8f71684a4576
+SHA256 (llk_linux-2.2.tar.gz) = 2e906a2ecf4154cbeb3e994defecca0d7627240494aa34b4e216e8483e855e3a
+SIZE (llk_linux-2.2.tar.gz) = 3251973
diff --git a/games/lianliankan/files/lianliankan.desktop b/games/lianliankan/files/lianliankan.desktop
new file mode 100644
index 00000000000..ad0c6816d61
--- /dev/null
+++ b/games/lianliankan/files/lianliankan.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=lianiankan
+Name[zh_CN]=连连看
+Comment=Choose a pair of same pattern links.
+Comment[zh_TW]=选择一对相同的牌联机
+Exec=llk_linux
+Icon=llk_linux.png
+Terminal=false
+Type=Application
+Categories=GNOME;Application;Game;PuzzleGame;
diff --git a/games/lianliankan/files/patch-Makefile.in b/games/lianliankan/files/patch-Makefile.in
new file mode 100644
index 00000000000..94b43c2977a
--- /dev/null
+++ b/games/lianliankan/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Mon Apr 3 22:53:12 2006
++++ Makefile.in Mon Apr 3 22:54:11 2006
+@@ -213,7 +213,7 @@
+ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
+ SUBDIRS = po src pixmaps data
+-llk_linuxdocdir = ${prefix}/doc/llk_linux
++llk_linuxdocdir = $(PACKAGE_DATA_DIR)/doc/llk_linux
+ llk_linuxdoc_DATA = \
+ README\
+ COPYING\
diff --git a/games/lianliankan/files/patch-src_pak_pak.c b/games/lianliankan/files/patch-src_pak_pak.c
new file mode 100644
index 00000000000..ad2491d4c86
--- /dev/null
+++ b/games/lianliankan/files/patch-src_pak_pak.c
@@ -0,0 +1,41 @@
+--- src/pak/pak.c.orig Mon Apr 3 21:41:15 2006
++++ src/pak/pak.c Mon Apr 3 21:45:37 2006
+@@ -249,11 +249,7 @@
+
+ /* Set the position in the PAK file for this file to be written at */
+ /* If not GNU system,this should be Pos = Current->dwOffset */
+-#ifdef WIN32
+- Pos = Current->dwOffset;
+-#else
+- Pos.__pos = Current->dwOffset;
+-#endif
++ Pos = Current->dwOffset;
+ fsetpos( PAKStream, &Pos );
+
+ /* Read in the file a byte at a time, encrypt it and write to PAK */
+@@ -410,11 +406,7 @@
+ /* Set the offset in PAK to the beginning of this particular file
+ to be extracted */
+ /* If not GNU system,this should be Pos = Current->dwOffset */
+-#ifdef WIN32
+- Pos = Current->dwOffset;
+-#else
+- Pos.__pos = Current->dwOffset;
+-#endif
++ Pos = Current->dwOffset;
+ fsetpos( ReadStream, &Pos );
+
+ /* Loop through the file by it's size and read from the PAK
+@@ -488,11 +480,7 @@
+ /* Set the offset in PAK to the beginning of this particular file
+ to be extracted */
+ /* If not GNU system,this should be Pos = Current->dwOffset */
+-#ifdef WIN32
+- Pos = Current->dwOffset;
+-#else
+- Pos.__pos = Current->dwOffset;
+-#endif
++ Pos = Current->dwOffset;
+ fsetpos( ReadStream, &Pos );
+
+ /* Loop through the file by it's size and read from the PAK
diff --git a/games/lianliankan/pkg-descr b/games/lianliankan/pkg-descr
new file mode 100644
index 00000000000..c1aa3f6c91f
--- /dev/null
+++ b/games/lianliankan/pkg-descr
@@ -0,0 +1,7 @@
+LianLianKan is a scarce recreation game. Game playing is very simple,
+first you are required to choose a pair of same pattern links, but
+the path of links appeared can not exceed twice turns, after links
+keep away from other patterns. Only can enter next one when you fulfill task.
+The difficulty of game can be divided into three levels.
+
+WWW: http://sourceforge.net/projects/llk-linux
diff --git a/games/lianliankan/pkg-plist b/games/lianliankan/pkg-plist
new file mode 100644
index 00000000000..bda76bf4934
--- /dev/null
+++ b/games/lianliankan/pkg-plist
@@ -0,0 +1,24 @@
+bin/llk_linux
+share/applications/lianliankan.desktop
+share/doc/llk_linux/AUTHORS
+share/doc/llk_linux/COPYING
+share/doc/llk_linux/ChangeLog
+share/doc/llk_linux/INSTALL
+share/doc/llk_linux/NEWS
+share/doc/llk_linux/README
+share/doc/llk_linux/TODO
+share/llk_linux/Cancle.wav
+share/llk_linux/CanntLink.wav
+share/llk_linux/Classical.pak
+share/llk_linux/Click.wav
+share/llk_linux/GameOver.wav
+share/llk_linux/Hint.wav
+share/llk_linux/Link.wav
+share/llk_linux/QQ.pak
+share/llk_linux/Shuffle.wav
+share/llk_linux/Win.wav
+share/locale/zh_CN/LC_MESSAGES/llk_linux.mo
+share/pixmaps/llk_linux.png
+@dirrm share/llk_linux
+@dirrm share/doc/llk_linux
+@dirrmtry share/applications