aboutsummaryrefslogtreecommitdiffstats
path: root/games/linux-nwserver/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-02-03 16:49:22 +0800
committeredwin <edwin@FreeBSD.org>2003-02-03 16:49:22 +0800
commit89763eda2ba604f4df8e43e075923583783bbafb (patch)
tree9162ca4ca8917199041da6d7b741050afb4b37bd /games/linux-nwserver/Makefile
parentf1f255832c4fd676ebfc54ee90177f9b1c82c0ab (diff)
downloadfreebsd-ports-graphics-89763eda2ba604f4df8e43e075923583783bbafb.tar.gz
freebsd-ports-graphics-89763eda2ba604f4df8e43e075923583783bbafb.tar.zst
freebsd-ports-graphics-89763eda2ba604f4df8e43e075923583783bbafb.zip
New port: games/linux-nwserver
This package contains Neverwinter Nights Linux Dedicated Server, that could run under FreeBSD. Additionally you will need original game data, which should be installed manually. PR: ports/40914 Submitted by: Igor Pokrovsky <tiamat@telegraph.spb.ru>
Diffstat (limited to 'games/linux-nwserver/Makefile')
-rw-r--r--games/linux-nwserver/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/games/linux-nwserver/Makefile b/games/linux-nwserver/Makefile
new file mode 100644
index 00000000000..1baa08e00aa
--- /dev/null
+++ b/games/linux-nwserver/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: linux-nwserver
+# Date created: 22 July 2002
+# Whom: Igor Pokrovsky <tiamat@telegraph.spb.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= linux-nwserver
+PORTVERSION= 1.21
+CATEGORIES= games linux
+MASTER_SITES= http://nwdownloads.bioware.com/neverwinternights/linux/121/
+DISTNAME= linuxserver
+
+MAINTAINER= tiamat@telegraph.spb.ru
+
+USE_LINUX= yes
+NO_BUILD= yes
+ONLY_FOR_ARCHS= i386
+
+# Linux binary should not be stripped by INSTALL_PROGRAM
+# because as a side effect it brands the binary as FreeBSD.
+STRIP=
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKDIR}/fixinstall ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKDIR}/nwserver ${PREFIX}/bin
+
+.ifndef (NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/readme.linuxserver.txt ${DOCSDIR}
+.endif
+
+post-install:
+ @${ECHO} "*******************************************************************************"
+ @${ECHO} "Neverwinter Nights Dedicated Server requires original game data to run."
+ @${ECHO} "Consult ${DOCSDIR}/readme.linuxserver.txt"
+ @${ECHO} "for more information about required data directories."
+ @${ECHO} "From directory, where you will have installed game data you can run:"
+ @${ECHO} "${PREFIX}/bin/fixinstall - to check installation (FAILED nwserver is ok)"
+ @${ECHO} "and ${PREFIX}/bin/nwserver - to start server"
+ @${ECHO} "*******************************************************************************"
+
+.include <bsd.port.mk>