aboutsummaryrefslogtreecommitdiffstats
path: root/games/prboom
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2012-02-20 22:25:13 +0800
committerswills <swills@FreeBSD.org>2012-02-20 22:25:13 +0800
commitc8875536cd4b68affed818e8c27577cb25ea43b0 (patch)
tree0042bdc30d1a1fc0524a4325ae56367555fa03cf /games/prboom
parent5e15ab1bfbe367cb5ee3cfbcd890bfa62fde07e9 (diff)
downloadfreebsd-ports-graphics-c8875536cd4b68affed818e8c27577cb25ea43b0.tar.gz
freebsd-ports-graphics-c8875536cd4b68affed818e8c27577cb25ea43b0.tar.zst
freebsd-ports-graphics-c8875536cd4b68affed818e8c27577cb25ea43b0.zip
- Fix build with new png
Submitted by: avg
Diffstat (limited to 'games/prboom')
-rw-r--r--games/prboom/Makefile2
-rw-r--r--games/prboom/files/patch-i_sshot.c20
2 files changed, 21 insertions, 1 deletions
diff --git a/games/prboom/Makefile b/games/prboom/Makefile
index b10fbf25a80..178ec16032d 100644
--- a/games/prboom/Makefile
+++ b/games/prboom/Makefile
@@ -7,7 +7,7 @@
PORTNAME= prboom
PORTVERSION= 2.5.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20stable/${PORTVERSION}
diff --git a/games/prboom/files/patch-i_sshot.c b/games/prboom/files/patch-i_sshot.c
new file mode 100644
index 00000000000..b4e7485740a
--- /dev/null
+++ b/games/prboom/files/patch-i_sshot.c
@@ -0,0 +1,20 @@
+--- src/SDL/i_sshot.c.orig 2010-05-19 13:40:36.506099313 +0300
++++ src/SDL/i_sshot.c 2010-05-19 13:41:50.837973800 +0300
+@@ -231,7 +231,7 @@
+ if (fp)
+ {
+ png_struct *png_ptr = png_create_write_struct(
+- PNG_LIBPNG_VER_STRING, png_error_ptr_NULL, error_fn, warning_fn);
++ PNG_LIBPNG_VER_STRING, NULL, error_fn, warning_fn);
+
+ if (png_ptr)
+ {
+@@ -279,7 +279,7 @@
+ break;
+ }
+ }
+- png_destroy_write_struct(&png_ptr, png_infopp_NULL);
++ png_destroy_write_struct(&png_ptr, NULL);
+ }
+ fclose(fp);
+ }