aboutsummaryrefslogtreecommitdiffstats
path: root/games/seabattle/files
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>1998-03-27 20:08:01 +0800
committertg <tg@FreeBSD.org>1998-03-27 20:08:01 +0800
commit14ce6ba390c2d32b7333653ff77b94b9bf678c35 (patch)
tree1af93387c03d506b299f27aeee1b7740abce457e /games/seabattle/files
parenta6741390a75bd0c66a949b66869591cd927f8947 (diff)
downloadfreebsd-ports-graphics-14ce6ba390c2d32b7333653ff77b94b9bf678c35.tar.gz
freebsd-ports-graphics-14ce6ba390c2d32b7333653ff77b94b9bf678c35.tar.zst
freebsd-ports-graphics-14ce6ba390c2d32b7333653ff77b94b9bf678c35.zip
Import seabattle port. This version comes with sound support.
PR: 4820 Submitted by: Andrey Zakhvatov <andy@icc.surw.chel.su>
Diffstat (limited to 'games/seabattle/files')
-rw-r--r--games/seabattle/files/patch-aa28
-rw-r--r--games/seabattle/files/patch-ab19
-rw-r--r--games/seabattle/files/patch-ac55
-rw-r--r--games/seabattle/files/patch-ad35
4 files changed, 137 insertions, 0 deletions
diff --git a/games/seabattle/files/patch-aa b/games/seabattle/files/patch-aa
new file mode 100644
index 00000000000..7142b444338
--- /dev/null
+++ b/games/seabattle/files/patch-aa
@@ -0,0 +1,28 @@
+*** Makefile Tue May 13 17:53:34 1997
+--- /home/andy/tmp/wrk/Makefile Mon Jun 30 14:43:45 1997
+***************
+*** 17,28 ****
+ #C_OPTS =
+ #L_OPTS = -lcurses
+
+! #On Linux, uncomment the following
+ #
+! PLATFORM = Linux
+! C_OPTS = -O2 -Wall
+ L_OPTS = -lncurses
+-
+
+ #For Dos/Windows DJGPP (you need the curses lib)
+ #PLATFORM = DOS_DJGPP
+--- 17,27 ----
+ #C_OPTS =
+ #L_OPTS = -lcurses
+
+! #On FreeBSD/Linux, uncomment the following
+ #
+! PLATFORM = FreeBSD/Linux
+! C_OPTS = ${CFLAGS} -DPREFIX=\"${PREFIX}\"
+ L_OPTS = -lncurses
+
+ #For Dos/Windows DJGPP (you need the curses lib)
+ #PLATFORM = DOS_DJGPP
diff --git a/games/seabattle/files/patch-ab b/games/seabattle/files/patch-ab
new file mode 100644
index 00000000000..c64ebe46740
--- /dev/null
+++ b/games/seabattle/files/patch-ab
@@ -0,0 +1,19 @@
+*** batt.h Tue May 13 19:58:17 1997
+--- /home/andy/tmp/wrk/batt.h Mon Jun 30 14:41:02 1997
+***************
+*** 2,8 ****
+ * batt.h Part of the SEABATTLE game by Vince Weaver *
+ ************************************************************************/
+
+! #include <curses.h> /* Slang support is good for rxvt in linux */
+ #include <stdio.h>
+ #include <ctype.h>
+ #include <stdlib.h>
+--- 2,8 ----
+ * batt.h Part of the SEABATTLE game by Vince Weaver *
+ ************************************************************************/
+
+! #include <ncurses.h> /* Slang support is good for rxvt in linux */
+ #include <stdio.h>
+ #include <ctype.h>
+ #include <stdlib.h>
diff --git a/games/seabattle/files/patch-ac b/games/seabattle/files/patch-ac
new file mode 100644
index 00000000000..d10e66458e9
--- /dev/null
+++ b/games/seabattle/files/patch-ac
@@ -0,0 +1,55 @@
+*** bdb.c Tue May 13 19:49:59 1997
+--- /home/andy/tmp/wrk/bdb.c Mon Jun 30 14:41:23 1997
+***************
+*** 325,332 ****
+ char names[10][100],text[100];
+ int ch,scores[10],i;
+ /* If not there, create one */
+! if( (fff=fopen("hiscore.sea","r+"))==NULL ){
+! if ( (fff=fopen("hiscore.sea","a+"))!=NULL) {
+ fprintf(fff,"Vince\n50\nMarie\n55\nJohn\n56\n");
+ fprintf(fff,"Gus\n57\nLizann\n58\nKevin\n59\n");
+ fprintf(fff,"Hal\n60\nHairold\n61\nChipper\n62\nBob\n63\n");
+--- 325,332 ----
+ char names[10][100],text[100];
+ int ch,scores[10],i;
+ /* If not there, create one */
+! if( (fff=fopen(PREFIX "/share/seabattle/hiscore.sea","r+"))==NULL ){
+! if ( (fff=fopen(PREFIX "/share/seabattle/hiscore.sea","a+"))!=NULL) {
+ fprintf(fff,"Vince\n50\nMarie\n55\nJohn\n56\n");
+ fprintf(fff,"Gus\n57\nLizann\n58\nKevin\n59\n");
+ fprintf(fff,"Hal\n60\nHairold\n61\nChipper\n62\nBob\n63\n");
+***************
+*** 335,341 ****
+ }
+ else fclose(fff);
+
+! if ( (fff=fopen("hiscore.sea","r"))!=NULL) {
+ for(i=0;i<10;i++)
+ fscanf(fff,"%s%i",names[i],&scores[i]);
+ fclose(fff);
+--- 335,341 ----
+ }
+ else fclose(fff);
+
+! if ( (fff=fopen(PREFIX "/share/seabattle/hiscore.sea","r"))!=NULL) {
+ for(i=0;i<10;i++)
+ fscanf(fff,"%s%i",names[i],&scores[i]);
+ fclose(fff);
+***************
+*** 355,361 ****
+ set_color(C_WHITE,C_BOLD);
+ sprintf(text,"%s got a new High Score, #%i",name,i+1);
+ printxy(20,1,text);
+! if ( (fff=fopen("hiscore.sea","w+"))!=NULL) {
+ for(i=0;i<10;i++) fprintf(fff,"%s\n%i",names[i],scores[i]);
+ fclose(fff);
+ }
+--- 355,361 ----
+ set_color(C_WHITE,C_BOLD);
+ sprintf(text,"%s got a new High Score, #%i",name,i+1);
+ printxy(20,1,text);
+! if ( (fff=fopen(PREFIX "/share/seabattle/hiscore.sea","w+"))!=NULL) {
+ for(i=0;i<10;i++) fprintf(fff,"%s\n%i",names[i],scores[i]);
+ fclose(fff);
+ }
diff --git a/games/seabattle/files/patch-ad b/games/seabattle/files/patch-ad
new file mode 100644
index 00000000000..9af20bc7223
--- /dev/null
+++ b/games/seabattle/files/patch-ad
@@ -0,0 +1,35 @@
+*** binp.c Tue May 13 17:51:00 1997
+--- /home/andy/tmp/wrk/binp.c Mon Jun 30 14:41:38 1997
+***************
+*** 129,143 ****
+ /* Incomplete as of yet */
+ if (which_one==1)
+ if (sound_device)
+! if(rand()%2) system("cat hit1.au > /dev/audio ");
+! else system("cat hit2.au > /dev/audio ");
+ else beep();
+ if (which_one==2)
+ if (sound_device)
+! if(rand()%2) system("cat miss1.au > /dev/audio ");
+! else system("cat miss2.au > /dev/audio ");
+ if (which_one==3)
+! if (sound_device) system("cat sunkit.au > /dev/audio ");
+ else beep();
+ }
+
+--- 129,143 ----
+ /* Incomplete as of yet */
+ if (which_one==1)
+ if (sound_device)
+! if(rand()%2) system("cat " PREFIX "/share/seabattle/hit1.au > /dev/audio ");
+! else system("cat " PREFIX "/share/seabattle/hit2.au > /dev/audio ");
+ else beep();
+ if (which_one==2)
+ if (sound_device)
+! if(rand()%2) system("cat " PREFIX "/share/seabattle/miss1.au > /dev/audio ");
+! else system("cat " PREFIX "/share/seabattle/miss2.au > /dev/audio ");
+ if (which_one==3)
+! if (sound_device) system("cat " PREFIX "/share/seabattle/sunkit.au > /dev/audio ");
+ else beep();
+ }
+